MozillaFirefox/MozillaFirefox.spec
branchfirefox68
changeset 1098 538cbf0bbdca
parent 1097 840132a4a9b3
child 1099 8a3c73e74e65
equal deleted inserted replaced
1097:840132a4a9b3 1098:538cbf0bbdca
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          68
    21 %define major          68
    22 %define mainver        %major.0
    22 %define mainver        %major.0.2
    23 %define orig_version   68.0
    23 %define orig_version   68.0.2
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20190705220548
    27 %define releasedate    20190813150448
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # always build with GCC as SUSE Security Team requires that
    30 # always build with GCC as SUSE Security Team requires that
    31 %define clang_build 0
    31 %define clang_build 0
    32 
    32 
   346 export CFLAGS="$CFLAGS -mminimal-toc"
   346 export CFLAGS="$CFLAGS -mminimal-toc"
   347 %endif
   347 %endif
   348 %endif
   348 %endif
   349 export CXXFLAGS="$CFLAGS"
   349 export CXXFLAGS="$CFLAGS"
   350 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   350 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   351 %limit_build -m 1500
   351 %limit_build -m 2000
   352 cat << EOF > $MOZCONFIG
   352 cat << EOF > $MOZCONFIG
   353 mk_add_options MOZILLA_OFFICIAL=1
   353 mk_add_options MOZILLA_OFFICIAL=1
   354 mk_add_options BUILD_OFFICIAL=1
   354 mk_add_options BUILD_OFFICIAL=1
   355 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   355 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   356 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   356 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   368 ac_add_options --disable-debug-symbols
   368 ac_add_options --disable-debug-symbols
   369 %else
   369 %else
   370 ac_add_options --enable-debug-symbols
   370 ac_add_options --enable-debug-symbols
   371 %endif
   371 %endif
   372 %if 0%{?suse_version} > 1549
   372 %if 0%{?suse_version} > 1549
   373 %ifnarch aarch64 ppc64 ppc64le
   373 %ifnarch aarch64 ppc64 ppc64le s390x
   374 ac_add_options --disable-elf-hack
   374 ac_add_options --disable-elf-hack
   375 %endif
   375 %endif
   376 %endif
   376 %endif
   377 ac_add_options --with-system-nspr
   377 ac_add_options --with-system-nspr
   378 ac_add_options --with-system-nss
   378 ac_add_options --with-system-nss
   409 ac_add_options --with-arch=armv7-a
   409 ac_add_options --with-arch=armv7-a
   410 %endif
   410 %endif
   411 %endif
   411 %endif
   412 %ifarch aarch64 %arm s390x
   412 %ifarch aarch64 %arm s390x
   413 ac_add_options --disable-webrtc
   413 ac_add_options --disable-webrtc
       
   414 %endif
       
   415 # mitigation/workaround for bmo#1512162
       
   416 %ifarch ppc64le
       
   417 ac_add_options --enable-optimize="-O1"
   414 %endif
   418 %endif
   415 %ifarch x86_64
   419 %ifarch x86_64
   416 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
   420 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
   417 %if 0%{?suse_version} > 1500
   421 %if 0%{?suse_version} > 1500
   418 ac_add_options --enable-lto
   422 ac_add_options --enable-lto
   447 # install additional locales
   451 # install additional locales
   448 %if %localize
   452 %if %localize
   449 mkdir -p %{buildroot}%{progdir}/browser/extensions
   453 mkdir -p %{buildroot}%{progdir}/browser/extensions
   450 truncate -s 0 %{_tmppath}/translations.{common,other}
   454 truncate -s 0 %{_tmppath}/translations.{common,other}
   451 sed -r '/^(ja-JP-mac|en-US|)$/d;s/ .*$//' $RPM_BUILD_DIR/%{source_prefix}/browser/locales/shipped-locales \
   455 sed -r '/^(ja-JP-mac|en-US|)$/d;s/ .*$//' $RPM_BUILD_DIR/%{source_prefix}/browser/locales/shipped-locales \
   452     | xargs -P 8 -n 1 -I {} /bin/sh -c '
   456     | xargs -n 1 -I {} /bin/sh -c '
   453         locale=$1
   457         locale=$1
   454         pushd $RPM_BUILD_DIR/compare-locales
   458         pushd $RPM_BUILD_DIR/compare-locales
   455         PYTHONPATH=lib \
   459         PYTHONPATH=lib \
   456             scripts/compare-locales -m ../l10n-merged/$locale \
   460             scripts/compare-locales -m ../l10n-merged/$locale \
   457             ../%{source_prefix}/browser/locales/l10n.ini ../l10n $locale
   461             ../%{source_prefix}/browser/locales/l10n.ini ../l10n $locale