MozillaFirefox/MozillaFirefox.spec
branchfirefox60
changeset 1090 554cd9503f75
parent 1080 e8d4a33582b8
child 1091 cbed5671ff47
equal deleted inserted replaced
1080:e8d4a33582b8 1090:554cd9503f75
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
     5 #               2006-2018 Wolfgang Rosenauer
     5 #               2006-2019 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 60
    21 %define major 60
    22 %define mainver %major.4.0
    22 %define mainver %major.5.0
    23 %define update_channel esr
    23 %define update_channel esr
    24 %define branding 1
    24 %define branding 1
    25 %define releasedate 20181203164059
    25 %define releasedate 20190121141556
    26 %define source_prefix firefox-%{mainver}
    26 %define source_prefix firefox-%{mainver}
    27 
    27 
    28 # PIE, full relro (x86_64 for now)
    28 # PIE, full relro (x86_64 for now)
    29 %define build_hardened 1
    29 %define build_hardened 1
    30 
    30 
    71 BuildRequires:  libiw-devel
    71 BuildRequires:  libiw-devel
    72 BuildRequires:  libnotify-devel
    72 BuildRequires:  libnotify-devel
    73 BuildRequires:  libproxy-devel
    73 BuildRequires:  libproxy-devel
    74 BuildRequires:  makeinfo
    74 BuildRequires:  makeinfo
    75 BuildRequires:  mozilla-nspr-devel >= 4.19
    75 BuildRequires:  mozilla-nspr-devel >= 4.19
    76 BuildRequires:  mozilla-nss-devel >= 3.36.6
    76 BuildRequires:  mozilla-nss-devel >= 3.36.7
    77 BuildRequires:  python-devel
    77 BuildRequires:  python-devel
    78 BuildRequires:  python2-xml
    78 BuildRequires:  python2-xml
    79 BuildRequires:  rust >= 1.24
    79 BuildRequires:  rust >= 1.24
    80 BuildRequires:  rust-std
    80 BuildRequires:  rust-std
    81 BuildRequires:  startup-notification-devel
    81 BuildRequires:  startup-notification-devel
   148 # Gecko/Toolkit
   148 # Gecko/Toolkit
   149 Patch1:         mozilla-nongnome-proxies.patch
   149 Patch1:         mozilla-nongnome-proxies.patch
   150 Patch2:         mozilla-kde.patch
   150 Patch2:         mozilla-kde.patch
   151 Patch3:         mozilla-ntlm-full-path.patch
   151 Patch3:         mozilla-ntlm-full-path.patch
   152 Patch4:         mozilla-openaes-decl.patch
   152 Patch4:         mozilla-openaes-decl.patch
   153 Patch5:         mozilla-no-stdcxx-check.patch
       
   154 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   153 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   155 Patch7:         mozilla-aarch64-startup-crash.patch
   154 Patch7:         mozilla-aarch64-startup-crash.patch
   156 Patch8:         mozilla-bmo256180.patch
   155 Patch8:         mozilla-bmo256180.patch
   157 Patch9:         mozilla-i586-DecoderDoctorLogger.patch
   156 Patch9:         mozilla-i586-DecoderDoctorLogger.patch
   158 Patch10:        mozilla-i586-domPrefs.patch
   157 Patch10:        mozilla-i586-domPrefs.patch
   159 Patch11:        mozilla-bmo1464766.patch
   158 Patch11:        mozilla-bmo1464766.patch
   160 Patch13:        mozilla-bmo1375074.patch
   159 Patch13:        mozilla-bmo1375074.patch
   161 Patch14:        mozilla-bmo1436242.patch
   160 Patch14:        mozilla-bmo1436242.patch
       
   161 Patch15:        mozilla-bmo1463035.patch
   162 # Firefox/browser
   162 # Firefox/browser
   163 Patch101:       firefox-kde.patch
   163 Patch101:       firefox-kde.patch
   164 Patch102:       firefox-branded-icons.patch
   164 Patch102:       firefox-branded-icons.patch
   165 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   165 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   166 Requires(post):   coreutils shared-mime-info desktop-file-utils
   166 Requires(post):   coreutils shared-mime-info desktop-file-utils
   260 cd $RPM_BUILD_DIR/%{source_prefix}
   260 cd $RPM_BUILD_DIR/%{source_prefix}
   261 %patch1 -p1
   261 %patch1 -p1
   262 %patch2 -p1
   262 %patch2 -p1
   263 %patch3 -p1
   263 %patch3 -p1
   264 %patch4 -p1
   264 %patch4 -p1
   265 %patch5 -p1
       
   266 %ifarch %ix86
   265 %ifarch %ix86
   267 %patch6 -p1
   266 %patch6 -p1
   268 %endif
   267 %endif
   269 %patch7 -p1
   268 %patch7 -p1
   270 %patch8 -p1
   269 %patch8 -p1
   273 %patch10 -p1
   272 %patch10 -p1
   274 %endif
   273 %endif
   275 %patch11 -p1
   274 %patch11 -p1
   276 %patch13 -p1
   275 %patch13 -p1
   277 %patch14 -p1
   276 %patch14 -p1
       
   277 %patch15 -p1
   278 # Firefox
   278 # Firefox
   279 %patch101 -p1
   279 %patch101 -p1
   280 %patch102 -p1
   280 %patch102 -p1
   281 
   281 
   282 %build
   282 %build