MozillaFirefox/MozillaFirefox.spec
changeset 1073 63a32fb3b602
parent 1072 84c1339de259
child 1074 4b99400f6d17
equal deleted inserted replaced
1070:18f97bd2c2bf 1073:63a32fb3b602
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          61
    21 %define major          62
    22 %define mainver        %major.99
    22 %define mainver        %major.99
    23 %define orig_version   62.0
    23 %define orig_version   63.0
    24 %define orig_suffix    b20
    24 %define orig_suffix    b14
    25 %define update_channel beta
    25 %define update_channel beta
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20180823143155
    27 %define releasedate    20181011200118
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # PIE, full relro (x86_64 for now)
    30 # PIE, full relro (x86_64 for now)
    31 %define build_hardened 1
    31 %define build_hardened 1
    32 
    32 
   343 %endif
   343 %endif
   344 # gcc7 (boo#104105)
   344 # gcc7 (boo#104105)
   345 %if 0%{?suse_version} > 1320
   345 %if 0%{?suse_version} > 1320
   346 ac_add_options --enable-optimize="-g -O2"
   346 ac_add_options --enable-optimize="-g -O2"
   347 %endif
   347 %endif
   348 %ifarch %ix86 %arm
   348 %ifarch %arm
   349 %if 0%{?suse_version} > 1230
   349 %if 0%{?suse_version} > 1230
   350 ac_add_options --disable-optimize
   350 ac_add_options --disable-optimize
   351 %endif
   351 %endif
       
   352 %endif
       
   353 # bmo#1441155 - Disable the generation of Rust debug symbols on Linux32
       
   354 %ifarch %ix86
       
   355 ac_add_options --disable-debug-symbols
   352 %endif
   356 %endif
   353 %ifarch %arm
   357 %ifarch %arm
   354 ac_add_options --disable-elf-hack
   358 ac_add_options --disable-elf-hack
   355 %endif
   359 %endif
   356 ac_add_options --with-system-nspr
   360 ac_add_options --with-system-nspr