MozillaFirefox/MozillaFirefox.spec
changeset 263 64adf7ca3005
parent 262 b680975515e0
child 264 73231d44ef1f
equal deleted inserted replaced
262:b680975515e0 263:64adf7ca3005
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 %define major 4
    21 %define major 4
    22 %define mainver %major.2
    22 %define mainver %major.2
    23 %define use_xulrunner 1
       
    24 %define xulrunner mozilla-xulrunner22
       
    25 
    23 
    26 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    27 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip fdupes Mesa-devel yasm libproxy-devel
    25 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip fdupes Mesa-devel yasm
    28 %if %suse_version > 1110
    26 %if %suse_version > 1110
    29 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
       
    28 BuildRequires:  libproxy-devel
    30 %else
    29 %else
    31 BuildRequires:  wireless-tools
    30 BuildRequires:  wireless-tools
    32 %endif
    31 %endif
    33 %if 0%{?use_xulrunner}
       
    34 BuildRequires:  %{xulrunner}-devel = 2.2a
       
    35 %else
       
    36 BuildRequires:  mozilla-nspr-devel >= 4.8.6
    32 BuildRequires:  mozilla-nspr-devel >= 4.8.6
    37 BuildRequires:  mozilla-nss-devel >= 3.12.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    38 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    39 %endif
       
    40 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    41 Version:        %{mainver}a
    36 Version:        %{mainver}a
    42 Release:        1
    37 Release:        1
       
    38 %define         releasedate 2011041100
    43 Provides:       web_browser
    39 Provides:       web_browser
    44 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    45 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    46 %define         releasedate 2011041100
    42 # this is needed to match this package with the kde4 helper package without the main package
       
    43 # having a hard requirement on the kde4 package
       
    44 %define kde_helper_version 6
       
    45 Provides:       mozilla-kde4-version = %{kde_helper_version}
    47 Summary:        Mozilla Firefox Web Browser
    46 Summary:        Mozilla Firefox Web Browser
    48 Url:            http://www.mozilla.org/
    47 Url:            http://www.mozilla.org/
    49 Group:          Productivity/Networking/Web/Browsers
    48 Group:          Productivity/Networking/Web/Browsers
    50 Source:         firefox-%{version}-source.tar.bz2
    49 Source:         firefox-%{version}-source.tar.bz2
    51 Source1:        MozillaFirefox.desktop
    50 Source1:        MozillaFirefox.desktop
    52 Source2:        MozillaFirefox-rpmlintrc
    51 Source2:        MozillaFirefox-rpmlintrc
    53 Source3:        mozilla.sh.in
    52 Source3:        mozilla.sh.in
    54 Source4:        find-external-requires.sh
    53 Source4:        find-external-requires.sh
    55 Source5:        firefox.schemas
       
    56 Source6:        kde.js
    54 Source6:        kde.js
    57 Source7:        l10n-%{version}.tar.bz2
    55 Source7:        l10n-%{version}.tar.bz2
    58 Source8:        firefox-mimeinfo.xml
    56 Source8:        firefox-mimeinfo.xml
    59 Source9:        firefox-lockdown.js
       
    60 Source10:       compare-locales.tar.bz2
    57 Source10:       compare-locales.tar.bz2
    61 Source11:       firefox.1
    58 Source11:       firefox.1
    62 Source12:       mozilla-get-app-id
    59 Source12:       mozilla-get-app-id
    63 Source13:       add-plugins.sh.in
    60 Source13:       add-plugins.sh.in
    64 Source14:       create-tar.sh
    61 Source14:       create-tar.sh
    77 Patch30:        firefox-linkorder.patch
    74 Patch30:        firefox-linkorder.patch
    78 Patch31:        firefox-browser-css.patch
    75 Patch31:        firefox-browser-css.patch
    79 Patch32:        firefox-cross-desktop.patch
    76 Patch32:        firefox-cross-desktop.patch
    80 Patch33:        firefox-kde.patch
    77 Patch33:        firefox-kde.patch
    81 Patch34:        firefox-kde-114.patch
    78 Patch34:        firefox-kde-114.patch
    82 Patch35:        firefox-ui-lockdown.patch
       
    83 Patch36:        firefox-no-sync-l10n.patch
    79 Patch36:        firefox-no-sync-l10n.patch
    84 Patch37:        firefox-libxulsdk-locales.patch
       
    85 Patch38:        firefox-no-default-ualocale.patch
    80 Patch38:        firefox-no-default-ualocale.patch
    86 Patch39:        firefox-multilocale-chrome.patch
    81 Patch39:        firefox-multilocale-chrome.patch
    87 Patch40:        firefox-shellservice.patch
    82 Patch40:        firefox-shellservice.patch
    88 Patch41:        firefox-branded-icons.patch
    83 Patch41:        firefox-branded-icons.patch
    89 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    84 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    90 Requires(post):   coreutils shared-mime-info desktop-file-utils
    85 Requires(post):   coreutils shared-mime-info desktop-file-utils
    91 Requires(postun): shared-mime-info desktop-file-utils
    86 Requires(postun): shared-mime-info desktop-file-utils
    92 %if 0%{?use_xulrunner}
       
    93 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
       
    94 %requires_eq    %{xulrunner}
       
    95 %ifarch %ix86
       
    96 Requires:       %{xulrunner}-32bit >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
       
    97 Requires:       %{xulrunner}-32bit = %(rpm -q --queryformat '%{VERSION}' %{xulrunner})
       
    98 %endif
       
    99 %else
       
   100 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
    87 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
   101 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
    88 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
   102 %endif
       
   103 Requires:       %{name}-branding >= 4.0
    89 Requires:       %{name}-branding >= 4.0
   104 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    90 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
   105 %define _use_internal_dependency_generator 0
    91 %define _use_internal_dependency_generator 0
   106 %define __find_requires sh %{SOURCE4}
    92 %define __find_requires sh %{SOURCE4}
   107 %global provfind sh -c "grep -v '.so' | %__find_provides"
    93 %global provfind sh -c "grep -v '.so' | %__find_provides"
   179 #BRAND: Provide three files -
   165 #BRAND: Provide three files -
   180 #BRAND: /usr/lib/firefox/browserconfig.properties that contains the
   166 #BRAND: /usr/lib/firefox/browserconfig.properties that contains the
   181 #BRAND: default homepage and some other default configuration options
   167 #BRAND: default homepage and some other default configuration options
   182 #BRAND: /usr/lib/firefox/defaults/profile/bookmarks.html that contains
   168 #BRAND: /usr/lib/firefox/defaults/profile/bookmarks.html that contains
   183 #BRAND: the list of default bookmarks
   169 #BRAND: the list of default bookmarks
   184 #BRAND: /etc/gconf/schemas/firefox.schemas
       
   185 #BRAND: for mapping some Firefox prefs to gconf
   170 #BRAND: for mapping some Firefox prefs to gconf
   186 #BRAND: It's also possible to create a file
   171 #BRAND: It's also possible to create a file
   187 #BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
   172 #BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
   188 #BRAND: custom preference overrides.
   173 #BRAND: custom preference overrides.
   189 #BRAND: It's also possible to drop files in /usr/lib/firefox/searchplugins
   174 #BRAND: It's also possible to drop files in /usr/lib/firefox/searchplugins
   190 
   175 
   191 %description branding-upstream
   176 %description branding-upstream
   192 This package provides upstream look and feel for MozillaFirefox.
   177 This package provides upstream look and feel for MozillaFirefox.
   193 
   178 
   194 
   179 
   195 %if %crashreporter && !0%{?use_xulrunner}
   180 %if %crashreporter
   196 %package buildsymbols
   181 %package buildsymbols
   197 License:        MPLv1.1 or GPLv2+ or LGPLv2+
   182 License:        MPLv1.1 or GPLv2+ or LGPLv2+
   198 Summary:        Breakpad buildsymbols for %{name}
   183 Summary:        Breakpad buildsymbols for %{name}
   199 Group:          Development/Debug
   184 Group:          Development/Debug
   200 
   185 
   227 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   212 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   228 %endif
   213 %endif
   229 %if %suse_version >= 1140
   214 %if %suse_version >= 1140
   230 %patch34 -p1
   215 %patch34 -p1
   231 %endif
   216 %endif
   232 #%patch35 -p1
       
   233 %patch36 -p1
   217 %patch36 -p1
   234 %patch37 -p1
       
   235 %patch38 -p1
   218 %patch38 -p1
   236 %patch39 -p1
   219 %patch39 -p1
   237 %patch40 -p1
   220 %patch40 -p1
   238 %patch41 -p1
   221 %patch41 -p1
   239 
   222 
   240 %build
   223 %build
   241 %if !0%{?use_xulrunner}
       
   242 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   224 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   243 if test "$kdehelperversion" != %{kde_helper_version}; then
   225 if test "$kdehelperversion" != %{kde_helper_version}; then
   244   echo fix kde helper version in the .spec file
   226   echo fix kde helper version in the .spec file
   245   exit 1
   227   exit 1
   246 fi
   228 fi
   247 %endif
       
   248 export MOZ_BUILD_DATE=%{releasedate}
   229 export MOZ_BUILD_DATE=%{releasedate}
   249 export MOZILLA_OFFICIAL=1
   230 export MOZILLA_OFFICIAL=1
   250 export BUILD_OFFICIAL=1
   231 export BUILD_OFFICIAL=1
   251 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   232 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   252 %ifarch ppc64
   233 %ifarch ppc64
   253 export CFLAGS="$CFLAGS -mminimal-toc"
   234 export CFLAGS="$CFLAGS -mminimal-toc"
   254 %endif
   235 %endif
   255 export CXXFLAGS="$CFLAGS"
   236 export CXXFLAGS="$CFLAGS"
   256 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   237 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   257 SDKDIR=$(pkg-config --variable=sdkdir libxul)
       
   258 cat << EOF > $MOZCONFIG
   238 cat << EOF > $MOZCONFIG
   259 mk_add_options MOZILLA_OFFICIAL=1
   239 mk_add_options MOZILLA_OFFICIAL=1
   260 mk_add_options BUILD_OFFICIAL=1
   240 mk_add_options BUILD_OFFICIAL=1
   261 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   241 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   262 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   242 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   267 ac_add_options --mandir=%{_mandir}
   247 ac_add_options --mandir=%{_mandir}
   268 ac_add_options --includedir=%{_includedir}
   248 ac_add_options --includedir=%{_includedir}
   269 ac_add_options --with-system-nspr
   249 ac_add_options --with-system-nspr
   270 ac_add_options --with-system-nss
   250 ac_add_options --with-system-nss
   271 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   251 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
   272 ac_add_options --with-system-jpeg
   252 #ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
   273 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   253 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   274 ac_add_options --with-system-zlib
   254 ac_add_options --with-system-zlib
   275 ac_add_options --disable-installer
   255 ac_add_options --disable-installer
   276 ac_add_options --disable-updater
   256 ac_add_options --disable-updater
   277 ac_add_options --disable-tests
   257 ac_add_options --disable-tests
   278 ac_add_options --disable-debug
   258 ac_add_options --disable-debug
       
   259 ac_add_options --enable-chrome-format=jar
   279 #ac_add_options --enable-update-channel=beta
   260 #ac_add_options --enable-update-channel=beta
   280 EOF
   261 EOF
   281 %if 0%{?use_xulrunner}
   262 %if %suse_version > 1130
   282 cat << EOF >> $MOZCONFIG
   263 cat << EOF >> $MOZCONFIG
   283 ac_add_options --with-libxul-sdk=$SDKDIR
   264 ac_add_options --disable-gnomevfs
   284 ac_add_options --enable-chrome-format=jar
   265 ac_add_options --enable-gio
   285 EOF
   266 EOF
   286 %endif
   267 %endif
   287 %if %branding
   268 %if %branding
   288 cat << EOF >> $MOZCONFIG
   269 cat << EOF >> $MOZCONFIG
   289 ac_add_options --enable-official-branding
   270 ac_add_options --enable-official-branding
   306 %endif
   287 %endif
   307 make -f client.mk build
   288 make -f client.mk build
   308 
   289 
   309 %install
   290 %install
   310 cd $RPM_BUILD_DIR/obj
   291 cd $RPM_BUILD_DIR/obj
   311 # FIXME (will be needed once lockdown is integrated; needs omni.jar adoption)
   292 rm dist/bin/defaults/pref/firefox-l10n.js
   312 #cp %{SOURCE9} dist/bin/defaults/preferences/lockdown.js
       
   313 rm dist/bin/defaults/preferences/firefox-l10n.js
       
   314 make -C browser/installer STRIP=/bin/true
   293 make -C browser/installer STRIP=/bin/true
   315 # copy tree into RPM_BUILD_ROOT
   294 # copy tree into RPM_BUILD_ROOT
   316 mkdir -p $RPM_BUILD_ROOT/%{progdir}
   295 mkdir -p $RPM_BUILD_ROOT/%{progdir}
   317 cp -rf $RPM_BUILD_DIR/obj/dist/firefox/* $RPM_BUILD_ROOT%{progdir}
   296 cp -rf $RPM_BUILD_DIR/obj/dist/firefox/* $RPM_BUILD_ROOT%{progdir}
   318 mkdir -p $RPM_BUILD_ROOT/%{progdir}/distribution/extensions
   297 mkdir -p $RPM_BUILD_ROOT/%{progdir}/distribution/extensions
   319 # remove some executable permissions
   298 # remove some executable permissions
   320 find $RPM_BUILD_ROOT%{progdir} \
   299 find $RPM_BUILD_ROOT%{progdir} \
   321      -name "*.js" -o -name "*.jsm" -o -name "*.rdf" | xargs chmod a-x
   300      -name "*.js" -o -name "*.jsm" -o -name "*.rdf" | xargs chmod a-x
   322 mkdir -p $RPM_BUILD_ROOT%{progdir}/searchplugins
   301 mkdir -p $RPM_BUILD_ROOT%{progdir}/searchplugins
       
   302 # install add-plugins.sh
       
   303 sed "s:%%PROGDIR:%{progdir}:g" \
       
   304   %{SOURCE13} > $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
       
   305 chmod 755 $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   323 # install additional locales
   306 # install additional locales
   324 %if %localize
   307 %if %localize
   325 rm -f %{_tmppath}/translations.*
   308 rm -f %{_tmppath}/translations.*
   326 touch %{_tmppath}/translations.{common,other}
   309 touch %{_tmppath}/translations.{common,other}
   327 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
   310 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
   392 rm -f $RPM_BUILD_ROOT%{progdir}/README.txt
   375 rm -f $RPM_BUILD_ROOT%{progdir}/README.txt
   393 rm -f $RPM_BUILD_ROOT%{progdir}/old-homepage-default.properties
   376 rm -f $RPM_BUILD_ROOT%{progdir}/old-homepage-default.properties
   394 rm -f $RPM_BUILD_ROOT%{progdir}/run-mozilla.sh
   377 rm -f $RPM_BUILD_ROOT%{progdir}/run-mozilla.sh
   395 rm -f $RPM_BUILD_ROOT%{progdir}/LICENSE
   378 rm -f $RPM_BUILD_ROOT%{progdir}/LICENSE
   396 rm -f $RPM_BUILD_ROOT%{progdir}/precomplete
   379 rm -f $RPM_BUILD_ROOT%{progdir}/precomplete
       
   380 rm -f $RPM_BUILD_ROOT%{progdir}/dictionaries/en-US*
       
   381 rm -f $RPM_BUILD_ROOT%{progdir}/firefox
   397 # devel
   382 # devel
   398 mkdir -p %{buildroot}%{_bindir}
   383 mkdir -p %{buildroot}%{_bindir}
   399 install -m 755 %SOURCE12 %{buildroot}%{_bindir}
   384 install -m 755 %SOURCE12 %{buildroot}%{_bindir}
   400 # inspired by mandriva
   385 # inspired by mandriva
   401 mkdir -p %{buildroot}/etc/rpm
   386 mkdir -p %{buildroot}/etc/rpm
   403 # Macros from %{name} package
   388 # Macros from %{name} package
   404 %%firefox_major              %{major}
   389 %%firefox_major              %{major}
   405 %%firefox_version            %{version}
   390 %%firefox_version            %{version}
   406 %%firefox_mainver            %{mainver}
   391 %%firefox_mainver            %{mainver}
   407 %%firefox_mozillapath        %%{_libdir}/%{progname}
   392 %%firefox_mozillapath        %%{_libdir}/%{progname}
   408 %%firefox_xulrunner          %{xulrunner}
       
   409 %%firefox_xulrunner_version  %(rpm -q --queryformat '%{VERSION}' %{xulrunner})
       
   410 %%firefox_pluginsdir         %%{_libdir}/browser-plugins
   393 %%firefox_pluginsdir         %%{_libdir}/browser-plugins
   411 %%firefox_appid              \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
   394 %%firefox_appid              \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
   412 %%firefox_extdir             %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
   395 %%firefox_extdir             %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
   413 
   396 
   414 %%firefox_ext_install() \
   397 %%firefox_ext_install() \
   424 #       cp "%%1" "$extdir" \
   407 #       cp "%%1" "$extdir" \
   425 #       %%{nil}
   408 #       %%{nil}
   426 # fdupes
   409 # fdupes
   427 %fdupes $RPM_BUILD_ROOT%{progdir}
   410 %fdupes $RPM_BUILD_ROOT%{progdir}
   428 %fdupes $RPM_BUILD_ROOT%{_datadir}
   411 %fdupes $RPM_BUILD_ROOT%{_datadir}
       
   412 # create breakpad debugsymbols
       
   413 %if %crashreporter
       
   414 SYMBOLS_NAME="firefox-%{version}-%{release}.%{_arch}-%{suse_version}-symbols"
       
   415 make buildsymbols \
       
   416   SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
       
   417   SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
       
   418   SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
       
   419 if [ -e dist/*symbols.zip ]; then
       
   420   mkdir -p $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   421   cp dist/*symbols.zip $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   422 fi
       
   423 %endif
   429 
   424 
   430 %clean
   425 %clean
   431 rm -rf $RPM_BUILD_ROOT
   426 rm -rf $RPM_BUILD_ROOT
   432 %if %localize
   427 %if %localize
   433 rm -rf %{_tmppath}/translations.*
   428 rm -rf %{_tmppath}/translations.*
   445 fi
   440 fi
   446 if [ -f usr/bin/update-desktop-database ] ; then
   441 if [ -f usr/bin/update-desktop-database ] ; then
   447   usr/bin/update-desktop-database > /dev/null || :
   442   usr/bin/update-desktop-database > /dev/null || :
   448 fi
   443 fi
   449 %endif
   444 %endif
       
   445 %{progdir}/add-plugins.sh > /dev/null 2>&1
   450 exit 0
   446 exit 0
   451 
   447 
   452 %postun
   448 %postun
   453 %if %suse_version > 1130
   449 %if %suse_version > 1130
   454 %icon_theme_cache_postun
   450 %icon_theme_cache_postun
   462   usr/bin/update-desktop-database > /dev/null || :
   458   usr/bin/update-desktop-database > /dev/null || :
   463 fi
   459 fi
   464 %endif
   460 %endif
   465 exit 0
   461 exit 0
   466 
   462 
       
   463 %posttrans
       
   464 [ -e %{progdir}/add-plugins.sh ] && \
       
   465   %{progdir}/add-plugins.sh > /dev/null 2>&1
       
   466 exit 0
       
   467 
       
   468 %preun
       
   469 rm -f %{progdir}/dictionaries/*
       
   470 exit 0
       
   471 
   467 %files
   472 %files
   468 %defattr(-,root,root)
   473 %defattr(-,root,root)
   469 %dir %{progdir}
   474 %dir %{progdir}
   470 %dir %{progdir}/chrome/
   475 %dir %{progdir}/chrome/
   471 %dir %{progdir}/distribution/
   476 %dir %{progdir}/distribution/
   472 %{progdir}/chrome/browser.*
   477 %{progdir}/chrome/browser.*
       
   478 %{progdir}/chrome/pippki.*
       
   479 %{progdir}/chrome/toolkit.*
   473 %{progdir}/chrome/localized.manifest
   480 %{progdir}/chrome/localized.manifest
   474 %{progdir}/chrome/nonlocalized.manifest
   481 %{progdir}/chrome/nonlocalized.manifest
   475 %{progdir}/chrome/en-US.*
   482 %{progdir}/chrome/en-US.*
   476 %{progdir}/chrome/icons
   483 %{progdir}/chrome/icons
   477 %{progdir}/components/
   484 %{progdir}/components/
   478 %exclude %{progdir}/defaults/profile/bookmarks.html
   485 %exclude %{progdir}/defaults/profile/bookmarks.html
   479 %{progdir}/defaults/
   486 %{progdir}/defaults/
       
   487 %{progdir}/dictionaries/
   480 %dir %{progdir}/extensions/
   488 %dir %{progdir}/extensions/
   481 %{progdir}/distribution/extensions/
   489 %{progdir}/distribution/extensions/
   482 %{progdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   490 %{progdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   483 %{progdir}/icons/
   491 %{progdir}/icons/
   484 %{progdir}/modules/
   492 %{progdir}/modules/
       
   493 %{progdir}/res/
   485 %{progdir}/searchplugins/
   494 %{progdir}/searchplugins/
   486 %attr(755,root,root) %{progdir}/%{progname}.sh
   495 %attr(755,root,root) %{progdir}/%{progname}.sh
   487 %{progdir}/firefox
   496 %{progdir}/Throbber-small.gif
       
   497 %{progdir}/firefox-bin
       
   498 %{progdir}/add-plugins.sh
   488 %{progdir}/application.ini
   499 %{progdir}/application.ini
   489 %{progdir}/blocklist.xml
   500 %{progdir}/blocklist.xml
       
   501 %{progdir}/dependentlibs.list
       
   502 %{progdir}/greprefs.js
       
   503 %{progdir}/*.so
       
   504 %{progdir}/mozilla-xremote-client
       
   505 %{progdir}/platform.ini
       
   506 %{progdir}/plugin-container
   490 %if %crashreporter
   507 %if %crashreporter
   491 %{progdir}/crashreporter-override.ini
   508 %{progdir}/crashreporter-override.ini
       
   509 %{progdir}/crashreporter
       
   510 %{progdir}/crashreporter.ini
   492 %endif
   511 %endif
   493 %{progdir}/chrome.manifest
   512 %{progdir}/chrome.manifest
   494 %{_datadir}/applications/%{desktop_file_name}.desktop
   513 %{_datadir}/applications/%{desktop_file_name}.desktop
   495 %{_datadir}/mime/packages/%{progname}.xml
   514 %{_datadir}/mime/packages/%{progname}.xml
   496 %{_datadir}/pixmaps/firefox*
   515 %{_datadir}/pixmaps/firefox*
   527 %defattr(-,root,root)
   546 %defattr(-,root,root)
   528 %dir %{progdir}
   547 %dir %{progdir}
   529 %dir %{progdir}/defaults/
   548 %dir %{progdir}/defaults/
   530 %{progdir}/defaults/profile/bookmarks.html
   549 %{progdir}/defaults/profile/bookmarks.html
   531 
   550 
       
   551 %if %crashreporter
       
   552 %files buildsymbols
       
   553 %defattr(-,root,root)
       
   554 %{_datadir}/mozilla/*.zip
       
   555 %endif
       
   556 
   532 %changelog
   557 %changelog