MozillaFirefox/MozillaFirefox.spec
branchfirefox60
changeset 1052 7a49806c8dae
parent 1051 87c1625d07e2
child 1053 893fc4d031d6
child 1062 48d794331fce
equal deleted inserted replaced
1051:87c1625d07e2 1052:7a49806c8dae
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 60
    21 %define major 60
    22 %define mainver %major.0.1
    22 %define mainver %major.0.2
    23 %define update_channel release
    23 %define update_channel release
    24 %define branding 1
    24 %define branding 1
    25 %define releasedate 20180516032328
    25 %define releasedate 20180605171542
    26 %define source_prefix firefox-%{mainver}
    26 %define source_prefix firefox-%{mainver}
    27 
    27 
    28 # PIE, full relro (x86_64 for now)
    28 # PIE, full relro (x86_64 for now)
    29 %define build_hardened 1
    29 %define build_hardened 1
    30 
    30 
    56 BuildRequires:  Mesa-devel
    56 BuildRequires:  Mesa-devel
    57 BuildRequires:  alsa-devel
    57 BuildRequires:  alsa-devel
    58 BuildRequires:  autoconf213
    58 BuildRequires:  autoconf213
    59 BuildRequires:  dbus-1-glib-devel
    59 BuildRequires:  dbus-1-glib-devel
    60 BuildRequires:  fdupes
    60 BuildRequires:  fdupes
       
    61 BuildRequires:  memory-constraints
    61 %if 0%{?suse_version} <= 1320
    62 %if 0%{?suse_version} <= 1320
    62 BuildRequires:  gcc7-c++
    63 BuildRequires:  gcc7-c++
    63 %else
    64 %else
    64 BuildRequires:  gcc-c++
    65 BuildRequires:  gcc-c++
    65 %endif
    66 %endif
    70 BuildRequires:  libiw-devel
    71 BuildRequires:  libiw-devel
    71 BuildRequires:  libnotify-devel
    72 BuildRequires:  libnotify-devel
    72 BuildRequires:  libproxy-devel
    73 BuildRequires:  libproxy-devel
    73 BuildRequires:  makeinfo
    74 BuildRequires:  makeinfo
    74 BuildRequires:  mozilla-nspr-devel >= 4.19
    75 BuildRequires:  mozilla-nspr-devel >= 4.19
    75 BuildRequires:  mozilla-nss-devel >= 3.36.1
    76 BuildRequires:  mozilla-nss-devel >= 3.36.4
    76 BuildRequires:  python-devel
    77 BuildRequires:  python-devel
    77 BuildRequires:  python2-xml
    78 BuildRequires:  python2-xml
    78 BuildRequires:  rust >= 1.24
    79 BuildRequires:  rust >= 1.24
    79 BuildRequires:  rust-std
    80 BuildRequires:  rust-std
    80 BuildRequires:  startup-notification-devel
    81 BuildRequires:  startup-notification-devel
   155 Patch8:         mozilla-bmo256180.patch
   156 Patch8:         mozilla-bmo256180.patch
   156 Patch9:         mozilla-i586-DecoderDoctorLogger.patch
   157 Patch9:         mozilla-i586-DecoderDoctorLogger.patch
   157 Patch10:        mozilla-i586-domPrefs.patch
   158 Patch10:        mozilla-i586-domPrefs.patch
   158 Patch11:        mozilla-enable-csd.patch
   159 Patch11:        mozilla-enable-csd.patch
   159 Patch12:        mozilla-fix-skia-aarch64.patch
   160 Patch12:        mozilla-fix-skia-aarch64.patch
       
   161 Patch13:        mozilla-bmo1375074.patch
   160 # Firefox/browser
   162 # Firefox/browser
   161 Patch101:       firefox-kde.patch
   163 Patch101:       firefox-kde.patch
   162 Patch102:       firefox-branded-icons.patch
   164 Patch102:       firefox-branded-icons.patch
   163 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   165 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   164 Requires(post):   coreutils shared-mime-info desktop-file-utils
   166 Requires(post):   coreutils shared-mime-info desktop-file-utils
   270 %patch9 -p1
   272 %patch9 -p1
   271 %patch10 -p1
   273 %patch10 -p1
   272 %endif
   274 %endif
   273 %patch11 -p1
   275 %patch11 -p1
   274 %patch12 -p1
   276 %patch12 -p1
       
   277 %patch13 -p1
   275 # Firefox
   278 # Firefox
   276 %patch101 -p1
   279 %patch101 -p1
   277 %patch102 -p1
   280 %patch102 -p1
   278 
   281 
   279 %build
   282 %build
   303 export CFLAGS="%{optflags} -fno-strict-aliasing"
   306 export CFLAGS="%{optflags} -fno-strict-aliasing"
   304 # boo#986541: add -fno-delete-null-pointer-checks for gcc6
   307 # boo#986541: add -fno-delete-null-pointer-checks for gcc6
   305 %if 0%{?suse_version} > 1320
   308 %if 0%{?suse_version} > 1320
   306 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks"
   309 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks"
   307 %endif
   310 %endif
   308 %ifarch aarch64
       
   309 export CFLAGS="$CFLAGS -ffixed-x28"
       
   310 %endif
       
   311 %ifarch %arm
   311 %ifarch %arm
   312 export CFLAGS="${CFLAGS/-g / }"
   312 export CFLAGS="${CFLAGS/-g / }"
   313 %endif
   313 %endif
   314 %ifarch %arm %ix86
   314 %ifarch %arm %ix86
   315 # Limit RAM usage during link
   315 # Limit RAM usage during link
   326 export CXXFLAGS="$CFLAGS"
   326 export CXXFLAGS="$CFLAGS"
   327 %ifarch %{arm}
   327 %ifarch %{arm}
   328 export RUSTFLAGS="-Cdebuginfo=0"
   328 export RUSTFLAGS="-Cdebuginfo=0"
   329 %endif
   329 %endif
   330 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   330 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
       
   331 %limit_build -m 1500
   331 cat << EOF > $MOZCONFIG
   332 cat << EOF > $MOZCONFIG
   332 mk_add_options MOZILLA_OFFICIAL=1
   333 mk_add_options MOZILLA_OFFICIAL=1
   333 mk_add_options BUILD_OFFICIAL=1
   334 mk_add_options BUILD_OFFICIAL=1
   334 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   335 mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
   335 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
   336 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj