MozillaFirefox/MozillaFirefox.spec
changeset 214 7ba53683584c
parent 213 b2978eba3a92
child 215 b84e98861887
equal deleted inserted replaced
213:b2978eba3a92 214:7ba53683584c
   318 %post
   318 %post
   319 # update mime and desktop database
   319 # update mime and desktop database
   320 if [ -f usr/bin/update-mime-database ] ; then
   320 if [ -f usr/bin/update-mime-database ] ; then
   321   usr/bin/update-mime-database %{_datadir}/mime > /dev/null || :
   321   usr/bin/update-mime-database %{_datadir}/mime > /dev/null || :
   322 fi
   322 fi
   323 %if %suse_version >= 1030
       
   324 if [ -f usr/bin/update-desktop-database ] ; then
   323 if [ -f usr/bin/update-desktop-database ] ; then
   325   usr/bin/update-desktop-database > /dev/null || :
   324   usr/bin/update-desktop-database > /dev/null || :
   326 fi
       
   327 %else
       
   328 if [ -f opt/gnome/bin/update-mime-database ] ; then
       
   329   opt/gnome/bin/update-mime-database > /dev/null || :
       
   330 fi
       
   331 %endif
       
   332 # move plugins to new location
       
   333 if [ "$1" = "2" ]; then
       
   334   if [ -d /opt/MozillaFirefox/%{_lib}/plugins ]; then
       
   335     rm -rf /opt/MozillaFirefox/%{_lib}/plugins/libnullplugin.so
       
   336     cp -fud /opt/MozillaFirefox/%{_lib}/plugins/* %{progdir}/plugins
       
   337     rm -rf /opt/MozillaFirefox/%{_lib}/plugins
       
   338   fi
       
   339 fi
   325 fi
   340 exit 0
   326 exit 0
   341 
   327 
   342 %postun
   328 %postun
   343 if [ -f usr/bin/update-mime-database ] ; then
   329 if [ -f usr/bin/update-mime-database ] ; then
   344   usr/bin/update-mime-database %{_datadir}/mime > /dev/null || :
   330   usr/bin/update-mime-database %{_datadir}/mime > /dev/null || :
   345 fi
   331 fi
   346 %if %suse_version >= 1030
       
   347 if [ -f usr/bin/update-desktop-database ] ; then
   332 if [ -f usr/bin/update-desktop-database ] ; then
   348   usr/bin/update-desktop-database > /dev/null || :
   333   usr/bin/update-desktop-database > /dev/null || :
   349 fi
   334 fi
   350 %else
       
   351 if [ -f opt/gnome/bin/update-mime-database ] ; then
       
   352   opt/gnome/bin/update-mime-database > /dev/null || :
       
   353 fi
       
   354 %endif
       
   355 
   335 
   356 %files
   336 %files
   357 %defattr(-,root,root)
   337 %defattr(-,root,root)
   358 %dir %{progdir}
   338 %dir %{progdir}
   359 %dir %{progdir}/chrome/
   339 %dir %{progdir}/chrome/