MozillaFirefox/MozillaFirefox.spec
branchfirefox20
changeset 633 7c6f56a37ed6
parent 629 f454588ac85b
parent 631 e5ead5bc3360
child 634 3fbce5dd16c2
child 639 0cb8814119b0
equal deleted inserted replaced
629:f454588ac85b 633:7c6f56a37ed6
    49 BuildRequires:  libproxy-devel
    49 BuildRequires:  libproxy-devel
    50 %else
    50 %else
    51 BuildRequires:  wireless-tools
    51 BuildRequires:  wireless-tools
    52 %endif
    52 %endif
    53 BuildRequires:  mozilla-nspr-devel >= 4.9.5
    53 BuildRequires:  mozilla-nspr-devel >= 4.9.5
    54 BuildRequires:  mozilla-nss-devel >= 3.14.2
    54 BuildRequires:  mozilla-nss-devel >= 3.14.3
    55 BuildRequires:  nss-shared-helper-devel
    55 BuildRequires:  nss-shared-helper-devel
    56 %if %suse_version > 1140
    56 %if %suse_version > 1140
    57 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    57 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    60 %endif
    60 %endif
    61 Version:        %{mainver}
    61 Version:        %{mainver}
    62 Release:        0
    62 Release:        0
    63 %define         releasedate 2013030800
    63 %define         releasedate 2013031500
    64 Provides:       firefox = %{mainver}
    64 Provides:       firefox = %{mainver}
    65 Provides:       firefox = %{version}-%{release}
    65 Provides:       firefox = %{version}-%{release}
    66 Provides:       web_browser
    66 Provides:       web_browser
    67 Provides:       browser(npapi)
    67 Provides:       browser(npapi)
    68 # this is needed to match this package with the kde4 helper package without the main package
    68 # this is needed to match this package with the kde4 helper package without the main package
   272 export MOZ_BUILD_DATE=%{releasedate}
   272 export MOZ_BUILD_DATE=%{releasedate}
   273 export MOZILLA_OFFICIAL=1
   273 export MOZILLA_OFFICIAL=1
   274 export BUILD_OFFICIAL=1
   274 export BUILD_OFFICIAL=1
   275 export MOZ_TELEMETRY_REPORTING=1
   275 export MOZ_TELEMETRY_REPORTING=1
   276 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   276 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   277 %ifarch %arm
       
   278 export CFLAGS="${CFLAGS/-g/}"
       
   279 %endif
   277 %ifarch ppc64
   280 %ifarch ppc64
   278 export CFLAGS="$CFLAGS -mminimal-toc"
   281 export CFLAGS="$CFLAGS -mminimal-toc"
   279 %endif
   282 %endif
   280 export CXXFLAGS="$CFLAGS"
   283 export CXXFLAGS="$CFLAGS"
   281 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   284 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   332 %endif
   335 %endif
   333 # Disable neon for arm as it does not build correctly
   336 # Disable neon for arm as it does not build correctly
   334 %ifarch %arm
   337 %ifarch %arm
   335 cat << EOF >> $MOZCONFIG
   338 cat << EOF >> $MOZCONFIG
   336 ac_add_options --disable-neon
   339 ac_add_options --disable-neon
       
   340 ac_add_options --disable-webrtc
   337 EOF
   341 EOF
   338 %endif
   342 %endif
   339 make -f client.mk build
   343 make -f client.mk build
   340 
   344 
   341 %install
   345 %install