MozillaFirefox/MozillaFirefox.spec
branchfirefox70
changeset 1112 8a4f5aea2475
parent 1111 97a6da6d7e29
child 1113 8e9195853a32
equal deleted inserted replaced
1111:97a6da6d7e29 1112:8a4f5aea2475
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          69
    21 %define major          70
    22 %define mainver        %major.0.3
    22 %define mainver        %major.0
    23 %define orig_version   69.0.3
    23 %define orig_version   70.0
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define devpkg         1
    27 %define devpkg         1
    28 %define releasedate    20191009172106
    28 %define releasedate    20191016161957
    29 
    29 
    30 # always build with GCC as SUSE Security Team requires that
    30 # always build with GCC as SUSE Security Team requires that
    31 %define clang_build 0
    31 %define clang_build 0
    32 
    32 
    33 # PIE, full relro
    33 # PIE, full relro
    71 %if 0%{?suse_version} <= 1320
    71 %if 0%{?suse_version} <= 1320
    72 BuildRequires:  gcc7-c++
    72 BuildRequires:  gcc7-c++
    73 %else
    73 %else
    74 BuildRequires:  gcc-c++
    74 BuildRequires:  gcc-c++
    75 %endif
    75 %endif
    76 BuildRequires:  cargo >= 1.35
    76 BuildRequires:  cargo >= 1.36
    77 BuildRequires:  libXcomposite-devel
    77 BuildRequires:  libXcomposite-devel
    78 BuildRequires:  libcurl-devel
    78 BuildRequires:  libcurl-devel
    79 BuildRequires:  libidl-devel
    79 BuildRequires:  libidl-devel
    80 BuildRequires:  libiw-devel
    80 BuildRequires:  libiw-devel
    81 BuildRequires:  libnotify-devel
    81 BuildRequires:  libnotify-devel
    82 BuildRequires:  libproxy-devel
    82 BuildRequires:  libproxy-devel
    83 BuildRequires:  makeinfo
    83 BuildRequires:  makeinfo
    84 BuildRequires:  mozilla-nspr-devel >= 4.21
    84 BuildRequires:  mozilla-nspr-devel >= 4.22
    85 BuildRequires:  mozilla-nss-devel >= 3.45
    85 BuildRequires:  mozilla-nss-devel >= 3.46.1
    86 BuildRequires:  nasm >= 2.13
    86 BuildRequires:  nasm >= 2.13
    87 BuildRequires:  nodejs8 >= 8.11
    87 BuildRequires:  nodejs8 >= 8.11
    88 BuildRequires:  python-devel
    88 BuildRequires:  python-devel
    89 BuildRequires:  python2-xml
    89 BuildRequires:  python2-xml
    90 BuildRequires:  python3 >= 3.5
    90 BuildRequires:  python3 >= 3.5
    91 BuildRequires:  rust >= 1.35
    91 BuildRequires:  rust >= 1.36
    92 BuildRequires:  rust-cbindgen >= 0.9.0
    92 BuildRequires:  rust-cbindgen >= 0.9.1
    93 BuildRequires:  startup-notification-devel
    93 BuildRequires:  startup-notification-devel
    94 BuildRequires:  unzip
    94 BuildRequires:  unzip
    95 BuildRequires:  update-desktop-files
    95 BuildRequires:  update-desktop-files
    96 BuildRequires:  xorg-x11-libXt-devel
    96 BuildRequires:  xorg-x11-libXt-devel
    97 %if 0%{?do_profiling}
    97 %if 0%{?do_profiling}
   177 Patch11:        mozilla-s390-bigendian.patch
   177 Patch11:        mozilla-s390-bigendian.patch
   178 Patch12:        mozilla-reduce-rust-debuginfo.patch
   178 Patch12:        mozilla-reduce-rust-debuginfo.patch
   179 Patch13:        mozilla-ppc-altivec_static_inline.patch
   179 Patch13:        mozilla-ppc-altivec_static_inline.patch
   180 Patch14:        mozilla-bmo1005535.patch
   180 Patch14:        mozilla-bmo1005535.patch
   181 Patch15:        mozilla-bmo1568145.patch
   181 Patch15:        mozilla-bmo1568145.patch
   182 Patch16:        mozilla-bmo1573381.patch
   182 Patch16:        mozilla-bmo1504834-part1.patch
   183 Patch17:        mozilla-bmo1504834-part1.patch
   183 Patch17:        mozilla-bmo1504834-part2.patch
   184 Patch18:        mozilla-bmo1504834-part2.patch
   184 Patch18:        mozilla-bmo1504834-part3.patch
   185 Patch19:        mozilla-bmo1504834-part3.patch
   185 Patch19:        mozilla-bmo1511604.patch
   186 Patch20:        mozilla-bmo1511604.patch
   186 Patch20:        mozilla-bmo1554971.patch
   187 Patch21:        mozilla-bmo1554971.patch
   187 Patch21:        mozilla-bmo1512162.patch
   188 Patch22:        mozilla-nestegg-big-endian.patch
   188 Patch22:        mozilla-fix-top-level-asm.patch
   189 Patch23:        mozilla-bmo1512162.patch
       
   190 Patch24:        mozilla-fix-top-level-asm.patch
       
   191 # Firefox/browser
   189 # Firefox/browser
   192 Patch101:       firefox-kde.patch
   190 Patch101:       firefox-kde.patch
   193 Patch102:       firefox-branded-icons.patch
   191 Patch102:       firefox-branded-icons.patch
   194 %endif # only_print_mozconfig
   192 %endif # only_print_mozconfig
   195 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   193 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   321 %patch18 -p1
   319 %patch18 -p1
   322 %patch19 -p1
   320 %patch19 -p1
   323 %patch20 -p1
   321 %patch20 -p1
   324 %patch21 -p1
   322 %patch21 -p1
   325 %patch22 -p1
   323 %patch22 -p1
   326 %patch23 -p1
       
   327 %patch24 -p1
       
   328 # Firefox
   324 # Firefox
   329 %patch101 -p1
   325 %patch101 -p1
   330 %patch102 -p1
   326 %patch102 -p1
   331 %endif # only_print_mozconfig
   327 %endif # only_print_mozconfig
   332 
   328 
   344   exit 1
   340   exit 1
   345 fi
   341 fi
   346 source %{SOURCE5}
   342 source %{SOURCE5}
   347 %endif # only_print_mozconfig
   343 %endif # only_print_mozconfig
   348 
   344 
       
   345 export CARGO_HOME=${RPM_BUILD_DIR}/%{srcname}-%{orig_version}/.cargo
   349 export MOZ_SOURCE_CHANGESET=$REV
   346 export MOZ_SOURCE_CHANGESET=$REV
   350 export SOURCE_REPO=$REPO
   347 export SOURCE_REPO=$REPO
   351 export source_repo=$REPO
   348 export source_repo=$REPO
   352 export MOZ_SOURCE_REPO=$REPO
   349 export MOZ_SOURCE_REPO=$REPO
   353 export MOZ_BUILD_DATE=%{releasedate}
   350 export MOZ_BUILD_DATE=%{releasedate}
   499 mkdir -p %{buildroot}%{progdir}/distribution/extensions
   496 mkdir -p %{buildroot}%{progdir}/distribution/extensions
   500 mkdir -p %{buildroot}%{progdir}/browser/defaults/preferences/
   497 mkdir -p %{buildroot}%{progdir}/browser/defaults/preferences/
   501 # renaming executables (for regular vs. ESR)
   498 # renaming executables (for regular vs. ESR)
   502 %if "%{srcname}" != "%{progname}"
   499 %if "%{srcname}" != "%{progname}"
   503 mv %{buildroot}%{progdir}/%{srcname} %{buildroot}%{progdir}/%{progname}
   500 mv %{buildroot}%{progdir}/%{srcname} %{buildroot}%{progdir}/%{progname}
   504 mv %{buildroot}%{progdir}/%{srcname}-bin %{buildroot}%{progdir}/%{progname}
   501 mv %{buildroot}%{progdir}/%{srcname}-bin %{buildroot}%{progdir}/%{progname}-bin
   505 %endif
   502 %endif
   506 # install gre prefs
   503 # install gre prefs
   507 install -m 644 %{SOURCE13} %{buildroot}%{progdir}/defaults/pref/
   504 install -m 644 %{SOURCE13} %{buildroot}%{progdir}/defaults/pref/
   508 # install browser prefs
   505 # install browser prefs
   509 install -m 644 %{SOURCE9} %{buildroot}%{progdir}/browser/defaults/preferences/firefox.js
   506 install -m 644 %{SOURCE9} %{buildroot}%{progdir}/browser/defaults/preferences/firefox.js