MozillaFirefox/MozillaFirefox.spec
branchfirefox50
changeset 932 a58cc7936ce7
parent 931 c5f980be6e8b
child 933 7f60766aae16
equal deleted inserted replaced
931:c5f980be6e8b 932:a58cc7936ce7
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 49
    21 %define major 50
    22 %define mainver %major.0.2
    22 %define mainver %major.0
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 20161020000000
    24 %define releasedate 20161113000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 # general build definitions
    29 # general build definitions
    52 %define branding 0
    52 %define branding 0
    53 %else
    53 %else
    54 %define branding 1
    54 %define branding 1
    55 %endif
    55 %endif
    56 %define localize 1
    56 %define localize 1
    57 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
    57 %ifarch %ix86 x86_64
       
    58 %define crashreporter 1
       
    59 %else
    58 %define crashreporter 0
    60 %define crashreporter 0
    59 %else
       
    60 %define crashreporter 1
       
    61 %endif
    61 %endif
    62 
    62 
    63 Name:           %{pkgname}
    63 Name:           %{pkgname}
    64 BuildRequires:  Mesa-devel
    64 BuildRequires:  Mesa-devel
    65 BuildRequires:  autoconf213
    65 BuildRequires:  autoconf213
    73 BuildRequires:  libiw-devel
    73 BuildRequires:  libiw-devel
    74 BuildRequires:  libnotify-devel
    74 BuildRequires:  libnotify-devel
    75 BuildRequires:  libproxy-devel
    75 BuildRequires:  libproxy-devel
    76 BuildRequires:  makeinfo
    76 BuildRequires:  makeinfo
    77 BuildRequires:  mozilla-nspr-devel >= 4.12
    77 BuildRequires:  mozilla-nspr-devel >= 4.12
    78 BuildRequires:  mozilla-nss-devel >= 3.25
    78 BuildRequires:  mozilla-nss-devel >= 3.26.2
    79 BuildRequires:  nss-shared-helper-devel
    79 BuildRequires:  nss-shared-helper-devel
    80 BuildRequires:  python-devel
    80 BuildRequires:  python-devel
    81 BuildRequires:  startup-notification-devel
    81 BuildRequires:  startup-notification-devel
    82 BuildRequires:  unzip
    82 BuildRequires:  unzip
    83 BuildRequires:  update-desktop-files
    83 BuildRequires:  update-desktop-files
   201 
   201 
   202 %package translations-other
   202 %package translations-other
   203 Summary:        Extra translations for %{appname}
   203 Summary:        Extra translations for %{appname}
   204 Group:          System/Localization
   204 Group:          System/Localization
   205 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;uz;vi;zu)
   205 Provides:       locale(%{name}:ach;af;ak;as;ast;be;bg;bn_BD;bn_IN;br;bs;csb;cy;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gu_IN;he;hi_IN;hr;hy_AM;id;is;kk;km;kn;ku;lg;lij;lt;lv;mai;mk;ml;mr;nn_NO;nso;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;ta_LK;te;th;tr;uk;uz;vi;zu)
       
   206 Provides:       locale(%{name}:ach;af;an;as;ast;az;be;bg;bn_BD;bn_IN;br;bs;cak;cy;dsb;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gn;gu_IN;he;hi_IN;hr;hsb;hy_AM;id;is;kk;km;kn;lij;lt;lv;mai;mk;ml;mr;ms;nn_NO;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;te;th;tr;uk;uz;vi;xh)
   206 Requires:       %{name} = %{version}
   207 Requires:       %{name} = %{version}
   207 Obsoletes:      %{name}-translations < %{version}-%{release}
   208 Obsoletes:      %{name}-translations < %{version}-%{release}
   208 
   209 
   209 %description translations-other
   210 %description translations-other
   210 This package contains rarely used languages for the user interface
   211 This package contains rarely used languages for the user interface
   332 %ifarch %ix86 %arm
   333 %ifarch %ix86 %arm
   333 %if 0%{?suse_version} > 1230
   334 %if 0%{?suse_version} > 1230
   334 ac_add_options --disable-optimize
   335 ac_add_options --disable-optimize
   335 %endif
   336 %endif
   336 %endif
   337 %endif
   337 %ifarch ppc ppc64 ppc64le aarch64 %arm
   338 %ifarch ppc ppc64 ppc64le %arm
   338 ac_add_options --disable-elf-hack
   339 ac_add_options --disable-elf-hack
   339 %endif
   340 %endif
   340 ac_add_options --with-system-nspr
   341 ac_add_options --with-system-nspr
   341 ac_add_options --with-system-nss
   342 ac_add_options --with-system-nss
   342 %if %{localize}
   343 %if %{localize}
   361 %ifarch %arm
   362 %ifarch %arm
   362 ac_add_options --with-fpu=vfpv3-d16
   363 ac_add_options --with-fpu=vfpv3-d16
   363 ac_add_options --with-float-abi=hard
   364 ac_add_options --with-float-abi=hard
   364 ac_add_options --with-arch=armv7-a
   365 ac_add_options --with-arch=armv7-a
   365 %endif
   366 %endif
   366 %ifarch %arm aarch64 s390x
   367 %ifarch %arm s390x
   367 ac_add_options --disable-webrtc
   368 ac_add_options --disable-webrtc
   368 %endif
   369 %endif
   369 EOF
   370 EOF
   370 make -f client.mk build
   371 make -f client.mk build
   371 
   372 
   581 %{progdir}/application.ini
   582 %{progdir}/application.ini
   582 %{progdir}/dependentlibs.list
   583 %{progdir}/dependentlibs.list
   583 %{progdir}/*.so
   584 %{progdir}/*.so
   584 %{progdir}/icudt56l.dat
   585 %{progdir}/icudt56l.dat
   585 %{progdir}/omni.ja
   586 %{progdir}/omni.ja
       
   587 %{progdir}/fonts/
   586 %{progdir}/platform.ini
   588 %{progdir}/platform.ini
   587 %{progdir}/plugin-container
   589 %{progdir}/plugin-container
   588 %if %crashreporter
   590 %if %crashreporter
   589 %{progdir}/crashreporter
   591 %{progdir}/crashreporter
   590 %{progdir}/crashreporter.ini
   592 %{progdir}/crashreporter.ini