MozillaFirefox/MozillaFirefox.spec
changeset 645 a9f3d5963cc0
parent 643 d323f07d98a2
child 647 9d8bdcdd4d2a
equal deleted inserted replaced
644:77d8529fa082 645:a9f3d5963cc0
    20 %define major 20
    20 %define major 20
    21 %define mainver %major.99
    21 %define mainver %major.99
    22 %define update_channel beta
    22 %define update_channel beta
    23 
    23 
    24 %if %suse_version > 1220
    24 %if %suse_version > 1220
    25 %define gstreamer_ver 1.0
    25 %define gstreamer_ver 0.10
    26 %else
    26 %else
    27 %define gstreamer_ver 0.10
    27 %define gstreamer_ver 0.10
    28 %endif
    28 %endif
    29 
    29 
    30 Name:           MozillaFirefox
    30 Name:           MozillaFirefox
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    60 %endif
    60 %endif
    61 Version:        %{mainver}
    61 Version:        %{mainver}
    62 Release:        0
    62 Release:        0
    63 %define         releasedate 2013040100
    63 %define         releasedate 2013041300
    64 Provides:       firefox = %{mainver}
    64 Provides:       firefox = %{mainver}
    65 Provides:       firefox = %{version}-%{release}
    65 Provides:       firefox = %{version}-%{release}
    66 Provides:       web_browser
    66 Provides:       web_browser
    67 Provides:       browser(npapi)
    67 Provides:       browser(npapi)
    68 # this is needed to match this package with the kde4 helper package without the main package
    68 # this is needed to match this package with the kde4 helper package without the main package
   101 Patch10:        mozilla-sle11.patch
   101 Patch10:        mozilla-sle11.patch
   102 Patch12:        mozilla-arm-disable-edsp.patch
   102 Patch12:        mozilla-arm-disable-edsp.patch
   103 Patch13:        mozilla-ppc.patch
   103 Patch13:        mozilla-ppc.patch
   104 Patch14:        mozilla-gstreamer-760140.patch
   104 Patch14:        mozilla-gstreamer-760140.patch
   105 Patch15:        mozilla-libproxy-compat.patch
   105 Patch15:        mozilla-libproxy-compat.patch
   106 Patch16:        mozilla-gstreamer-1.patch
       
   107 # Firefox/browser
   106 # Firefox/browser
   108 Patch30:        firefox-browser-css.patch
   107 Patch30:        firefox-browser-css.patch
   109 Patch31:        firefox-kde.patch
   108 Patch31:        firefox-kde.patch
   110 Patch32:        firefox-kde-114.patch
   109 Patch32:        firefox-kde-114.patch
   111 Patch33:        firefox-no-default-ualocale.patch
   110 Patch33:        firefox-no-default-ualocale.patch
   234 %endif
   233 %endif
   235 %patch12 -p1
   234 %patch12 -p1
   236 %patch13 -p1
   235 %patch13 -p1
   237 %patch14 -p1
   236 %patch14 -p1
   238 %patch15 -p1
   237 %patch15 -p1
   239 %patch16 -p1
       
   240 #
   238 #
   241 %patch30 -p1
   239 %patch30 -p1
   242 %if %suse_version >= 1110
   240 %if %suse_version >= 1110
   243 %patch31 -p1
   241 %patch31 -p1
   244 %endif
   242 %endif
   310 ac_add_options --enable-gio
   308 ac_add_options --enable-gio
   311 EOF
   309 EOF
   312 %endif
   310 %endif
   313 %if %suse_version > 1140
   311 %if %suse_version > 1140
   314 cat << EOF >> $MOZCONFIG
   312 cat << EOF >> $MOZCONFIG
   315 ac_add_options --enable-gstreamer=%{gstreamer_ver}
   313 ac_add_options --enable-gstreamer
   316 EOF
   314 EOF
   317 %endif
   315 %endif
   318 %if %branding
   316 %if %branding
   319 cat << EOF >> $MOZCONFIG
   317 cat << EOF >> $MOZCONFIG
   320 ac_add_options --enable-official-branding
   318 ac_add_options --enable-official-branding