MozillaFirefox/MozillaFirefox.spec
changeset 340 aabcc7895695
parent 337 cf16b6560dd1
child 341 a90633075f60
equal deleted inserted replaced
338:5b3e3dc8fb40 340:aabcc7895695
    17 #
    17 #
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 %define major 7
    21 %define major 7
    22 %define mainver %major.0
    22 %define mainver %major.99
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files yasm zip
    25 BuildRequires:  Mesa-devel autoconf213 dbus-1-glib-devel fdupes gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files yasm zip
    26 %if %suse_version > 1110
    26 %if %suse_version > 1110
    27 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
    31 %endif
    31 %endif
    32 BuildRequires:  mozilla-nspr-devel >= 4.8.8
    32 BuildRequires:  mozilla-nspr-devel >= 4.8.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.10
    33 BuildRequires:  mozilla-nss-devel >= 3.12.10
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}.1
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011092900
    38 %define         releasedate 2011100400
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
    64 Patch1:         toolkit-download-folder.patch
    64 Patch1:         toolkit-download-folder.patch
    65 Patch2:         mozilla-nongnome-proxies.patch
    65 Patch2:         mozilla-nongnome-proxies.patch
    66 Patch3:         mozilla-prefer_plugin_pref.patch
    66 Patch3:         mozilla-prefer_plugin_pref.patch
    67 Patch4:         mozilla-shared-nss-db.patch
    67 Patch4:         mozilla-shared-nss-db.patch
    68 Patch5:         mozilla-kde.patch
    68 Patch5:         mozilla-kde.patch
    69 Patch7:         mozilla-language.patch
    69 Patch6:         mozilla-language.patch
    70 Patch9:         mozilla-cairo-return.patch
    70 Patch7:         mozilla-ntlm-full-path.patch
    71 Patch10:        mozilla-ntlm-full-path.patch
    71 Patch8:         mozilla-repo.patch
    72 Patch12:        mozilla-repo.patch
    72 Patch9:         mozilla-dump_syms-static.patch
    73 Patch13:        mozilla-dump_syms-static.patch
    73 Patch10:        mozilla-sle11.patch
    74 Patch14:        mozilla-sle11.patch
    74 Patch11:        mozilla-linux3.patch
    75 Patch15:        mozilla-linux3.patch
       
    76 Patch16:        mozilla-curl.patch
       
    77 # Firefox/browser
    75 # Firefox/browser
    78 Patch31:        firefox-browser-css.patch
    76 Patch31:        firefox-browser-css.patch
    79 Patch32:        firefox-cross-desktop.patch
    77 Patch32:        firefox-cross-desktop.patch
    80 Patch33:        firefox-kde.patch
    78 Patch33:        firefox-kde.patch
    81 Patch34:        firefox-kde-114.patch
    79 Patch34:        firefox-kde-114.patch
   194 %patch1 -p1
   192 %patch1 -p1
   195 %patch2 -p1
   193 %patch2 -p1
   196 %patch3 -p1
   194 %patch3 -p1
   197 %patch4 -p1
   195 %patch4 -p1
   198 %patch5 -p1
   196 %patch5 -p1
       
   197 %patch6 -p1
   199 %patch7 -p1
   198 %patch7 -p1
       
   199 %patch8 -p1
   200 %patch9 -p1
   200 %patch9 -p1
       
   201 %if %suse_version < 1120
   201 %patch10 -p1
   202 %patch10 -p1
   202 %patch12 -p1
   203 %endif
   203 %patch13 -p1
   204 %patch11 -p1
   204 %if %suse_version < 1120
       
   205 %patch14 -p1
       
   206 %endif
       
   207 %patch15 -p1
       
   208 %patch16 -p1
       
   209 #
   205 #
   210 %patch31 -p1
   206 %patch31 -p1
   211 %patch32 -p1
   207 %patch32 -p1
   212 %if %suse_version >= 1110
   208 %if %suse_version >= 1110
   213 %patch33 -p1
   209 %patch33 -p1
   265 ac_add_options --disable-updater
   261 ac_add_options --disable-updater
   266 ac_add_options --disable-tests
   262 ac_add_options --disable-tests
   267 ac_add_options --disable-debug
   263 ac_add_options --disable-debug
   268 ac_add_options --enable-startup-notification
   264 ac_add_options --enable-startup-notification
   269 #ac_add_options --enable-chrome-format=jar
   265 #ac_add_options --enable-chrome-format=jar
   270 ac_add_options --enable-update-channel=default
   266 ac_add_options --enable-update-channel=beta
   271 EOF
   267 EOF
   272 %if %suse_version > 1130
   268 %if %suse_version > 1130
   273 cat << EOF >> $MOZCONFIG
   269 cat << EOF >> $MOZCONFIG
   274 ac_add_options --disable-gnomevfs
   270 ac_add_options --disable-gnomevfs
   275 ac_add_options --enable-gio
   271 ac_add_options --enable-gio