xulrunner/xulrunner.spec
changeset 539 b1134fe91f9a
parent 535 cba7622bad5d
child 554 d19c7ee78903
equal deleted inserted replaced
529:4812378b5646 539:b1134fe91f9a
    40 BuildRequires:  libiw-devel
    40 BuildRequires:  libiw-devel
    41 BuildRequires:  libproxy-devel
    41 BuildRequires:  libproxy-devel
    42 %else
    42 %else
    43 BuildRequires:  wireless-tools
    43 BuildRequires:  wireless-tools
    44 %endif
    44 %endif
    45 BuildRequires:  mozilla-nspr-devel >= 4.9.1
    45 BuildRequires:  mozilla-nspr-devel >= 4.9.2
    46 BuildRequires:  mozilla-nss-devel >= 3.13.6
    46 BuildRequires:  mozilla-nss-devel >= 3.13.6
    47 Version:        15.98
    47 Version:        16.98
    48 Release:        0
    48 Release:        0
    49 %define         releasedate 2012071800
    49 %define         releasedate 2012091000
    50 %define         version_internal 15.0
    50 %define         version_internal 17.0
    51 %define         apiversion 15
    51 %define         apiversion 17
    52 %define         uaweight 1500000
    52 %define         uaweight 1700000
    53 Summary:        Mozilla Runtime Environment
    53 Summary:        Mozilla Runtime Environment
    54 License:        MPL-2.0
    54 License:        MPL-2.0
    55 Group:          Productivity/Other
    55 Group:          Productivity/Other
    56 Url:            http://www.mozilla.org/
    56 Url:            http://www.mozilla.org/
    57 Provides:       gecko
    57 Provides:       gecko
    68 Source7:        baselibs.conf
    68 Source7:        baselibs.conf
    69 Source8:        source-stamp.txt
    69 Source8:        source-stamp.txt
    70 Source9:        compare-locales.tar.bz2
    70 Source9:        compare-locales.tar.bz2
    71 Patch1:         toolkit-download-folder.patch
    71 Patch1:         toolkit-download-folder.patch
    72 Patch2:         mozilla-pkgconfig.patch
    72 Patch2:         mozilla-pkgconfig.patch
       
    73 Patch3:         idldir.patch
    73 Patch4:         mozilla-nongnome-proxies.patch
    74 Patch4:         mozilla-nongnome-proxies.patch
    74 Patch5:         mozilla-prefer_plugin_pref.patch
    75 Patch5:         mozilla-prefer_plugin_pref.patch
    75 Patch6:         mozilla-language.patch
    76 Patch6:         mozilla-language.patch
    76 Patch7:         mozilla-ntlm-full-path.patch
    77 Patch7:         mozilla-ntlm-full-path.patch
    77 Patch9:         mozilla-sle11.patch
    78 Patch9:         mozilla-sle11.patch
    78 Patch13:        mozilla-gstreamer.patch
    79 Patch12:        mozilla-crashreporter-restart-args.patch
    79 Patch14:        mozilla-ppc.patch
    80 Patch14:        mozilla-ppc.patch
    80 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    81 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    81 Requires:       mozilla-js = %{version}
    82 Requires:       mozilla-js = %{version}
    82 Requires(post):  update-alternatives coreutils
    83 Requires(post):  update-alternatives coreutils
    83 Requires(preun): update-alternatives coreutils
    84 Requires(preun): update-alternatives coreutils
    84 ### build configuration ###
    85 ### build configuration ###
    85 %define has_system_nspr  1
    86 %define has_system_nspr  1
    86 %define has_system_nss   1
    87 %define has_system_nss   1
    87 %define has_system_cairo 0
    88 %define has_system_cairo 0
    88 %define localize 0
    89 %define localize 0
    89 %ifarch ppc ppc64 s390 s390x ia64
    90 %ifarch ppc ppc64 s390 s390x ia64 %arm
    90 %define crashreporter    0
    91 %define crashreporter    0
    91 %else
    92 %else
    92 %define crashreporter    1
    93 %define crashreporter    1
    93 %endif
    94 %endif
    94 ### configuration end ###
    95 ### configuration end ###
   180 
   181 
   181 %prep
   182 %prep
   182 %setup -n mozilla -q -b 1 -b 9
   183 %setup -n mozilla -q -b 1 -b 9
   183 %patch1 -p1
   184 %patch1 -p1
   184 %patch2 -p1
   185 %patch2 -p1
       
   186 %patch3 -p1
   185 %patch4 -p1
   187 %patch4 -p1
   186 %patch5 -p1
   188 %patch5 -p1
   187 %patch6 -p1
   189 %patch6 -p1
   188 %patch7 -p1
   190 %patch7 -p1
   189 %if %suse_version < 1120
   191 %if %suse_version < 1120
   190 %patch9 -p1
   192 %patch9 -p1
   191 %endif
   193 %endif
   192 %patch13 -p1
   194 %patch12 -p1
   193 %patch14 -p1
   195 %patch14 -p1
   194 
   196 
   195 %build
   197 %build
   196 # no need to add build time to binaries
   198 # no need to add build time to binaries
   197 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   199 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   203 export MOZ_BUILD_DATE=%{releasedate}
   205 export MOZ_BUILD_DATE=%{releasedate}
   204 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   206 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   205 %ifarch ppc64
   207 %ifarch ppc64
   206 export CFLAGS="$CFLAGS -mminimal-toc"
   208 export CFLAGS="$CFLAGS -mminimal-toc"
   207 %endif
   209 %endif
       
   210 export LDFLAGS=" -Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   211 %ifarch %arm
       
   212 # debug symbols require too much memory during build
       
   213 export CFLAGS="${CFLAGS/-g/}"
       
   214 LDFLAGS+="-Wl,--reduce-memory-overheads -Wl,--no-keep-memory"
       
   215 %endif
   208 export CXXFLAGS="$CFLAGS"
   216 export CXXFLAGS="$CFLAGS"
   209 export LDFLAGS="-Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   210 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   217 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   211 export MOZILLA_OFFICIAL=1
   218 export MOZILLA_OFFICIAL=1
   212 export BUILD_OFFICIAL=1
   219 export BUILD_OFFICIAL=1
   213 export MOZ_MILESTONE_RELEASE=1
   220 export MOZ_MILESTONE_RELEASE=1
   214 #
   221 #
   278 EOF
   285 EOF
   279 %endif
   286 %endif
   280 # ARM
   287 # ARM
   281 %ifarch %arm
   288 %ifarch %arm
   282 cat << EOF >> $MOZCONFIG
   289 cat << EOF >> $MOZCONFIG
   283 %ifarch armv7l
   290 %ifarch armv7l armv7hl
   284 ac_add_options --with-arch=armv7-a
   291 ac_add_options --with-arch=armv7-a
   285 ac_add_options --with-float-abi=hard
   292 ac_add_options --with-float-abi=hard
   286 ac_add_options --with-fpu=vfpv3-d16
   293 ac_add_options --with-fpu=vfpv3-d16
   287 ac_add_options --with-thumb=yes
   294 ac_add_options --with-thumb=yes
       
   295 ac_add_options --disable-debug
   288 %endif
   296 %endif
   289 %ifarch armv5tel
   297 %ifarch armv5tel
   290 ac_add_options --with-arch=armv5te
   298 ac_add_options --with-arch=armv5te
   291 ac_add_options --with-float-abi=soft
   299 ac_add_options --with-float-abi=soft
   292 ac_add_options --with-thumb=no
   300 ac_add_options --with-thumb=no
   450 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
   458 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
   451 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
   459 %{_libdir}/xulrunner-%{version_internal}/chrome.manifest
   452 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
   460 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
   453 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
   461 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
   454 %{_libdir}/xulrunner-%{version_internal}/plugin-container
   462 %{_libdir}/xulrunner-%{version_internal}/plugin-container
   455 %{_libdir}/xulrunner-%{version_internal}/run-mozilla.sh
       
   456 %{_libdir}/xulrunner-%{version_internal}/xulrunner
   463 %{_libdir}/xulrunner-%{version_internal}/xulrunner
   457 %{_libdir}/xulrunner-%{version_internal}/xulrunner-bin
       
   458 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
   464 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
   459 %{_libdir}/xulrunner-%{version_internal}/platform.ini
   465 %{_libdir}/xulrunner-%{version_internal}/platform.ini
   460 %{_libdir}/xulrunner-%{version_internal}/omni.ja
   466 %{_libdir}/xulrunner-%{version_internal}/omni.ja
   461 %{_libdir}/xulrunner-%{version_internal}/README.xulrunner
   467 %{_libdir}/xulrunner-%{version_internal}/README.xulrunner
   462 # crashreporter files
   468 # crashreporter files