MozillaFirefox/MozillaFirefox.spec
branchfirefox91
changeset 1160 b28cf22ff7cf
parent 1159 c4aba2fa0908
child 1161 36ae1e4f15eb
equal deleted inserted replaced
1159:c4aba2fa0908 1160:b28cf22ff7cf
    30 # orig_version would be the upstream tar ball
    30 # orig_version would be the upstream tar ball
    31 # orig_version 70.0
    31 # orig_version 70.0
    32 # orig_suffix b3
    32 # orig_suffix b3
    33 # major 69
    33 # major 69
    34 # mainver %major.99
    34 # mainver %major.99
    35 %define major          90
    35 %define major          91
    36 %define mainver        %major.0.2
    36 %define mainver        %major.0
    37 %define orig_version   90.0.2
    37 %define orig_version   91.0
    38 %define orig_suffix    %{nil}
    38 %define orig_suffix    %{nil}
    39 %define update_channel release
    39 %define update_channel release
    40 %define branding       1
    40 %define branding       1
    41 %define devpkg         1
    41 %define devpkg         1
    42 
    42 
    51 
    51 
    52 %bcond_with only_print_mozconfig
    52 %bcond_with only_print_mozconfig
    53 
    53 
    54 # define if ccache should be used or not
    54 # define if ccache should be used or not
    55 %define useccache     1
    55 %define useccache     1
       
    56 
       
    57 # SLE-12 doesn't have this macro
       
    58 %{!?_rpmmacrodir: %global _rpmmacrodir %{_rpmconfigdir}/macros.d}
    56 
    59 
    57 # Firefox only supports i686
    60 # Firefox only supports i686
    58 %ifarch %ix86
    61 %ifarch %ix86
    59 ExclusiveArch:  i586 i686
    62 ExclusiveArch:  i586 i686
    60 BuildArch:      i686
    63 BuildArch:      i686
    98 %if 0%{?suse_version} <= 1320
   101 %if 0%{?suse_version} <= 1320
    99 BuildRequires:  gcc9-c++
   102 BuildRequires:  gcc9-c++
   100 %else
   103 %else
   101 BuildRequires:  gcc-c++
   104 BuildRequires:  gcc-c++
   102 %endif
   105 %endif
   103 BuildRequires:  cargo >= 1.47
   106 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
       
   107 BuildRequires:  cargo >= 1.51
       
   108 BuildRequires:  rust >= 1.51
       
   109 %else
       
   110 # Newer sle/leap/tw use parallel versioned rust releases which have
       
   111 # a different method for provides that we can use to request a
       
   112 # specific version
       
   113 BuildRequires:  rust+cargo >= 1.51
       
   114 %endif
   104 %if 0%{useccache} != 0
   115 %if 0%{useccache} != 0
   105 BuildRequires:  ccache
   116 BuildRequires:  ccache
   106 %endif
   117 %endif
   107 BuildRequires:  libXcomposite-devel
   118 BuildRequires:  libXcomposite-devel
   108 BuildRequires:  libcurl-devel
   119 BuildRequires:  libcurl-devel
   109 BuildRequires:  libidl-devel
   120 BuildRequires:  libidl-devel
   110 BuildRequires:  libiw-devel
   121 BuildRequires:  libiw-devel
   111 BuildRequires:  libproxy-devel
   122 BuildRequires:  libproxy-devel
   112 BuildRequires:  makeinfo
   123 BuildRequires:  makeinfo
   113 BuildRequires:  mozilla-nspr-devel >= 4.31
   124 BuildRequires:  mozilla-nspr-devel >= 4.32
   114 BuildRequires:  mozilla-nss-devel >= 3.66
   125 BuildRequires:  mozilla-nss-devel >= 3.68
   115 BuildRequires:  nasm >= 2.14
   126 BuildRequires:  nasm >= 2.14
   116 BuildRequires:  nodejs >= 10.22.1
   127 BuildRequires:  nodejs >= 10.22.1
   117 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   128 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   118 BuildRequires:  python-libxml2
   129 BuildRequires:  python-libxml2
   119 BuildRequires:  python36
   130 BuildRequires:  python36
   120 %else
   131 %else
   121 BuildRequires:  python3 >= 3.5
   132 BuildRequires:  python3 >= 3.5
   122 BuildRequires:  python3-devel
   133 BuildRequires:  python3-devel
   123 %endif
   134 %endif
   124 BuildRequires:  rust >= 1.47
       
   125 BuildRequires:  rust-cbindgen >= 0.19.0
   135 BuildRequires:  rust-cbindgen >= 0.19.0
   126 BuildRequires:  unzip
   136 BuildRequires:  unzip
   127 BuildRequires:  update-desktop-files
   137 BuildRequires:  update-desktop-files
   128 BuildRequires:  xorg-x11-libXt-devel
   138 BuildRequires:  xorg-x11-libXt-devel
   129 %if 0%{?do_profiling}
   139 %if 0%{?do_profiling}
   365 sed -i "s/python3/python36/g" configure.in
   375 sed -i "s/python3/python36/g" configure.in
   366 sed -i "s/python3/python36/g" mach
   376 sed -i "s/python3/python36/g" mach
   367 export PYTHON3=/usr/bin/python36
   377 export PYTHON3=/usr/bin/python36
   368 %endif
   378 %endif
   369 
   379 
       
   380 # Webrender does not support big endian yet, so we are forcing it off
       
   381 # see: https://bugzilla.mozilla.org/show_bug.cgi?id=1716707
       
   382 %ifarch s390x ppc64
       
   383 echo 'pref("gfx.webrender.force-disabled", true);' >> %{SOURCE9}
       
   384 %endif
       
   385 
   370 #
   386 #
   371 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   387 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   372 if test "$kdehelperversion" != %{kde_helper_version}; then
   388 if test "$kdehelperversion" != %{kde_helper_version}; then
   373   echo fix kde helper version in the .spec file
   389   echo fix kde helper version in the .spec file
   374   exit 1
   390   exit 1
   650 ##########
   666 ##########
   651 # ADDONS
   667 # ADDONS
   652 #
   668 #
   653 mkdir -p %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
   669 mkdir -p %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
   654 mkdir -p %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
   670 mkdir -p %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
       
   671 # Install symbolic icon for GNOME
   655 %if %branding
   672 %if %branding
   656 # Install symbolic icon for GNOME
       
   657 mkdir -p %{buildroot}%{gnome_dir}/share/icons/hicolor/symbolic/apps/
       
   658 cp %{_builddir}/%{srcname}-%{orig_version}/browser/branding/official/content/identity-icons-brand.svg \
       
   659    %{buildroot}%{gnome_dir}/share/icons/hicolor/symbolic/apps/%{progname}-symbolic.svg
       
   660 for size in 16 22 24 32 48 64 128 256; do
   673 for size in 16 22 24 32 48 64 128 256; do
   661 %else
   674 %else
   662 for size in 16 32 48; do
   675 for size in 16 32 48; do
   663 %endif
   676 %endif
   664   mkdir -p %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/
   677   mkdir -p %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/