MozillaFirefox/MozillaFirefox.spec
changeset 81 c8f7496d60e7
parent 72 09df8552b796
child 83 d06e40a1d7de
equal deleted inserted replaced
80:67e4ee440947 81:c8f7496d60e7
     1 #
     1 #
     2 # spec file for package MozillaFirefox (Version 3.6.4)
     2 # spec file for package MozillaFirefox (Version 3.7a)
     3 #
     3 #
     4 # Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
     5 #               2006-2010 Wolfgang Rosenauer
     5 #               2006-2010 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 
    21 
    22 Name:           MozillaFirefox
    22 Name:           MozillaFirefox
    23 %define xulrunner mozilla-xulrunner192
    23 %define xulrunner mozilla-xulrunner193
    24 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip
    24 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip fdupes Mesa
    25 BuildRequires:  %{xulrunner}-devel = 1.9.2.4
    25 BuildRequires:  %{xulrunner}-devel = 1.9.3a4
    26 %if %suse_version > 1020
       
    27 BuildRequires:  fdupes
       
    28 %endif
       
    29 %if %suse_version > 1110
    26 %if %suse_version > 1110
    30 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
    31 %else
    28 %else
    32 BuildRequires:  wireless-tools
    29 BuildRequires:  wireless-tools
    33 %endif
    30 %endif
    34 License:        GPLv2+ ; LGPLv2.1+ ; MPLv1.1+
    31 License:        GPLv2+ ; LGPLv2.1+ ; MPLv1.1+
    35 Provides:       web_browser
    32 Provides:       web_browser
    36 Provides:       firefox
    33 Provides:       firefox
    37 Version:        3.6.4
    34 Version:        3.7a
    38 Release:        1
    35 Release:        1
    39 %define         releasedate 2010050300
    36 %define         releasedate 2010060800
    40 Summary:        Mozilla Firefox Web Browser
    37 Summary:        Mozilla Firefox Web Browser
    41 Url:            http://www.mozilla.org/
    38 Url:            http://www.mozilla.org/
    42 Group:          Productivity/Networking/Web/Browsers
    39 Group:          Productivity/Networking/Web/Browsers
    43 Source:         firefox-%{version}-source.tar.bz2
    40 Source:         firefox-%{version}-source.tar.bz2
    44 Source1:        MozillaFirefox.desktop
    41 Source1:        MozillaFirefox.desktop
    56 Patch2:         firefox-credits.patch
    53 Patch2:         firefox-credits.patch
    57 Patch3:         toolkit-download-folder.patch
    54 Patch3:         toolkit-download-folder.patch
    58 Patch4:         firefox-linkorder.patch
    55 Patch4:         firefox-linkorder.patch
    59 Patch5:         firefox-browser-css.patch
    56 Patch5:         firefox-browser-css.patch
    60 Patch6:         firefox-cross-desktop.patch
    57 Patch6:         firefox-cross-desktop.patch
    61 Patch7:         firefox-no-gnomevfs.patch
       
    62 Patch8:         firefox-appname.patch
    58 Patch8:         firefox-appname.patch
    63 Patch9:         firefox-kde.patch
    59 Patch9:         firefox-kde.patch
    64 Patch10:        firefox-ui-lockdown.patch
    60 Patch10:        firefox-ui-lockdown.patch
    65 Patch11:        firefox-crashreporter.patch
       
    66 Patch12:        mozilla-crashreporter-x86_64.patch
       
    67 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    61 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    68 Requires(post):   coreutils shared-mime-info desktop-file-utils
    62 Requires(post):   coreutils shared-mime-info desktop-file-utils
    69 Requires(postun): shared-mime-info desktop-file-utils
    63 Requires(postun): shared-mime-info desktop-file-utils
    70 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
    64 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
    71 %requires_eq    %{xulrunner}
    65 %requires_eq    %{xulrunner}
   156 %patch2 -p1
   150 %patch2 -p1
   157 %patch3 -p1
   151 %patch3 -p1
   158 %patch4 -p1
   152 %patch4 -p1
   159 %patch5 -p1
   153 %patch5 -p1
   160 %patch6 -p1
   154 %patch6 -p1
   161 %patch7 -p1
       
   162 %patch8 -p1
   155 %patch8 -p1
   163 %if %suse_version >= 1110
   156 %if %suse_version >= 1110
   164 %patch9 -p1
   157 #%patch9 -p1
   165 # install kde.js
   158 # install kde.js
   166 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   159 #install -m 644 %{SOURCE6} browser/app/profile/kde.js
   167 %endif
   160 %endif
   168 %patch10 -p1
   161 #%patch10 -p1
   169 %patch11 -p1
       
   170 %patch12 -p1
       
   171 
   162 
   172 %build
   163 %build
   173 export MOZ_BUILD_DATE=%{releasedate}
   164 export MOZ_BUILD_DATE=%{releasedate}
   174 export MOZILLA_OFFICIAL=1
   165 export MOZILLA_OFFICIAL=1
   175 export BUILD_OFFICIAL=1
   166 export BUILD_OFFICIAL=1
   176 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"  
   167 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"  
   177 export CXXFLAGS="$CFLAGS"
   168 export CXXFLAGS="$CFLAGS"
   178 # 10.3-x86_64 build fails probably because gcc bug
       
   179 %if %suse_version == 1030
       
   180 %ifarch x86_64
       
   181 export ac_cv_visibility_hidden="no"
       
   182 %endif
       
   183 %endif
       
   184 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   169 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   185 SDKDIR=$(pkg-config --variable=sdkdir libxul)
   170 SDKDIR=$(pkg-config --variable=sdkdir libxul)
   186 cat << EOF > $MOZCONFIG
   171 cat << EOF > $MOZCONFIG
   187 mk_add_options MOZILLA_OFFICIAL=1
   172 mk_add_options MOZILLA_OFFICIAL=1
   188 mk_add_options BUILD_OFFICIAL=1
   173 mk_add_options BUILD_OFFICIAL=1
   191 ac_add_options --prefix=%{_prefix}
   176 ac_add_options --prefix=%{_prefix}
   192 ac_add_options --libdir=%{_libdir}
   177 ac_add_options --libdir=%{_libdir}
   193 ac_add_options --sysconfdir=%{_sysconfdir}
   178 ac_add_options --sysconfdir=%{_sysconfdir}
   194 ac_add_options --mandir=%{_mandir}
   179 ac_add_options --mandir=%{_mandir}
   195 ac_add_options --includedir=%{_includedir}
   180 ac_add_options --includedir=%{_includedir}
   196 ac_add_options --with-system-nspr
   181 #ac_add_options --with-system-nspr
   197 ac_add_options --with-system-nss
   182 ac_add_options --with-system-nss
   198 ac_add_options --with-libxul-sdk=$SDKDIR
   183 ac_add_options --with-libxul-sdk=$SDKDIR
   199 ac_add_options --with-l10n-base=../l10n
   184 ac_add_options --with-l10n-base=../l10n
   200 ac_add_options --with-system-jpeg
   185 ac_add_options --with-system-jpeg
   201 #ac_add_options --with-system-png     # doesn't work because of missing APNG support
   186 #ac_add_options --with-system-png     # doesn't work because of missing APNG support