mozilla-xulrunner20/mozilla-xulrunner20.spec
changeset 141 d493b01be9e2
parent 138 d04c09ee4ce4
child 146 cf1c79206520
equal deleted inserted replaced
140:c5e051ab6cb8 141:d493b01be9e2
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 
    21 
    22 Name:           mozilla-xulrunner20
    22 Name:           mozilla-xulrunner20
    23 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel zip pkg-config fdupes hunspell-devel yasm Mesa-devel
    23 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel zip pkg-config fdupes hunspell-devel yasm Mesa-devel nss-shared-helper-devel
    24 # needed for brp-check-bytecode-version (jar, fastjar would do as well)
    24 # needed for brp-check-bytecode-version (jar, fastjar would do as well)
    25 BuildRequires:  unzip
    25 BuildRequires:  unzip
    26 %if %suse_version > 1100
       
    27 BuildRequires:  nss-shared-helper-devel
       
    28 %endif
       
    29 %if %suse_version > 1110
    26 %if %suse_version > 1110
    30 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
    31 BuildRequires:  libproxy-devel
    28 BuildRequires:  libproxy-devel
    32 %else
    29 %else
    33 BuildRequires:  wireless-tools
    30 BuildRequires:  wireless-tools
    42 Summary:        Mozilla Runtime Environment 2.0
    39 Summary:        Mozilla Runtime Environment 2.0
    43 Url:            http://www.mozilla.org
    40 Url:            http://www.mozilla.org
    44 Group:          Productivity/Other
    41 Group:          Productivity/Other
    45 Provides:       gecko20
    42 Provides:       gecko20
    46 Obsoletes:      mozilla-xulrunner193
    43 Obsoletes:      mozilla-xulrunner193
    47 %if %suse_version >= 1110
       
    48 # this is needed to match this package with the kde4 helper package without the main package
    44 # this is needed to match this package with the kde4 helper package without the main package
    49 # having a hard requirement on the kde4 package
    45 # having a hard requirement on the kde4 package
    50 %define kde_helper_version 6
    46 %define kde_helper_version 6
    51 Provides:       mozilla-kde4-version = %{kde_helper_version}
    47 Provides:       mozilla-kde4-version = %{kde_helper_version}
    52 %endif
       
    53 %ifarch %ix86
    48 %ifarch %ix86
    54 Provides:       mozilla-xulrunner20-32bit = %{version}-%{release}
    49 Provides:       mozilla-xulrunner20-32bit = %{version}-%{release}
    55 %endif
    50 %endif
    56 Source:         xulrunner-source-%{version}.tar.bz2
    51 Source:         xulrunner-source-%{version}.tar.bz2
    57 Source1:        l10n-%{version}.tar.bz2
    52 Source1:        l10n-%{version}.tar.bz2
   209 %patch3 -p1
   204 %patch3 -p1
   210 %patch4 -p1
   205 %patch4 -p1
   211 %patch5 -p1
   206 %patch5 -p1
   212 %patch7 -p1
   207 %patch7 -p1
   213 %patch8 -p1
   208 %patch8 -p1
   214 %if %suse_version >= 1110
       
   215 %patch10 -p1
   209 %patch10 -p1
   216 %endif
       
   217 #%patch11 -p1
   210 #%patch11 -p1
   218 #%patch12 -p1
   211 #%patch12 -p1
   219 #%patch13 -p1
   212 #%patch13 -p1
   220 %if %suse_version < 1120
   213 %if %suse_version < 1120
   221 %patch14 -p1
   214 %patch14 -p1
   222 %endif
   215 %endif
   223 
   216 
   224 %build
   217 %build
   225 %if %suse_version >= 1110
       
   226 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   218 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   227 if test "$kdehelperversion" != %{kde_helper_version}; then
   219 if test "$kdehelperversion" != %{kde_helper_version}; then
   228   echo fix kde helper version in the .spec file
   220   echo fix kde helper version in the .spec file
   229   exit 1
   221   exit 1
   230 fi
   222 fi
   231 %endif
       
   232 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   223 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   233 export MOZ_BUILD_DATE=%{releasedate}
   224 export MOZ_BUILD_DATE=%{releasedate}
   234 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   225 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   235 %ifarch ppc64
   226 %ifarch ppc64
   236 export CFLAGS="$CFLAGS -mminimal-toc"
   227 export CFLAGS="$CFLAGS -mminimal-toc"