MozillaFirefox/MozillaFirefox.spec
branchfirefox41
changeset 884 d9d863421693
parent 883 7aa7715fdc8f
child 885 ee3c462047d5
equal deleted inserted replaced
883:7aa7715fdc8f 884:d9d863421693
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 41
    21 %define major 41
    22 %define mainver %major.0
    22 %define mainver %major.0.2
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 2015091800
    24 %define releasedate 2015101500
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
   105 Provides:       firefox = %{mainver}
   105 Provides:       firefox = %{mainver}
   106 Provides:       firefox = %{version}-%{release}
   106 Provides:       firefox = %{version}-%{release}
   107 %endif
   107 %endif
   108 Provides:       web_browser
   108 Provides:       web_browser
   109 Provides:       browser(npapi)
   109 Provides:       browser(npapi)
       
   110 %if "%{update_channel}" != "aurora"
       
   111 Provides:       appdata()
       
   112 Provides:       appdata(firefox.appdata.xml)
       
   113 %endif
   110 # this is needed to match this package with the kde4 helper package without the main package
   114 # this is needed to match this package with the kde4 helper package without the main package
   111 # having a hard requirement on the kde4 package
   115 # having a hard requirement on the kde4 package
   112 %define kde_helper_version 6
   116 %define kde_helper_version 6
   113 Provides:       mozilla-kde4-version = %{kde_helper_version}
   117 Provides:       mozilla-kde4-version = %{kde_helper_version}
   114 Summary:        Mozilla %{appname} Web Browser
   118 Summary:        Mozilla %{appname} Web Browser
   310 ac_add_options --libdir=%{_libdir}
   314 ac_add_options --libdir=%{_libdir}
   311 ac_add_options --sysconfdir=%{_sysconfdir}
   315 ac_add_options --sysconfdir=%{_sysconfdir}
   312 ac_add_options --mandir=%{_mandir}
   316 ac_add_options --mandir=%{_mandir}
   313 ac_add_options --includedir=%{_includedir}
   317 ac_add_options --includedir=%{_includedir}
   314 ac_add_options --enable-release
   318 ac_add_options --enable-release
   315 ac_add_options --enable-stdcxx-compat
       
   316 %ifarch %ix86 %arm
   319 %ifarch %ix86 %arm
   317 %if 0%{?suse_version} > 1230
   320 %if 0%{?suse_version} > 1230
   318 ac_add_options --disable-optimize
   321 ac_add_options --disable-optimize
   319 %endif
   322 %endif
   320 %endif
   323 %endif