MozillaFirefox/MozillaFirefox.spec
changeset 279 eb9e33036fb4
parent 277 37db3d6540b8
child 281 0bdc059f7280
equal deleted inserted replaced
277:37db3d6540b8 279:eb9e33036fb4
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011053000
    38 %define         releasedate 2011061300
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
    49 Source:         firefox-%{version}-source.tar.bz2
    49 Source:         firefox-%{version}-source.tar.bz2
    50 Source1:        MozillaFirefox.desktop
    50 Source1:        MozillaFirefox.desktop
    51 Source2:        MozillaFirefox-rpmlintrc
    51 Source2:        MozillaFirefox-rpmlintrc
    52 Source3:        mozilla.sh.in
    52 Source3:        mozilla.sh.in
    53 Source4:        find-external-requires.sh
    53 Source4:        find-external-requires.sh
       
    54 Source5:        source-stamp.txt
    54 Source6:        kde.js
    55 Source6:        kde.js
    55 Source7:        l10n-%{version}.tar.bz2
    56 Source7:        l10n-%{version}.tar.bz2
    56 Source8:        firefox-mimeinfo.xml
    57 Source8:        firefox-mimeinfo.xml
    57 Source10:       compare-locales.tar.bz2
    58 Source10:       compare-locales.tar.bz2
    58 Source11:       firefox.1
    59 Source11:       firefox.1
    69 Patch7:         mozilla-language.patch
    70 Patch7:         mozilla-language.patch
    70 Patch8:         mozilla-gio.patch
    71 Patch8:         mozilla-gio.patch
    71 Patch9:         mozilla-cairo-return.patch
    72 Patch9:         mozilla-cairo-return.patch
    72 Patch10:        mozilla-ntlm-full-path.patch
    73 Patch10:        mozilla-ntlm-full-path.patch
    73 Patch11:        mozilla-ppc-ipc.patch
    74 Patch11:        mozilla-ppc-ipc.patch
       
    75 Patch12:        mozilla-repo.patch
    74 # Firefox/browser
    76 # Firefox/browser
    75 Patch30:        firefox-linkorder.patch
    77 Patch30:        firefox-linkorder.patch
    76 Patch31:        firefox-browser-css.patch
    78 Patch31:        firefox-browser-css.patch
    77 Patch32:        firefox-cross-desktop.patch
    79 Patch32:        firefox-cross-desktop.patch
    78 Patch33:        firefox-kde.patch
    80 Patch33:        firefox-kde.patch
   199 %patch7 -p1
   201 %patch7 -p1
   200 %patch8 -p1
   202 %patch8 -p1
   201 %patch9 -p1
   203 %patch9 -p1
   202 %patch10 -p1
   204 %patch10 -p1
   203 %patch11 -p1
   205 %patch11 -p1
       
   206 %patch12 -p1
   204 #
   207 #
   205 %patch30 -p1
   208 %patch30 -p1
   206 %patch31 -p1
   209 %patch31 -p1
   207 %patch32 -p1
   210 %patch32 -p1
   208 %if %suse_version >= 1110
   211 %if %suse_version >= 1110
   229 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   232 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   230 if test "$kdehelperversion" != %{kde_helper_version}; then
   233 if test "$kdehelperversion" != %{kde_helper_version}; then
   231   echo fix kde helper version in the .spec file
   234   echo fix kde helper version in the .spec file
   232   exit 1
   235   exit 1
   233 fi
   236 fi
       
   237 source %{SOURCE5}
       
   238 export MOZ_SOURCE_STAMP=$REV
       
   239 export SOURCE_REPO=$REPO
       
   240 export MOZ_SOURCE_REPO=$REPO
   234 export MOZ_BUILD_DATE=%{releasedate}
   241 export MOZ_BUILD_DATE=%{releasedate}
   235 export MOZILLA_OFFICIAL=1
   242 export MOZILLA_OFFICIAL=1
   236 export BUILD_OFFICIAL=1
   243 export BUILD_OFFICIAL=1
   237 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   244 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   238 %ifarch ppc64
   245 %ifarch ppc64
   288 make -f client.mk build
   295 make -f client.mk build
   289 
   296 
   290 %install
   297 %install
   291 cd $RPM_BUILD_DIR/obj
   298 cd $RPM_BUILD_DIR/obj
   292 rm dist/bin/defaults/pref/firefox-l10n.js
   299 rm dist/bin/defaults/pref/firefox-l10n.js
       
   300 source %{SOURCE5}
       
   301 export MOZ_SOURCE_STAMP=$REV
       
   302 export MOZ_SOURCE_REPO=$REPO
   293 make -C browser/installer STRIP=/bin/true
   303 make -C browser/installer STRIP=/bin/true
   294 # copy tree into RPM_BUILD_ROOT
   304 # copy tree into RPM_BUILD_ROOT
   295 mkdir -p $RPM_BUILD_ROOT/%{progdir}
   305 mkdir -p $RPM_BUILD_ROOT/%{progdir}
   296 cp -rf $RPM_BUILD_DIR/obj/dist/firefox/* $RPM_BUILD_ROOT%{progdir}
   306 cp -rf $RPM_BUILD_DIR/obj/dist/firefox/* $RPM_BUILD_ROOT%{progdir}
   297 mkdir -p $RPM_BUILD_ROOT/%{progdir}/distribution/extensions
   307 mkdir -p $RPM_BUILD_ROOT/%{progdir}/distribution/extensions