MozillaFirefox/MozillaFirefox.spec
branchfirefox66
changeset 1089 eca1c1f2fe50
parent 1087 5fab52cd743d
child 1092 5d7b22f6b177
equal deleted inserted replaced
1087:5fab52cd743d 1089:eca1c1f2fe50
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          65
    21 %define major          66
    22 %define mainver        %major.0.1
    22 %define mainver        %major.0
    23 %define orig_version   65.0.1
    23 %define orig_version   66.0
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20190211233335
    27 %define releasedate    20190314174725
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # always build with GCC as SUSE Security Team requires that
    30 # always build with GCC as SUSE Security Team requires that
    31 %define clang_build 0
    31 %define clang_build 0
    32 
    32 
    67 %if 0%{?suse_version} <= 1320
    67 %if 0%{?suse_version} <= 1320
    68 BuildRequires:  gcc7-c++
    68 BuildRequires:  gcc7-c++
    69 %else
    69 %else
    70 BuildRequires:  gcc-c++
    70 BuildRequires:  gcc-c++
    71 %endif
    71 %endif
    72 BuildRequires:  cargo >= 1.30
    72 BuildRequires:  cargo >= 1.31
    73 BuildRequires:  libXcomposite-devel
    73 BuildRequires:  libXcomposite-devel
    74 BuildRequires:  libcurl-devel
    74 BuildRequires:  libcurl-devel
    75 BuildRequires:  libidl-devel
    75 BuildRequires:  libidl-devel
    76 BuildRequires:  libiw-devel
    76 BuildRequires:  libiw-devel
    77 BuildRequires:  libnotify-devel
    77 BuildRequires:  libnotify-devel
    78 BuildRequires:  libproxy-devel
    78 BuildRequires:  libproxy-devel
    79 BuildRequires:  makeinfo
    79 BuildRequires:  makeinfo
    80 BuildRequires:  mozilla-nspr-devel >= 4.20
    80 BuildRequires:  mozilla-nspr-devel >= 4.20
    81 BuildRequires:  mozilla-nss-devel >= 3.41
    81 BuildRequires:  mozilla-nss-devel >= 3.42.1
       
    82 BuildRequires:  nasm >= 2.13
    82 BuildRequires:  nodejs >= 8.11
    83 BuildRequires:  nodejs >= 8.11
    83 BuildRequires:  python-devel
    84 BuildRequires:  python-devel
    84 BuildRequires:  python2-xml
    85 BuildRequires:  python2-xml
    85 BuildRequires:  python3 >= 3.5
    86 BuildRequires:  python3 >= 3.5
    86 BuildRequires:  rust >= 1.30
    87 BuildRequires:  rust >= 1.31
    87 BuildRequires:  rust-cbindgen >= 0.6.7
    88 BuildRequires:  rust-cbindgen >= 0.6.8
    88 BuildRequires:  startup-notification-devel
    89 BuildRequires:  startup-notification-devel
    89 BuildRequires:  unzip
    90 BuildRequires:  unzip
    90 BuildRequires:  update-desktop-files
    91 BuildRequires:  update-desktop-files
    91 BuildRequires:  xorg-x11-libXt-devel
    92 BuildRequires:  xorg-x11-libXt-devel
    92 BuildRequires:  yasm
    93 BuildRequires:  yasm
   158 Patch1:         mozilla-nongnome-proxies.patch
   159 Patch1:         mozilla-nongnome-proxies.patch
   159 Patch2:         mozilla-kde.patch
   160 Patch2:         mozilla-kde.patch
   160 Patch3:         mozilla-ntlm-full-path.patch
   161 Patch3:         mozilla-ntlm-full-path.patch
   161 Patch4:         mozilla-openaes-decl.patch
   162 Patch4:         mozilla-openaes-decl.patch
   162 Patch7:         mozilla-aarch64-startup-crash.patch
   163 Patch7:         mozilla-aarch64-startup-crash.patch
   163 Patch8:         mozilla-bmo256180.patch
       
   164 Patch9:         mozilla-bmo1463035.patch
   164 Patch9:         mozilla-bmo1463035.patch
   165 Patch10:        mozilla-cubeb-noreturn.patch
   165 Patch10:        mozilla-cubeb-noreturn.patch
   166 # Firefox/browser
   166 # Firefox/browser
   167 Patch101:       firefox-kde.patch
   167 Patch101:       firefox-kde.patch
   168 Patch102:       firefox-branded-icons.patch
   168 Patch102:       firefox-branded-icons.patch
   265 %patch1 -p1
   265 %patch1 -p1
   266 %patch2 -p1
   266 %patch2 -p1
   267 %patch3 -p1
   267 %patch3 -p1
   268 %patch4 -p1
   268 %patch4 -p1
   269 %patch7 -p1
   269 %patch7 -p1
   270 %patch8 -p1
       
   271 %patch9 -p1
   270 %patch9 -p1
   272 %patch10 -p1
   271 %patch10 -p1
   273 # Firefox
   272 # Firefox
   274 %patch101 -p1
   273 %patch101 -p1
   275 %patch102 -p1
   274 %patch102 -p1
   357 ac_add_options --disable-debug
   356 ac_add_options --disable-debug
   358 ac_add_options --enable-startup-notification
   357 ac_add_options --enable-startup-notification
   359 #ac_add_options --enable-chrome-format=jar
   358 #ac_add_options --enable-chrome-format=jar
   360 ac_add_options --enable-update-channel=%{update_channel}
   359 ac_add_options --enable-update-channel=%{update_channel}
   361 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   360 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   362 ac_add_options --with-google-api-keyfile=%{SOURCE19}
   361 ac_add_options --with-google-location-service-api-keyfile=%{SOURCE19}
       
   362 ac_add_options --with-google-safebrowsing-api-keyfile=%{SOURCE19}
   363 ac_add_options --with-unsigned-addon-scopes=app
   363 ac_add_options --with-unsigned-addon-scopes=app
   364 %if %branding
   364 %if %branding
   365 ac_add_options --enable-official-branding
   365 ac_add_options --enable-official-branding
   366 %endif
   366 %endif
   367 ac_add_options --enable-libproxy
   367 ac_add_options --enable-libproxy