MozillaFirefox/MozillaFirefox.spec
branchfirefox65
changeset 1086 ed1c30c5f456
parent 1085 87f893cf45b9
child 1087 5fab52cd743d
equal deleted inserted replaced
1085:87f893cf45b9 1086:ed1c30c5f456
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          65
    21 %define major          65
    22 %define mainver        %major.0
    22 %define mainver        %major.0.1
    23 %define orig_version   65.0
    23 %define orig_version   65.0.1
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20190124174741
    27 %define releasedate    20190211233335
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # always build with GCC as SUSE Security Team requires that
    30 # always build with GCC as SUSE Security Team requires that
    31 %define clang_build 0
    31 %define clang_build 0
    32 
    32 
   157 # Gecko/Toolkit
   157 # Gecko/Toolkit
   158 Patch1:         mozilla-nongnome-proxies.patch
   158 Patch1:         mozilla-nongnome-proxies.patch
   159 Patch2:         mozilla-kde.patch
   159 Patch2:         mozilla-kde.patch
   160 Patch3:         mozilla-ntlm-full-path.patch
   160 Patch3:         mozilla-ntlm-full-path.patch
   161 Patch4:         mozilla-openaes-decl.patch
   161 Patch4:         mozilla-openaes-decl.patch
   162 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
       
   163 Patch7:         mozilla-aarch64-startup-crash.patch
   162 Patch7:         mozilla-aarch64-startup-crash.patch
   164 Patch8:         mozilla-bmo256180.patch
   163 Patch8:         mozilla-bmo256180.patch
   165 Patch9:         mozilla-bmo1463035.patch
   164 Patch9:         mozilla-bmo1463035.patch
   166 Patch10:        mozilla-cubeb-noreturn.patch
   165 Patch10:        mozilla-cubeb-noreturn.patch
   167 # Firefox/browser
   166 # Firefox/browser
   265 cd $RPM_BUILD_DIR/%{source_prefix}
   264 cd $RPM_BUILD_DIR/%{source_prefix}
   266 %patch1 -p1
   265 %patch1 -p1
   267 %patch2 -p1
   266 %patch2 -p1
   268 %patch3 -p1
   267 %patch3 -p1
   269 %patch4 -p1
   268 %patch4 -p1
   270 %ifarch %ix86
       
   271 %patch6 -p1
       
   272 %endif
       
   273 %patch7 -p1
   269 %patch7 -p1
   274 %patch8 -p1
   270 %patch8 -p1
   275 %patch9 -p1
   271 %patch9 -p1
   276 %patch10 -p1
   272 %patch10 -p1
   277 # Firefox
   273 # Firefox
   381 ac_add_options --with-arch=armv7-a
   377 ac_add_options --with-arch=armv7-a
   382 %endif
   378 %endif
   383 %endif
   379 %endif
   384 %ifarch aarch64 %arm s390x
   380 %ifarch aarch64 %arm s390x
   385 ac_add_options --disable-webrtc
   381 ac_add_options --disable-webrtc
       
   382 %endif
       
   383 %ifarch x86_64
       
   384 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
       
   385 %if 0%{?suse_version} > 1500
       
   386 ac_add_options --enable-lto
       
   387 %endif
   386 %endif
   388 %endif
   387 EOF
   389 EOF
   388 ./mach build
   390 ./mach build
   389 
   391 
   390 %install
   392 %install