mozilla-xulrunner192/mozilla-xulrunner192.spec
changeset 28 ed2afa8e733c
parent 24 ca988be0905b
child 32 e26339117f38
equal deleted inserted replaced
27:23cf7aafb85b 28:ed2afa8e733c
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 
    21 
    22 Name:           mozilla-xulrunner192
    22 Name:           mozilla-xulrunner192
    23 BuildRequires:  autoconf213 gcc-c++ libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel zip
    23 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel zip
    24 # needed for brp-check-bytecode-version (jar, fastjar would do as well)
    24 # needed for brp-check-bytecode-version (jar, fastjar would do as well)
    25 BuildRequires:  unzip
    25 BuildRequires:  unzip
    26 %if %suse_version > 1020
    26 %if %suse_version > 1020
    27 BuildRequires:  fdupes
    27 BuildRequires:  fdupes
    28 %endif
    28 %endif
    79 # PATCH-FEATURE-SLED FATE#302023, FATE#302024
    79 # PATCH-FEATURE-SLED FATE#302023, FATE#302024
    80 Patch11:        mozilla-gconf-backend.patch
    80 Patch11:        mozilla-gconf-backend.patch
    81 Patch12:        gecko-lockdown.patch
    81 Patch12:        gecko-lockdown.patch
    82 Patch13:        toolkit-ui-lockdown.patch
    82 Patch13:        toolkit-ui-lockdown.patch
    83 # ---
    83 # ---
       
    84 Patch14:        mozilla-breakpad.patch
    84 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    85 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    85 PreReq:         update-alternatives coreutils
    86 PreReq:         update-alternatives coreutils
    86 ### build configuration ###
    87 ### build configuration ###
       
    88 %ifarch %ix86
       
    89 %define crashreporter    1
       
    90 %endif
    87 %define has_system_nspr  0
    91 %define has_system_nspr  0
    88 %define has_system_nss   0
    92 %define has_system_nss   0
    89 %define has_system_cairo 0
    93 %define has_system_cairo 0
    90 %define localize 1
    94 %define localize 1
    91 %if %suse_version > 1030 || 0%{?opensuse_bs}
    95 %if %suse_version > 1030 || 0%{?opensuse_bs}
   174 %description gnome
   178 %description gnome
   175 This subpackage contains the Necko Gnome-VFS and Gnome components which
   179 This subpackage contains the Necko Gnome-VFS and Gnome components which
   176 rely on the gnome-vfs subsystem to be installed. They are recommended
   180 rely on the gnome-vfs subsystem to be installed. They are recommended
   177 for full desktop integration but not mandatory for small disk footprint
   181 for full desktop integration but not mandatory for small disk footprint
   178 KDE installations for example.
   182 KDE installations for example.
       
   183 
       
   184 
       
   185 %if 0%{?crashreporter}
       
   186 %package buildsymbols
       
   187 License:        GPLv2+ ; LGPLv2.1+ ; MPLv1.1+
       
   188 Summary:        Breakpad buildsymbols for %{name}
       
   189 Group:          Development/Debug
       
   190 
       
   191 %description buildsymbols
       
   192 This subpackage contains the Breakpad created and compatible debugging
       
   193 symbols meant for upload to Mozilla's crash collector database.
       
   194 %endif
   179 
   195 
   180 
   196 
   181 %prep
   197 %prep
   182 %setup -n mozilla -q -b 1
   198 %setup -n mozilla -q -b 1
   183 %patch1 -p1
   199 %patch1 -p1
   193 %patch10 -p1
   209 %patch10 -p1
   194 %endif
   210 %endif
   195 #%patch11 -p1
   211 #%patch11 -p1
   196 #%patch12 -p1
   212 #%patch12 -p1
   197 #%patch13 -p1
   213 #%patch13 -p1
       
   214 %patch14 -p1
   198 
   215 
   199 %build
   216 %build
   200 %if %suse_version >= 1110
   217 %if %suse_version >= 1110
   201 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   218 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   202 if test "$kdehelperversion" != %{kde_helper_version}; then
   219 if test "$kdehelperversion" != %{kde_helper_version}; then
   205 fi
   222 fi
   206 %endif
   223 %endif
   207 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   224 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
   208 export MOZ_BUILD_DATE=%{releasedate}
   225 export MOZ_BUILD_DATE=%{releasedate}
   209 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   226 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   227 %if 0%{?crashreporter}
       
   228 export CFLAGS="$CFLAGS -gstabs+"
       
   229 %endif
   210 %ifarch ppc64
   230 %ifarch ppc64
   211 export CFLAGS="$CFLAGS -mminimal-toc"
   231 export CFLAGS="$CFLAGS -mminimal-toc"
   212 %endif
   232 %endif
   213 # 10.3-x86_64 build fails probably because gcc bug
   233 # 10.3-x86_64 build fails probably because gcc bug
   214 %if %suse_version == 1030
   234 %if %suse_version == 1030
   247 ac_add_options --disable-tests
   267 ac_add_options --disable-tests
   248 ac_add_options --disable-mochitest
   268 ac_add_options --disable-mochitest
   249 ac_add_options --disable-installer
   269 ac_add_options --disable-installer
   250 ac_add_options --disable-updater
   270 ac_add_options --disable-updater
   251 ac_add_options --disable-javaxpcom
   271 ac_add_options --disable-javaxpcom
   252 ac_add_options --disable-crashreporter
       
   253 ac_add_options --enable-startup-notification
   272 ac_add_options --enable-startup-notification
   254 ac_add_options --enable-url-classifier
   273 ac_add_options --enable-url-classifier
   255 #ac_add_options --enable-debug
   274 #ac_add_options --enable-debug
   256 EOF
   275 EOF
   257 %if %has_system_nspr
   276 %if %has_system_nspr
   360 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/.autoreg
   379 touch $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/.autoreg
   361 # fdupes
   380 # fdupes
   362 %if %suse_version > 1020
   381 %if %suse_version > 1020
   363 %fdupes $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal}/
   382 %fdupes $RPM_BUILD_ROOT%{_includedir}/xulrunner-%{version_internal}/
   364 %fdupes $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/
   383 %fdupes $RPM_BUILD_ROOT%{_libdir}/xulrunner-%{version_internal}/
       
   384 %endif
       
   385 # create breakpad debugsymbols
       
   386 %if 0%{?crashreporter}
       
   387 make buildsymbols
       
   388 if [ -e dist/*.crashreporter-symbols.zip ]; then
       
   389   mkdir -p $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   390   cp dist/*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_datadir}/mozilla/
       
   391 fi
   365 %endif
   392 %endif
   366 
   393 
   367 %clean
   394 %clean
   368 rm -rf $RPM_BUILD_ROOT
   395 rm -rf $RPM_BUILD_ROOT
   369 %if %localize
   396 %if %localize
   435 %{_libdir}/xulrunner-%{version_internal}/*.so
   462 %{_libdir}/xulrunner-%{version_internal}/*.so
   436 %{_libdir}/xulrunner-%{version_internal}/.autoreg
   463 %{_libdir}/xulrunner-%{version_internal}/.autoreg
   437 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
   464 %{_libdir}/xulrunner-%{version_internal}/add-plugins.sh
   438 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
   465 %{_libdir}/xulrunner-%{version_internal}/dependentlibs.list
   439 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
   466 %{_libdir}/xulrunner-%{version_internal}/mozilla-xremote-client
   440 %if !%has_system_nss
       
   441 %{_libdir}/xulrunner-%{version_internal}/libsoftokn3.chk
       
   442 %{_libdir}/xulrunner-%{version_internal}/libfreebl3.chk
       
   443 %endif
       
   444 %{_libdir}/xulrunner-%{version_internal}/run-mozilla.sh
   467 %{_libdir}/xulrunner-%{version_internal}/run-mozilla.sh
   445 %{_libdir}/xulrunner-%{version_internal}/xulrunner
   468 %{_libdir}/xulrunner-%{version_internal}/xulrunner
   446 %{_libdir}/xulrunner-%{version_internal}/xulrunner-bin
   469 %{_libdir}/xulrunner-%{version_internal}/xulrunner-bin
   447 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
   470 %{_libdir}/xulrunner-%{version_internal}/xulrunner-stub
   448 %{_libdir}/xulrunner-%{version_internal}/platform.ini
   471 %{_libdir}/xulrunner-%{version_internal}/platform.ini
   449 #%{_libdir}/xulrunner-%{version_internal}/javaxpcom.jar
   472 # crashreporter files
       
   473 %if 0%{?crashreporter}
       
   474 %{_libdir}/xulrunner-%{version_internal}/crashreporter
       
   475 %{_libdir}/xulrunner-%{version_internal}/crashreporter.ini
       
   476 %{_libdir}/xulrunner-%{version_internal}/Throbber-small.gif
       
   477 %endif
   450 # ghosts
   478 # ghosts
   451 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
   479 %ghost %{_libdir}/xulrunner-%{version_internal}/global.reginfo
   452 # GRE
   480 # GRE
   453 %dir %{_sysconfdir}/gre.d/
   481 %dir %{_sysconfdir}/gre.d/
   454 %attr(644,root,root) %{_sysconfdir}/gre.d/*
   482 %attr(644,root,root) %{_sysconfdir}/gre.d/*
   455 # example
       
   456 #%{_libdir}/xulrunner-%{version_internal}/simple/
       
   457 # API symlink
   483 # API symlink
   458 %{_libdir}/xulrunner-%{apiversion}
   484 %{_libdir}/xulrunner-%{apiversion}
   459 # compat symlinks
   485 # compat symlinks
   460 %if 0%{?ga_version:1} 
   486 %if 0%{?ga_version:1} 
   461 %ghost %{_libdir}/xulrunner-%{ga_version}
   487 %ghost %{_libdir}/xulrunner-%{ga_version}
   462 %endif
   488 %endif
   463 
   489 
   464 %files devel
   490 %files devel
   465 %defattr(-,root,root)
   491 %defattr(-,root,root)
   466 #%{_libdir}/xulrunner-%{version_internal}/MozillaInterfaces*
       
   467 %{_libdir}/xulrunner-%{version_internal}/xpcshell
   492 %{_libdir}/xulrunner-%{version_internal}/xpcshell
   468 %{_libdir}/xulrunner-%{version_internal}/xpidl
   493 %{_libdir}/xulrunner-%{version_internal}/xpidl
   469 %{_libdir}/xulrunner-%{version_internal}/xpt_dump
   494 %{_libdir}/xulrunner-%{version_internal}/xpt_dump
   470 %{_libdir}/xulrunner-%{version_internal}/xpt_link
   495 %{_libdir}/xulrunner-%{version_internal}/xpt_link
   471 %{_libdir}/xulrunner-devel-%{version_internal}/
   496 %{_libdir}/xulrunner-devel-%{version_internal}/
   484 
   509 
   485 %files translations-other -f %{_tmppath}/translations.other
   510 %files translations-other -f %{_tmppath}/translations.other
   486 %defattr(-,root,root)
   511 %defattr(-,root,root)
   487 %endif
   512 %endif
   488 
   513 
       
   514 %if 0%{?crashreporter}
       
   515 %files buildsymbols
       
   516 %defattr(-,root,root)
       
   517 %{_datadir}/mozilla/
       
   518 %endif
       
   519 
   489 %changelog
   520 %changelog