MozillaFirefox/MozillaFirefox.spec
changeset 885 ee3c462047d5
parent 884 d9d863421693
child 886 2e9f984bca7f
equal deleted inserted replaced
882:82af81b0a6c7 885:ee3c462047d5
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 40
    21 %define major 41
    22 %define mainver %major.99
    22 %define mainver %major.99
    23 %define update_channel beta
    23 %define update_channel beta
    24 %define releasedate 2015091100
    24 %define releasedate 2015103000
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
    74 BuildRequires:  libidl-devel
    74 BuildRequires:  libidl-devel
    75 BuildRequires:  libiw-devel
    75 BuildRequires:  libiw-devel
    76 BuildRequires:  libnotify-devel
    76 BuildRequires:  libnotify-devel
    77 BuildRequires:  libproxy-devel
    77 BuildRequires:  libproxy-devel
    78 BuildRequires:  makeinfo
    78 BuildRequires:  makeinfo
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.8
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.10
    80 BuildRequires:  mozilla-nss-devel >= 3.19.2
    80 BuildRequires:  mozilla-nss-devel >= 3.19.4
    81 BuildRequires:  nss-shared-helper-devel
    81 BuildRequires:  nss-shared-helper-devel
    82 BuildRequires:  python-devel
    82 BuildRequires:  python-devel
    83 BuildRequires:  startup-notification-devel
    83 BuildRequires:  startup-notification-devel
    84 BuildRequires:  unzip
    84 BuildRequires:  unzip
    85 BuildRequires:  update-desktop-files
    85 BuildRequires:  update-desktop-files
   105 Provides:       firefox = %{mainver}
   105 Provides:       firefox = %{mainver}
   106 Provides:       firefox = %{version}-%{release}
   106 Provides:       firefox = %{version}-%{release}
   107 %endif
   107 %endif
   108 Provides:       web_browser
   108 Provides:       web_browser
   109 Provides:       browser(npapi)
   109 Provides:       browser(npapi)
       
   110 %if "%{update_channel}" != "aurora"
       
   111 Provides:       appdata()
       
   112 Provides:       appdata(firefox.appdata.xml)
       
   113 %endif
   110 # this is needed to match this package with the kde4 helper package without the main package
   114 # this is needed to match this package with the kde4 helper package without the main package
   111 # having a hard requirement on the kde4 package
   115 # having a hard requirement on the kde4 package
   112 %define kde_helper_version 6
   116 %define kde_helper_version 6
   113 Provides:       mozilla-kde4-version = %{kde_helper_version}
   117 Provides:       mozilla-kde4-version = %{kde_helper_version}
   114 Summary:        Mozilla %{appname} Web Browser
   118 Summary:        Mozilla %{appname} Web Browser
   131 Source13:       spellcheck.js
   135 Source13:       spellcheck.js
   132 Source14:       create-tar.sh
   136 Source14:       create-tar.sh
   133 Source15:       firefox-appdata.xml
   137 Source15:       firefox-appdata.xml
   134 Source16:       MozillaFirefox.changes
   138 Source16:       MozillaFirefox.changes
   135 # Gecko/Toolkit
   139 # Gecko/Toolkit
   136 Patch1:         toolkit-download-folder.patch
   140 Patch1:         mozilla-nongnome-proxies.patch
   137 Patch2:         mozilla-nongnome-proxies.patch
   141 Patch2:         mozilla-shared-nss-db.patch
   138 Patch4:         mozilla-shared-nss-db.patch
   142 Patch3:         mozilla-kde.patch
   139 Patch5:         mozilla-kde.patch
   143 Patch4:         mozilla-preferences.patch
   140 Patch6:         mozilla-preferences.patch
   144 Patch5:         mozilla-language.patch
   141 Patch7:         mozilla-language.patch
   145 Patch6:         mozilla-ntlm-full-path.patch
   142 Patch8:         mozilla-ntlm-full-path.patch
   146 Patch7:         mozilla-repo.patch
   143 Patch9:         mozilla-repo.patch
   147 Patch8:         mozilla-openaes-decl.patch
   144 Patch10:        mozilla-icu-strncat.patch
   148 Patch9:         mozilla-bmo1005535.patch
   145 Patch11:        mozilla-arm-disable-edsp.patch
   149 Patch10:        mozilla-no-stdcxx-check.patch
   146 Patch12:        mozilla-openaes-decl.patch
   150 Patch11:        mozilla-libproxy.patch
   147 Patch14:        mozilla-skia-be-le.patch
       
   148 Patch15:        mozilla-bmo1005535.patch
       
   149 Patch16:        mozilla-no-stdcxx-check.patch
       
   150 # Firefox/browser
   151 # Firefox/browser
   151 Patch101:       firefox-kde.patch
   152 Patch101:       firefox-kde.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   153 Patch102:       firefox-no-default-ualocale.patch
   153 Patch103:       firefox-branded-icons.patch
   154 Patch103:       firefox-branded-icons.patch
   154 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   155 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   246 %setup -q -n mozilla
   247 %setup -q -n mozilla
   247 %endif
   248 %endif
   248 cd $RPM_BUILD_DIR/mozilla
   249 cd $RPM_BUILD_DIR/mozilla
   249 %patch1 -p1
   250 %patch1 -p1
   250 %patch2 -p1
   251 %patch2 -p1
       
   252 %patch3 -p1
   251 %patch4 -p1
   253 %patch4 -p1
   252 %patch5 -p1
   254 %patch5 -p1
   253 %patch6 -p1
   255 %patch6 -p1
   254 %patch7 -p1
   256 %patch7 -p1
   255 %patch8 -p1
   257 %patch8 -p1
   256 %patch9 -p1
   258 #%patch9 -p1
   257 %patch10 -p1
   259 %patch10 -p1
   258 %patch11 -p1
   260 %patch11 -p1
   259 %patch12 -p1
       
   260 %patch14 -p1
       
   261 %patch15 -p1
       
   262 %patch16 -p1
       
   263 # Firefox
   261 # Firefox
   264 %patch101 -p1
   262 %patch101 -p1
   265 %patch102 -p1
   263 %patch102 -p1
   266 %patch103 -p1
   264 %patch103 -p1
   267 
   265 
   310 ac_add_options --libdir=%{_libdir}
   308 ac_add_options --libdir=%{_libdir}
   311 ac_add_options --sysconfdir=%{_sysconfdir}
   309 ac_add_options --sysconfdir=%{_sysconfdir}
   312 ac_add_options --mandir=%{_mandir}
   310 ac_add_options --mandir=%{_mandir}
   313 ac_add_options --includedir=%{_includedir}
   311 ac_add_options --includedir=%{_includedir}
   314 ac_add_options --enable-release
   312 ac_add_options --enable-release
   315 ac_add_options --enable-stdcxx-compat
       
   316 %ifarch %ix86 %arm
   313 %ifarch %ix86 %arm
   317 %if 0%{?suse_version} > 1230
   314 %if 0%{?suse_version} > 1230
   318 ac_add_options --disable-optimize
   315 ac_add_options --disable-optimize
   319 %endif
   316 %endif
   320 %endif
   317 %endif