MozillaFirefox/MozillaFirefox.spec
changeset 659 fa96cf6ffd14
parent 653 38c67b6b2f37
child 661 aac91d5705b1
equal deleted inserted replaced
653:38c67b6b2f37 659:fa96cf6ffd14
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 %define major 22
    20 %define major 23
    21 %define mainver %major.98
    21 %define mainver %major.98
    22 %define update_channel aurora
    22 %define update_channel aurora
    23 
    23 
    24 %if %suse_version > 1220
    24 %if %suse_version > 1220
    25 %define gstreamer_ver 0.10
    25 %define gstreamer_ver 0.10
    51 BuildRequires:  wireless-tools
    51 BuildRequires:  wireless-tools
    52 %endif
    52 %endif
    53 BuildRequires:  mozilla-nspr-devel >= 4.10
    53 BuildRequires:  mozilla-nspr-devel >= 4.10
    54 BuildRequires:  mozilla-nss-devel >= 3.15
    54 BuildRequires:  mozilla-nss-devel >= 3.15
    55 BuildRequires:  nss-shared-helper-devel
    55 BuildRequires:  nss-shared-helper-devel
    56 %if %suse_version > 1140
    56 %if %suse_version > 1210
    57 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    57 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    58 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    59 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    60 %endif
    60 %endif
    61 Version:        %{mainver}
    61 Version:        %{mainver}
    62 Release:        0
    62 Release:        0
    63 %define         releasedate 2013061600
    63 %define         releasedate 2013071300
    64 Provides:       firefox = %{mainver}
    64 Provides:       firefox = %{mainver}
    65 Provides:       firefox = %{version}-%{release}
    65 Provides:       firefox = %{version}-%{release}
    66 Provides:       web_browser
    66 Provides:       web_browser
    67 Provides:       browser(npapi)
    67 Provides:       browser(npapi)
    68 # this is needed to match this package with the kde4 helper package without the main package
    68 # this is needed to match this package with the kde4 helper package without the main package
    86 Source10:       compare-locales.tar.bz2
    86 Source10:       compare-locales.tar.bz2
    87 Source11:       firefox.1
    87 Source11:       firefox.1
    88 Source12:       mozilla-get-app-id
    88 Source12:       mozilla-get-app-id
    89 Source13:       add-plugins.sh.in
    89 Source13:       add-plugins.sh.in
    90 Source14:       create-tar.sh
    90 Source14:       create-tar.sh
       
    91 Source15:       gecko.js
    91 # Gecko/Toolkit
    92 # Gecko/Toolkit
    92 Patch1:         toolkit-download-folder.patch
    93 Patch1:         toolkit-download-folder.patch
    93 Patch2:         mozilla-nongnome-proxies.patch
    94 Patch2:         mozilla-nongnome-proxies.patch
    94 Patch3:         mozilla-prefer_plugin_pref.patch
    95 Patch3:         mozilla-prefer_plugin_pref.patch
    95 Patch4:         mozilla-shared-nss-db.patch
    96 Patch4:         mozilla-shared-nss-db.patch
   266 export MOZILLA_OFFICIAL=1
   267 export MOZILLA_OFFICIAL=1
   267 export BUILD_OFFICIAL=1
   268 export BUILD_OFFICIAL=1
   268 export MOZ_TELEMETRY_REPORTING=1
   269 export MOZ_TELEMETRY_REPORTING=1
   269 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   270 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   270 %ifarch %arm
   271 %ifarch %arm
   271 export CFLAGS="${CFLAGS/-g/}"
   272 export CFLAGS="${CFLAGS/-g / }"
   272 %endif
   273 %endif
   273 %ifarch ppc64
   274 %ifarch ppc64
   274 export CFLAGS="$CFLAGS -mminimal-toc"
   275 export CFLAGS="$CFLAGS -mminimal-toc"
   275 %endif
   276 %endif
   276 export CXXFLAGS="$CFLAGS"
   277 export CXXFLAGS="$CFLAGS"
   304 cat << EOF >> $MOZCONFIG
   305 cat << EOF >> $MOZCONFIG
   305 ac_add_options --disable-gnomevfs
   306 ac_add_options --disable-gnomevfs
   306 ac_add_options --enable-gio
   307 ac_add_options --enable-gio
   307 EOF
   308 EOF
   308 %endif
   309 %endif
   309 %if %suse_version > 1140
   310 %if %suse_version < 1220
   310 cat << EOF >> $MOZCONFIG
   311 cat << EOF >> $MOZCONFIG
   311 ac_add_options --enable-gstreamer
   312 ac_add_options --disable-gstreamer
   312 EOF
   313 EOF
   313 %endif
   314 %endif
   314 %if %branding
   315 %if %branding
   315 cat << EOF >> $MOZCONFIG
   316 cat << EOF >> $MOZCONFIG
   316 ac_add_options --enable-official-branding
   317 ac_add_options --enable-official-branding
   356 # install kde.js
   357 # install kde.js
   357 %if %suse_version >= 1110
   358 %if %suse_version >= 1110
   358 install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{progdir}/browser/defaults/preferences/kde.js
   359 install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{progdir}/browser/defaults/preferences/kde.js
   359 install -m 644 %{SOURCE9} $RPM_BUILD_ROOT%{progdir}/browser/defaults/preferences/firefox.js
   360 install -m 644 %{SOURCE9} $RPM_BUILD_ROOT%{progdir}/browser/defaults/preferences/firefox.js
   360 %endif
   361 %endif
       
   362 # core configuration (e.g. temporary gstreamer pref)
       
   363 # this is expected to be just temporary and therefore not handled in openSUSE branding
       
   364 install -m 644 %{SOURCE15} $RPM_BUILD_ROOT%{progdir}/defaults/pref/gecko.js
   361 # install add-plugins.sh
   365 # install add-plugins.sh
   362 sed "s:%%PROGDIR:%{progdir}:g" \
   366 sed "s:%%PROGDIR:%{progdir}:g" \
   363   %{SOURCE13} > $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   367   %{SOURCE13} > $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   364 chmod 755 $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   368 chmod 755 $RPM_BUILD_ROOT%{progdir}/add-plugins.sh
   365 # install additional locales
   369 # install additional locales
   366 %if %localize
   370 %if %localize
   367 rm -f %{_tmppath}/translations.*
   371 rm -f %{_tmppath}/translations.*
   368 touch %{_tmppath}/translations.{common,other}
   372 touch %{_tmppath}/translations.{common,other}
   369 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
   373 for locale in $(awk '{ print $1; }' ../mozilla/browser/locales/shipped-locales); do
   370   case $locale in
   374   case $locale in
   371    ja-JP-mac|en-US)
   375    ja-JP-mac|en-US|mn|ta-LK)
   372 	;;
   376 	;;
   373    *)
   377    *)
   374    	pushd $RPM_BUILD_DIR/compare-locales
   378    	pushd $RPM_BUILD_DIR/compare-locales
   375 	PYTHONPATH=lib \
   379 	PYTHONPATH=lib \
   376 	  scripts/compare-locales -m ../l10n-merged/$locale \
   380 	  scripts/compare-locales -m ../l10n-merged/$locale \