MozillaFirefox/MozillaFirefox.spec
branchfirefox97
changeset 1171 130d464159be
parent 1170 f9b2d408b7ef
child 1172 7bdeb580be51
--- a/MozillaFirefox/MozillaFirefox.spec	Sat Feb 05 15:04:53 2022 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Wed Mar 02 15:34:50 2022 +0100
@@ -2,7 +2,7 @@
 # spec file
 #
 # Copyright (c) 2022 SUSE LLC
-#               2006-2021 Wolfgang Rosenauer <wr@rosenauer.org>
+#               2006-2022 Wolfgang Rosenauer <wr@rosenauer.org>
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,9 +28,9 @@
 # orig_suffix b3
 # major 69
 # mainver %major.99
-%define major          96
-%define mainver        %major.0.3
-%define orig_version   96.0.3
+%define major          97
+%define mainver        %major.0.1
+%define orig_version   97.0.1
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
@@ -97,13 +97,13 @@
 BuildRequires:  gcc-c++
 %endif
 %if 0%{?suse_version} < 1550 && 0%{?sle_version} < 150300
-BuildRequires:  cargo >= 1.53
-BuildRequires:  rust >= 1.53
+BuildRequires:  cargo >= 1.57
+BuildRequires:  rust >= 1.57
 %else
 # Newer sle/leap/tw use parallel versioned rust releases which have
 # a different method for provides that we can use to request a
 # specific version
-BuildRequires:  rust+cargo >= 1.53
+BuildRequires:  rust+cargo >= 1.57
 %endif
 %if 0%{useccache} != 0
 BuildRequires:  ccache
@@ -114,7 +114,7 @@
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
 BuildRequires:  mozilla-nspr-devel >= 4.33
-BuildRequires:  mozilla-nss-devel >= 3.73.1
+BuildRequires:  mozilla-nss-devel >= 3.74
 BuildRequires:  nasm >= 2.14
 BuildRequires:  nodejs >= 10.22.1
 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
@@ -381,6 +381,8 @@
 %ifarch %arm %ix86
 # Limit RAM usage during link
 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+# A lie to prevent -Wl,--gc-sections being set which requires more memory than 32bit can offer
+export GC_SECTIONS_BREAKS_DEBUG_RANGES=yes
 %endif
 export LDFLAGS="${LDFLAGS} -fPIC -Wl,-z,relro,-z,now"
 %ifarch ppc64 ppc64le
@@ -408,9 +410,7 @@
 echo ""
 cat << EOF
 %else
-%ifarch aarch64 ppc64 ppc64le x86_64
-%limit_build -m 2048
-%endif
+%limit_build -m 2560
 cat << EOF > $MOZCONFIG
 %endif
 mk_add_options MOZILLA_OFFICIAL=1
@@ -433,8 +433,8 @@
 ac_add_options --disable-debug-symbols
 %else
 ac_add_options --enable-debug-symbols=-g1
+%endif
 ac_add_options --disable-install-strip
-%endif
 # building with elf-hack started to fail everywhere with FF73
 #%if 0%{?suse_version} > 1549
 %ifnarch aarch64 ppc64 ppc64le s390x