mozilla-xulrunner20/mozilla-xulrunner20.spec
changeset 127 4c86470ed796
parent 125 bfef1af1ee28
child 128 dca77f2bed05
--- a/mozilla-xulrunner20/mozilla-xulrunner20.spec	Wed Aug 11 12:17:17 2010 +0200
+++ b/mozilla-xulrunner20/mozilla-xulrunner20.spec	Thu Aug 12 08:55:47 2010 +0200
@@ -35,8 +35,8 @@
 License:        GPLv2+ ; LGPLv2.1+ ; MPLv1.1+
 Version:        2.0b
 Release:        1
-%define         releasedate 2010080300
-%define         version_internal 2.0b3
+%define         releasedate 2010081000
+%define         version_internal 2.0b4pre
 %define         apiversion 2.0
 %define         uaweight 199900
 Summary:        Mozilla Runtime Environment 2.0
@@ -47,8 +47,8 @@
 %if %suse_version >= 1110
 # this is needed to match this package with the kde4 helper package without the main package
 # having a hard requirement on the kde4 package
-#%define kde_helper_version 6
-#Provides:       mozilla-kde4-version = %{kde_helper_version}
+%define kde_helper_version 6
+Provides:       mozilla-kde4-version = %{kde_helper_version}
 %endif
 %ifarch %ix86
 Provides:       mozilla-xulrunner20-32bit = %{version}-%{release}
@@ -211,9 +211,9 @@
 %patch5 -p1
 %patch7 -p1
 %patch8 -p1
-#%if %suse_version >= 1110
-#%patch10 -p1
-#%endif
+%if %suse_version >= 1110
+%patch10 -p1
+%endif
 #%patch11 -p1
 #%patch12 -p1
 #%patch13 -p1
@@ -222,13 +222,13 @@
 %endif
 
 %build
-#%if %suse_version >= 1110
-#kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
-#if test "$kdehelperversion" != %{kde_helper_version}; then
-#  echo fix kde helper version in the .spec file
-#  exit 1
-#fi
-#%endif
+%if %suse_version >= 1110
+kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
+if test "$kdehelperversion" != %{kde_helper_version}; then
+  echo fix kde helper version in the .spec file
+  exit 1
+fi
+%endif
 MOZ_APP_DIR=%{_libdir}/xulrunner-%{version_internal}
 export MOZ_BUILD_DATE=%{releasedate}
 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"