MozillaFirefox/MozillaFirefox.spec
branchfirefox60
changeset 1052 7a49806c8dae
parent 1051 87c1625d07e2
child 1053 893fc4d031d6
child 1062 48d794331fce
--- a/MozillaFirefox/MozillaFirefox.spec	Sat May 26 18:04:18 2018 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Fri Jun 08 22:09:15 2018 +0200
@@ -19,10 +19,10 @@
 
 # changed with every update
 %define major 60
-%define mainver %major.0.1
+%define mainver %major.0.2
 %define update_channel release
 %define branding 1
-%define releasedate 20180516032328
+%define releasedate 20180605171542
 %define source_prefix firefox-%{mainver}
 
 # PIE, full relro (x86_64 for now)
@@ -58,6 +58,7 @@
 BuildRequires:  autoconf213
 BuildRequires:  dbus-1-glib-devel
 BuildRequires:  fdupes
+BuildRequires:  memory-constraints
 %if 0%{?suse_version} <= 1320
 BuildRequires:  gcc7-c++
 %else
@@ -72,7 +73,7 @@
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
 BuildRequires:  mozilla-nspr-devel >= 4.19
-BuildRequires:  mozilla-nss-devel >= 3.36.1
+BuildRequires:  mozilla-nss-devel >= 3.36.4
 BuildRequires:  python-devel
 BuildRequires:  python2-xml
 BuildRequires:  rust >= 1.24
@@ -157,6 +158,7 @@
 Patch10:        mozilla-i586-domPrefs.patch
 Patch11:        mozilla-enable-csd.patch
 Patch12:        mozilla-fix-skia-aarch64.patch
+Patch13:        mozilla-bmo1375074.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-branded-icons.patch
@@ -272,6 +274,7 @@
 %endif
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 # Firefox
 %patch101 -p1
 %patch102 -p1
@@ -305,9 +308,6 @@
 %if 0%{?suse_version} > 1320
 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks"
 %endif
-%ifarch aarch64
-export CFLAGS="$CFLAGS -ffixed-x28"
-%endif
 %ifarch %arm
 export CFLAGS="${CFLAGS/-g / }"
 %endif
@@ -328,6 +328,7 @@
 export RUSTFLAGS="-Cdebuginfo=0"
 %endif
 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
+%limit_build -m 1500
 cat << EOF > $MOZCONFIG
 mk_add_options MOZILLA_OFFICIAL=1
 mk_add_options BUILD_OFFICIAL=1