MozillaFirefox/MozillaFirefox.spec
branchfirefox63
changeset 1081 9fec29d2ead2
parent 1079 1663e876731f
child 1082 821cfbe8efcc
--- a/MozillaFirefox/MozillaFirefox.spec	Wed Nov 14 08:31:32 2018 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Tue Dec 11 08:48:38 2018 +0100
@@ -19,12 +19,12 @@
 
 # changed with every update
 %define major          63
-%define mainver        %major.0.1
-%define orig_version   63.0.1
+%define mainver        %major.0.3
+%define orig_version   63.0.3
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
-%define releasedate    20181030165643
+%define releasedate    20181114214635
 %define source_prefix  firefox-%{orig_version}
 
 # PIE, full relro (x86_64 for now)
@@ -66,6 +66,7 @@
 %else
 BuildRequires:  gcc-c++
 %endif
+BuildRequires:  cargo >= 1.28
 BuildRequires:  libXcomposite-devel
 BuildRequires:  libcurl-devel
 BuildRequires:  libidl-devel
@@ -80,7 +81,6 @@
 BuildRequires:  python2-xml
 BuildRequires:  python3 >= 3.5
 BuildRequires:  rust >= 1.28
-BuildRequires:  cargo >= 1.28
 BuildRequires:  rust-cbindgen >= 0.6.2
 BuildRequires:  startup-notification-devel
 BuildRequires:  unzip
@@ -162,7 +162,6 @@
 Patch9:         mozilla-bmo1463035.patch
 Patch10:        mozilla-bmo1491289.patch
 Patch11:        mozilla-cubeb-noreturn.patch
-Patch12:        mozilla-newer-cbindgen.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-branded-icons.patch
@@ -274,7 +273,6 @@
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
 # Firefox
 %patch101 -p1
 %patch102 -p1
@@ -308,9 +306,6 @@
 %if 0%{?suse_version} > 1320
 export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks"
 %endif
-%ifarch %arm
-export CFLAGS="${CFLAGS/-g / }"
-%endif
 %ifarch %arm %ix86
 # Limit RAM usage during link
 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
@@ -324,9 +319,6 @@
 export CFLAGS="$CFLAGS -mminimal-toc"
 %endif
 export CXXFLAGS="$CFLAGS"
-%ifarch %{arm}
-export RUSTFLAGS="-Cdebuginfo=0"
-%endif
 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
 %limit_build -m 1500
 cat << EOF > $MOZCONFIG
@@ -350,20 +342,14 @@
 %if 0%{?suse_version} > 1320
 ac_add_options --enable-optimize="-g -O2"
 %endif
-%ifarch %arm
-%if 0%{?suse_version} > 1230
-ac_add_options --disable-optimize
-%endif
-%endif
 # bmo#1441155 - Disable the generation of Rust debug symbols on Linux32
-%ifarch %ix86
+%ifarch %ix86 %arm
 ac_add_options --disable-debug-symbols
 %endif
-%ifarch %arm
+%if 0%{?suse_version} > 1549
+%ifnarch aarch64 ppc64 ppc64le
 ac_add_options --disable-elf-hack
 %endif
-%if 0%{?suse_version} > 1549
-ac_add_options --disable-elf-hack
 %endif
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss