MozillaFirefox/MozillaFirefox.spec
changeset 1018 0e45f8ad501c
parent 1017 8ccb9c3cbe47
child 1019 b0c883afdffa
equal deleted inserted replaced
1008:77c890186192 1018:0e45f8ad501c
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
     5 #               2006-2017 Wolfgang Rosenauer
     5 #               2006-2018 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 56
    21 %define major 57
    22 %define mainver %major.99
    22 %define mainver %major.99
    23 %define update_channel beta
    23 %define update_channel beta
    24 %define branding 1
    24 %define branding 1
    25 %define releasedate 20171102181127
    25 %define releasedate 20180108140638
    26 
    26 
    27 # PIE, full relro (x86_64 for now)
    27 # PIE, full relro (x86_64 for now)
    28 %define build_hardened 1
    28 %define build_hardened 1
    29 
    29 
    30 # Firefox only supports i686
    30 # Firefox only supports i686
    73 BuildRequires:  libproxy-devel
    73 BuildRequires:  libproxy-devel
    74 BuildRequires:  makeinfo
    74 BuildRequires:  makeinfo
    75 BuildRequires:  mozilla-nspr-devel >= 4.17
    75 BuildRequires:  mozilla-nspr-devel >= 4.17
    76 BuildRequires:  mozilla-nss-devel >= 3.33
    76 BuildRequires:  mozilla-nss-devel >= 3.33
    77 BuildRequires:  python-devel
    77 BuildRequires:  python-devel
       
    78 BuildRequires:  python2-xml
    78 BuildRequires:  rust >= 1.19
    79 BuildRequires:  rust >= 1.19
    79 BuildRequires:  rust-std
    80 BuildRequires:  rust-std
    80 BuildRequires:  startup-notification-devel
    81 BuildRequires:  startup-notification-devel
    81 BuildRequires:  unzip
    82 BuildRequires:  unzip
    82 BuildRequires:  update-desktop-files
    83 BuildRequires:  update-desktop-files
   151 Patch4:         mozilla-openaes-decl.patch
   152 Patch4:         mozilla-openaes-decl.patch
   152 Patch5:         mozilla-no-stdcxx-check.patch
   153 Patch5:         mozilla-no-stdcxx-check.patch
   153 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   154 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   154 Patch7:         mozilla-aarch64-startup-crash.patch
   155 Patch7:         mozilla-aarch64-startup-crash.patch
   155 Patch8:         mozilla-bindgen-systemlibs.patch
   156 Patch8:         mozilla-bindgen-systemlibs.patch
       
   157 Patch9:         mozilla-bmo1360278.patch
       
   158 Patch10:        mozilla-bmo1399611-csd.patch
       
   159 Patch11:        mozilla-rust-1.23.patch
   156 # Firefox/browser
   160 # Firefox/browser
   157 Patch101:       firefox-kde.patch
   161 Patch101:       firefox-kde.patch
   158 Patch102:       firefox-no-default-ualocale.patch
   162 Patch102:       firefox-no-default-ualocale.patch
   159 Patch103:       firefox-branded-icons.patch
   163 Patch103:       firefox-branded-icons.patch
   160 
   164 
   162 Requires(post):   coreutils shared-mime-info desktop-file-utils
   166 Requires(post):   coreutils shared-mime-info desktop-file-utils
   163 Requires(postun): shared-mime-info desktop-file-utils
   167 Requires(postun): shared-mime-info desktop-file-utils
   164 %if %branding
   168 %if %branding
   165 Requires:       %{name}-branding > 44.0
   169 Requires:       %{name}-branding > 44.0
   166 %endif
   170 %endif
   167 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
   171 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%%{VERSION}' mozilla-nspr)
   168 Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
   172 Requires:       mozilla-nss >= %(rpm -q --queryformat '%%{VERSION}' mozilla-nss)
   169 Recommends:     libcanberra0
   173 Recommends:     libcanberra0
   170 Recommends:     libpulse0
   174 Recommends:     libpulse0
   171 # addon leads to startup crash (bnc#908892)
   175 # addon leads to startup crash (bnc#908892)
   172 Obsoletes:      tracker-miner-firefox < 0.15
   176 Obsoletes:      tracker-miner-firefox < 0.15
   173 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   177 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   262 %ifarch %ix86
   266 %ifarch %ix86
   263 %patch6 -p1
   267 %patch6 -p1
   264 %endif
   268 %endif
   265 %patch7 -p1
   269 %patch7 -p1
   266 %patch8 -p1
   270 %patch8 -p1
       
   271 %patch9 -p1
       
   272 %patch10 -p1
       
   273 %patch11 -p1
   267 # Firefox
   274 # Firefox
   268 %patch101 -p1
   275 %patch101 -p1
   269 %patch102 -p1
   276 %patch102 -p1
   270 %patch103 -p1
   277 %patch103 -p1
   271 
   278