MozillaFirefox/MozillaFirefox.spec
changeset 1044 142a0c92607c
parent 1043 5ba4fbb8bed7
child 1045 f645c886d36b
equal deleted inserted replaced
1037:d61b64679bb4 1044:142a0c92607c
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 59
    21 %define major 59
    22 %define mainver %major.0
    22 %define mainver %major.99
    23 %define update_channel release
    23 %define update_channel beta
    24 %define branding 1
    24 %define branding 1
    25 %define releasedate 20180310025718
    25 %define releasedate 20180323154952
    26 
    26 
    27 # PIE, full relro (x86_64 for now)
    27 # PIE, full relro (x86_64 for now)
    28 %define build_hardened 1
    28 %define build_hardened 1
    29 
    29 
    30 # Firefox only supports i686
    30 # Firefox only supports i686
    68 BuildRequires:  libidl-devel
    68 BuildRequires:  libidl-devel
    69 BuildRequires:  libiw-devel
    69 BuildRequires:  libiw-devel
    70 BuildRequires:  libnotify-devel
    70 BuildRequires:  libnotify-devel
    71 BuildRequires:  libproxy-devel
    71 BuildRequires:  libproxy-devel
    72 BuildRequires:  makeinfo
    72 BuildRequires:  makeinfo
    73 BuildRequires:  mozilla-nspr-devel >= 4.18
    73 BuildRequires:  mozilla-nspr-devel >= 4.19
    74 BuildRequires:  mozilla-nss-devel >= 3.35
    74 BuildRequires:  mozilla-nss-devel >= 3.36
    75 BuildRequires:  python-devel
    75 BuildRequires:  python-devel
    76 BuildRequires:  python2-xml
    76 BuildRequires:  python2-xml
    77 BuildRequires:  rust >= 1.22.1
    77 BuildRequires:  rust >= 1.24
    78 BuildRequires:  rust-std
    78 BuildRequires:  rust-std
    79 BuildRequires:  startup-notification-devel
    79 BuildRequires:  startup-notification-devel
    80 BuildRequires:  unzip
    80 BuildRequires:  unzip
    81 BuildRequires:  update-desktop-files
    81 BuildRequires:  update-desktop-files
    82 BuildRequires:  xorg-x11-libXt-devel
    82 BuildRequires:  xorg-x11-libXt-devel
   148 Patch4:         mozilla-openaes-decl.patch
   148 Patch4:         mozilla-openaes-decl.patch
   149 Patch5:         mozilla-no-stdcxx-check.patch
   149 Patch5:         mozilla-no-stdcxx-check.patch
   150 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   150 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
   151 Patch7:         mozilla-aarch64-startup-crash.patch
   151 Patch7:         mozilla-aarch64-startup-crash.patch
   152 Patch8:         mozilla-bmo256180.patch
   152 Patch8:         mozilla-bmo256180.patch
       
   153 Patch9:         mozilla-bmo1005535.patch
       
   154 Patch10:        mozilla-i586-DecoderDoctorLogger.patch
       
   155 Patch11:        mozilla-i586-domPrefs.patch
   153 # Firefox/browser
   156 # Firefox/browser
   154 Patch101:       firefox-kde.patch
   157 Patch101:       firefox-kde.patch
   155 Patch102:       firefox-branded-icons.patch
   158 Patch102:       firefox-branded-icons.patch
   156 
   159 
   157 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   160 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   258 %ifarch %ix86
   261 %ifarch %ix86
   259 %patch6 -p1
   262 %patch6 -p1
   260 %endif
   263 %endif
   261 %patch7 -p1
   264 %patch7 -p1
   262 %patch8 -p1
   265 %patch8 -p1
       
   266 %patch9 -p1
       
   267 %ifarch %ix86
       
   268 %patch10 -p1
       
   269 %patch11 -p1
       
   270 %endif
   263 # Firefox
   271 # Firefox
   264 %patch101 -p1
   272 %patch101 -p1
   265 %patch102 -p1
   273 %patch102 -p1
   266 
   274 
   267 %build
   275 %build
   331 %ifarch %ix86 %arm
   339 %ifarch %ix86 %arm
   332 %if 0%{?suse_version} > 1230
   340 %if 0%{?suse_version} > 1230
   333 ac_add_options --disable-optimize
   341 ac_add_options --disable-optimize
   334 %endif
   342 %endif
   335 %endif
   343 %endif
   336 %ifarch ppc ppc64 ppc64le %arm
   344 %ifarch %arm
   337 ac_add_options --disable-elf-hack
   345 ac_add_options --disable-elf-hack
   338 %endif
   346 %endif
   339 ac_add_options --with-system-nspr
   347 ac_add_options --with-system-nspr
   340 ac_add_options --with-system-nss
   348 ac_add_options --with-system-nss
   341 %if %{localize}
   349 %if %{localize}