MozillaFirefox/MozillaFirefox.spec
branchfirefox53
changeset 964 218a4e337cfe
parent 960 42e50afb9638
child 966 8ee745000eea
equal deleted inserted replaced
963:70c9d891389f 964:218a4e337cfe
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 53
    21 %define major 53
    22 %define mainver %major.0
    22 %define mainver %major.0
    23 %define update_channel release
    23 %define update_channel release
       
    24 %define branding 1
    24 %define releasedate 20170414000000
    25 %define releasedate 20170414000000
    25 
    26 
    26 # PIE, full relro (x86_64 for now)
    27 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    28 %define build_hardened 1
    28 
    29 
    31 %define firefox_use_rust 1
    32 %define firefox_use_rust 1
    32 %endif
    33 %endif
    33 %endif
    34 %endif
    34 
    35 
    35 # general build definitions
    36 # general build definitions
    36 %if "%{update_channel}" != "aurora"
       
    37 %define progname firefox
    37 %define progname firefox
    38 %define pkgname  MozillaFirefox
    38 %define pkgname  MozillaFirefox
    39 %define appname  Firefox
    39 %define appname  Firefox
    40 %else
       
    41 %define progname firefox-dev
       
    42 %define pkgname  firefox-dev-edition
       
    43 %define appname  Firefox Developer Edition
       
    44 %endif
       
    45 %define progdir %{_prefix}/%_lib/%{progname}
    40 %define progdir %{_prefix}/%_lib/%{progname}
    46 %define gnome_dir     %{_prefix}
    41 %define gnome_dir     %{_prefix}
    47 %define desktop_file_name %{progname}
    42 %define desktop_file_name %{progname}
    48 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    43 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    49 %define _use_internal_dependency_generator 0
    44 %define _use_internal_dependency_generator 0
    52 %global __find_provides %provfind
    47 %global __find_provides %provfind
    53 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
    48 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
    54 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
    49 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
    55 # please get your own set of keys.
    50 # please get your own set of keys.
    56 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
    51 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
    57 %if %update_channel == "aurora"
       
    58 %define branding 0
       
    59 %else
       
    60 %define branding 1
       
    61 %endif
       
    62 %define localize 1
    52 %define localize 1
    63 %ifarch %ix86 x86_64
    53 %ifarch %ix86 x86_64
    64 %define crashreporter 1
    54 %define crashreporter 1
    65 %else
    55 %else
    66 %define crashreporter 0
    56 %define crashreporter 0
   115 %if "%{name}" == "MozillaFirefox"
   105 %if "%{name}" == "MozillaFirefox"
   116 Provides:       firefox = %{mainver}
   106 Provides:       firefox = %{mainver}
   117 Provides:       firefox = %{version}-%{release}
   107 Provides:       firefox = %{version}-%{release}
   118 %endif
   108 %endif
   119 Provides:       web_browser
   109 Provides:       web_browser
   120 %if "%{update_channel}" != "aurora"
       
   121 Provides:       appdata()
   110 Provides:       appdata()
   122 Provides:       appdata(firefox.appdata.xml)
   111 Provides:       appdata(firefox.appdata.xml)
   123 %endif
       
   124 # this is needed to match this package with the kde4 helper package without the main package
   112 # this is needed to match this package with the kde4 helper package without the main package
   125 # having a hard requirement on the kde4 package
   113 # having a hard requirement on the kde4 package
   126 %define kde_helper_version 6
   114 %define kde_helper_version 6
   127 Provides:       mozilla-kde4-version = %{kde_helper_version}
   115 Provides:       mozilla-kde4-version = %{kde_helper_version}
   128 Summary:        Mozilla %{appname} Web Browser
   116 Summary:        Mozilla %{appname} Web Browser
   145 Source13:       spellcheck.js
   133 Source13:       spellcheck.js
   146 Source14:       create-tar.sh
   134 Source14:       create-tar.sh
   147 Source15:       firefox-appdata.xml
   135 Source15:       firefox-appdata.xml
   148 Source16:       MozillaFirefox.changes
   136 Source16:       MozillaFirefox.changes
   149 Source17:       l10n_changesets.txt
   137 Source17:       l10n_changesets.txt
       
   138 Source18:       mozilla-api-key
   150 # Gecko/Toolkit
   139 # Gecko/Toolkit
   151 Patch1:         mozilla-nongnome-proxies.patch
   140 Patch1:         mozilla-nongnome-proxies.patch
   152 Patch2:         mozilla-shared-nss-db.patch
   141 Patch2:         mozilla-shared-nss-db.patch
   153 Patch3:         mozilla-kde.patch
   142 Patch3:         mozilla-kde.patch
   154 Patch4:         mozilla-preferences.patch
       
   155 Patch5:         mozilla-language.patch
   143 Patch5:         mozilla-language.patch
   156 Patch6:         mozilla-ntlm-full-path.patch
   144 Patch6:         mozilla-ntlm-full-path.patch
   157 Patch7:         mozilla-openaes-decl.patch
   145 Patch7:         mozilla-openaes-decl.patch
   158 Patch8:         mozilla-no-stdcxx-check.patch
   146 Patch8:         mozilla-no-stdcxx-check.patch
   159 Patch9:         mozilla-reduce-files-per-UnifiedBindings.patch
   147 Patch9:         mozilla-reduce-files-per-UnifiedBindings.patch
   177 Obsoletes:      tracker-miner-firefox < 0.15
   165 Obsoletes:      tracker-miner-firefox < 0.15
   178 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   166 # libproxy's mozjs pacrunner crashes FF (bnc#759123)
   179 %if 0%{?suse_version} < 1220
   167 %if 0%{?suse_version} < 1220
   180 Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
   168 Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
   181 %endif
   169 %endif
       
   170 ##BuildArch:      i686 x86_64 aarch64 ppc64le
   182 
   171 
   183 %description
   172 %description
   184 Mozilla Firefox is a standalone web browser, designed for standards
   173 Mozilla Firefox is a standalone web browser, designed for standards
   185 compliance and performance.  Its functionality can be enhanced via a
   174 compliance and performance.  Its functionality can be enhanced via a
   186 plethora of extensions.
   175 plethora of extensions.
   259 %endif
   248 %endif
   260 cd $RPM_BUILD_DIR/mozilla
   249 cd $RPM_BUILD_DIR/mozilla
   261 %patch1 -p1
   250 %patch1 -p1
   262 %patch2 -p1
   251 %patch2 -p1
   263 %patch3 -p1
   252 %patch3 -p1
   264 %patch4 -p1
       
   265 %patch5 -p1
   253 %patch5 -p1
   266 %patch6 -p1
   254 %patch6 -p1
   267 %patch7 -p1
   255 %patch7 -p1
   268 %patch8 -p1
   256 %patch8 -p1
   269 #%patch9 -p1
   257 %ifarch %ix86
       
   258 %patch9 -p1
       
   259 %endif
   270 %patch10 -p1
   260 %patch10 -p1
   271 # Firefox
   261 # Firefox
   272 %patch101 -p1
   262 %patch101 -p1
   273 %patch102 -p1
   263 %patch102 -p1
   274 %patch103 -p1
   264 %patch103 -p1
   359 ac_add_options --enable-alsa
   349 ac_add_options --enable-alsa
   360 ac_add_options --disable-debug
   350 ac_add_options --disable-debug
   361 ac_add_options --enable-startup-notification
   351 ac_add_options --enable-startup-notification
   362 #ac_add_options --enable-chrome-format=jar
   352 #ac_add_options --enable-chrome-format=jar
   363 ac_add_options --enable-update-channel=%{update_channel}
   353 ac_add_options --enable-update-channel=%{update_channel}
       
   354 ac_add_options --with-mozilla-api-keyfile=%{SOURCE18}
   364 %if %branding
   355 %if %branding
   365 ac_add_options --enable-official-branding
   356 ac_add_options --enable-official-branding
   366 %endif
   357 %endif
   367 ac_add_options --enable-libproxy
   358 ac_add_options --enable-libproxy
   368 %if ! %crashreporter
   359 %if ! %crashreporter
   463 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   454 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   464 # additional mime-types
   455 # additional mime-types
   465 mkdir -p %{buildroot}%{_datadir}/mime/packages
   456 mkdir -p %{buildroot}%{_datadir}/mime/packages
   466 cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml
   457 cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml
   467 # appdata
   458 # appdata
   468 %if "%{update_channel}" != "aurora"
       
   469 mkdir -p %{buildroot}%{_datadir}/appdata
   459 mkdir -p %{buildroot}%{_datadir}/appdata
   470 cp %{SOURCE15} %{buildroot}%{_datadir}/appdata/%{desktop_file_name}.appdata.xml
   460 cp %{SOURCE15} %{buildroot}%{_datadir}/appdata/%{desktop_file_name}.appdata.xml
   471 %endif
       
   472 # install man-page
   461 # install man-page
   473 mkdir -p %{buildroot}%{_mandir}/man1/
   462 mkdir -p %{buildroot}%{_mandir}/man1/
   474 cp %{SOURCE11} %{buildroot}%{_mandir}/man1/%{progname}.1
   463 cp %{SOURCE11} %{buildroot}%{_mandir}/man1/%{progname}.1
   475 ##########
   464 ##########
   476 # ADDONS
   465 # ADDONS
   611 %dir %{_libdir}/mozilla/extensions
   600 %dir %{_libdir}/mozilla/extensions
   612 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
   601 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
   613 %{gnome_dir}/share/icons/hicolor/
   602 %{gnome_dir}/share/icons/hicolor/
   614 %{_bindir}/%{progname}
   603 %{_bindir}/%{progname}
   615 %doc %{_mandir}/man1/%{progname}.1.gz
   604 %doc %{_mandir}/man1/%{progname}.1.gz
   616 %if "%{update_channel}" != "aurora"
       
   617 %{_datadir}/appdata/
   605 %{_datadir}/appdata/
   618 %endif
       
   619 
   606 
   620 %files devel
   607 %files devel
   621 %defattr(-,root,root)
   608 %defattr(-,root,root)
   622 %{_bindir}/mozilla-get-app-id
   609 %{_bindir}/mozilla-get-app-id
   623 %config %{_sysconfdir}/rpm/macros.%{progname}
   610 %config %{_sysconfdir}/rpm/macros.%{progname}