MozillaFirefox/MozillaFirefox.spec
changeset 34 2d77a25d185f
parent 33 467b3a3e2b4a
child 36 c55ce8284eb3
equal deleted inserted replaced
33:467b3a3e2b4a 34:2d77a25d185f
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 
    21 
    22 Name:           MozillaFirefox
    22 Name:           MozillaFirefox
    23 %define xulrunner mozilla-xulrunner192
    23 %define xulrunner mozilla-xulrunner192
    24 BuildRequires:  autoconf213 gcc-c++ libgnomeui-devel libidl-devel libnotify-devel orbit-devel python unzip update-desktop-files zip
    24 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel orbit-devel python unzip update-desktop-files zip
    25 BuildRequires:  %{xulrunner}-devel = 1.9.2b5
    25 BuildRequires:  %{xulrunner}-devel = 1.9.2b5
    26 %if %suse_version > 1020
    26 %if %suse_version > 1020
    27 BuildRequires:  fdupes
    27 BuildRequires:  fdupes
    28 %endif
    28 %endif
    29 %if %suse_version > 1110
    29 %if %suse_version > 1110
    60 Patch6:         firefox-cross-desktop.patch
    60 Patch6:         firefox-cross-desktop.patch
    61 Patch7:         firefox-no-gnomevfs.patch
    61 Patch7:         firefox-no-gnomevfs.patch
    62 Patch8:         firefox-appname.patch
    62 Patch8:         firefox-appname.patch
    63 Patch9:         firefox-kde.patch
    63 Patch9:         firefox-kde.patch
    64 Patch10:        firefox-ui-lockdown.patch
    64 Patch10:        firefox-ui-lockdown.patch
       
    65 Patch11:        firefox-crashreporter.patch
    65 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    66 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    66 PreReq:         coreutils /bin/sh shared-mime-info desktop-file-utils
    67 PreReq:         coreutils /bin/sh shared-mime-info desktop-file-utils
    67 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
    68 Requires:       %{xulrunner} >= %(rpm -q --queryformat '%{VERSION}-%{RELEASE}' %{xulrunner})
    68 %requires_eq    %{xulrunner}
    69 %requires_eq    %{xulrunner}
    69 %ifarch %ix86
    70 %ifarch %ix86
   160 %patch9 -p1
   161 %patch9 -p1
   161 # install kde.js
   162 # install kde.js
   162 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   163 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   163 %endif
   164 %endif
   164 %patch10 -p1
   165 %patch10 -p1
       
   166 %patch11 -p1
   165 
   167 
   166 %build
   168 %build
   167 export MOZ_BUILD_DATE=%{releasedate}
   169 export MOZ_BUILD_DATE=%{releasedate}
   168 export MOZILLA_OFFICIAL=1
   170 export MOZILLA_OFFICIAL=1
   169 export BUILD_OFFICIAL=1
   171 export BUILD_OFFICIAL=1
   196 ac_add_options --with-system-zlib
   198 ac_add_options --with-system-zlib
   197 ac_add_options --disable-installer
   199 ac_add_options --disable-installer
   198 ac_add_options --disable-updater
   200 ac_add_options --disable-updater
   199 ac_add_options --disable-tests
   201 ac_add_options --disable-tests
   200 ac_add_options --disable-debug
   202 ac_add_options --disable-debug
   201 ac_add_options --disable-crashreporter
       
   202 EOF
   203 EOF
   203 %if %branding
   204 %if %branding
   204 cat << EOF >> $MOZCONFIG
   205 cat << EOF >> $MOZCONFIG
   205 ac_add_options --enable-official-branding
   206 ac_add_options --enable-official-branding
   206 EOF
   207 EOF
   353 %{progdir}/modules/
   354 %{progdir}/modules/
   354 %attr(755,root,root) %{progdir}/%{progname}.sh
   355 %attr(755,root,root) %{progdir}/%{progname}.sh
   355 %{progdir}/%{progname}
   356 %{progdir}/%{progname}
   356 %{progdir}/application.ini
   357 %{progdir}/application.ini
   357 %{progdir}/blocklist.xml
   358 %{progdir}/blocklist.xml
       
   359 %ifarch %ix86
       
   360 %{progdir}/crashreporter-override.ini
       
   361 %endif
   358 %{_datadir}/applications/%{name}.desktop
   362 %{_datadir}/applications/%{name}.desktop
   359 %{_datadir}/mime/packages/%{progname}.xml
   363 %{_datadir}/mime/packages/%{progname}.xml
   360 %{_datadir}/pixmaps/firefox*
   364 %{_datadir}/pixmaps/firefox*
   361 %if %branding
   365 %if %branding
   362 %{gnome_dir}/share/icons/hicolor/
   366 %{gnome_dir}/share/icons/hicolor/
   363 %endif
   367 %endif
   364 %{_bindir}/%{progname}
   368 %{_bindir}/%{progname}
   365 %doc %{_mandir}/man1/%{progname}.1.gz
   369 %doc %{_mandir}/man1/%{progname}.1.gz
       
   370 
   366 %if %localize
   371 %if %localize
   367 
       
   368 %files translations-common -f %{_tmppath}/translations.common
   372 %files translations-common -f %{_tmppath}/translations.common
   369 %defattr(-,root,root)
   373 %defattr(-,root,root)
   370 
   374 
   371 %files translations-other -f %{_tmppath}/translations.other
   375 %files translations-other -f %{_tmppath}/translations.other
   372 %defattr(-,root,root)
   376 %defattr(-,root,root)