MozillaFirefox/MozillaFirefox.spec
branchfirefox82
changeset 1150 2faa589360df
parent 1149 7b455bd1ea97
child 1151 8df86bf11fc1
equal deleted inserted replaced
1149:7b455bd1ea97 1150:2faa589360df
    27 # orig_version would be the upstream tar ball
    27 # orig_version would be the upstream tar ball
    28 # orig_version 70.0
    28 # orig_version 70.0
    29 # orig_suffix b3
    29 # orig_suffix b3
    30 # major 69
    30 # major 69
    31 # mainver %major.99
    31 # mainver %major.99
    32 %define major          81
    32 %define major          82
    33 %define mainver        %major.99
    33 %define mainver        %major.0.3
    34 %define orig_version   82.0
    34 %define orig_version   82.0.3
    35 %define orig_suffix    b8
    35 %define orig_suffix    %{nil}
    36 %define update_channel beta
    36 %define update_channel release
    37 %define branding       1
    37 %define branding       1
    38 %define devpkg         1
    38 %define devpkg         1
    39 
    39 
    40 # PGO builds do not work in TW currently (bmo#1642410)
    40 # PGO builds do not work in TW currently (bmo#1642410)
    41 %define do_profiling   0
    41 %define do_profiling   0
   556 %if %branding
   556 %if %branding
   557 ac_add_options --enable-official-branding
   557 ac_add_options --enable-official-branding
   558 %endif
   558 %endif
   559 EOF
   559 EOF
   560 
   560 
       
   561 %ifarch %ix86
       
   562 %define njobs 1
       
   563 %else
       
   564 %define njobs 0%{?jobs:%jobs}
       
   565 %endif
   561 sed -r '/^(ja-JP-mac|ga-IE|en-US|)$/d;s/ .*$//' $RPM_BUILD_DIR/%{srcname}-%{orig_version}/browser/locales/shipped-locales \
   566 sed -r '/^(ja-JP-mac|ga-IE|en-US|)$/d;s/ .*$//' $RPM_BUILD_DIR/%{srcname}-%{orig_version}/browser/locales/shipped-locales \
   562     | xargs -n 1 %{?jobs:-P %jobs} -I {} /bin/sh -c '
   567     | xargs -n 1 %{?njobs:-P %njobs} -I {} /bin/sh -c '
   563         locale=$1
   568         locale=$1
   564         cp ${MOZCONFIG}_LANG ${MOZCONFIG}_$locale
   569         cp ${MOZCONFIG}_LANG ${MOZCONFIG}_$locale
   565         sed -i "s|obj_LANG|obj_$locale|" ${MOZCONFIG}_$locale
   570         sed -i "s|obj_LANG|obj_$locale|" ${MOZCONFIG}_$locale
   566         export MOZCONFIG=${MOZCONFIG}_$locale
   571         export MOZCONFIG=${MOZCONFIG}_$locale
   567         # nsinstall is needed for langpack-build. It is already built by `./mach build`, but building it again is very fast
   572         # nsinstall is needed for langpack-build. It is already built by `./mach build`, but building it again is very fast