MozillaFirefox/MozillaFirefox.spec
branchfirefox116
changeset 1191 37e065158be7
parent 1190 2a24a948b5cf
child 1192 7612b8d8c46f
equal deleted inserted replaced
1190:2a24a948b5cf 1191:37e065158be7
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %%major.99
    30 # mainver %%major.99
    31 %define major          115
    31 %define major          116
    32 %define mainver        %major.0.3
    32 %define mainver        %major.0
    33 %define orig_version   115.0.3
    33 %define orig_version   116.0
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
    59 ExclusiveArch:  i586 i686
    59 ExclusiveArch:  i586 i686
    60 BuildArch:      i686
    60 BuildArch:      i686
    61 %{expand:%%global optflags %(echo "%optflags"|sed -e s/i586/i686/) -march=i686 -mtune=generic -msse2}
    61 %{expand:%%global optflags %(echo "%optflags"|sed -e s/i586/i686/) -march=i686 -mtune=generic -msse2}
    62 %endif
    62 %endif
    63 %endif
    63 %endif
    64 %{expand:%%global optflags %(echo "%optflags"|sed -e s/-flto=auto//) }
    64 #%%{expand:%%global optflags %(echo "%optflags"|sed -e s/-flto=auto//) }
    65 
    65 
    66 # general build definitions
    66 # general build definitions
    67 %define progname firefox
    67 %define progname firefox
    68 %define appname  Firefox
    68 %define appname  Firefox
    69 %define pkgname  MozillaFirefox
    69 %define pkgname  MozillaFirefox
   217 Patch7:         mozilla-pgo.patch
   217 Patch7:         mozilla-pgo.patch
   218 Patch8:         mozilla-reduce-rust-debuginfo.patch
   218 Patch8:         mozilla-reduce-rust-debuginfo.patch
   219 Patch10:        mozilla-bmo1504834-part1.patch
   219 Patch10:        mozilla-bmo1504834-part1.patch
   220 Patch11:        mozilla-bmo1504834-part3.patch
   220 Patch11:        mozilla-bmo1504834-part3.patch
   221 Patch12:        mozilla-bmo1512162.patch
   221 Patch12:        mozilla-bmo1512162.patch
   222 Patch13:        mozilla-fix-top-level-asm.patch
   222 #Patch13:        mozilla-fix-top-level-asm.patch
   223 Patch14:        mozilla-bmo849632.patch
   223 Patch14:        mozilla-bmo849632.patch
   224 Patch15:        mozilla-bmo998749.patch
   224 Patch15:        mozilla-bmo998749.patch
   225 Patch17:        mozilla-libavcodec58_91.patch
   225 Patch17:        mozilla-libavcodec58_91.patch
   226 Patch18:        mozilla-silence-no-return-type.patch
   226 Patch18:        mozilla-silence-no-return-type.patch
   227 Patch19:        mozilla-bmo531915.patch
   227 Patch19:        mozilla-bmo531915.patch
   491 ac_add_options --enable-optimize="-O1"
   491 ac_add_options --enable-optimize="-O1"
   492 %endif
   492 %endif
   493 %ifarch x86_64
   493 %ifarch x86_64
   494 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
   494 # LTO needs newer toolchain stack only (at least GCC 8.2.1 (r268506)
   495 %if 0%{?suse_version} > 1500
   495 %if 0%{?suse_version} > 1500
   496 #ac_add_options --enable-lto
   496 ac_add_options --enable-lto
   497 %if 0%{?do_profiling}
   497 %if 0%{?do_profiling}
   498 ac_add_options MOZ_PGO=1
   498 ac_add_options MOZ_PGO=1
   499 %endif
   499 %endif
   500 %endif
   500 %endif
   501 %endif
   501 %endif