MozillaFirefox/MozillaFirefox.spec
changeset 289 3c0dff7ca9c4
parent 287 79d59c9143a2
child 290 8e4307c73cbd
equal deleted inserted replaced
288:d51f3999a1c2 289:3c0dff7ca9c4
    17 #
    17 #
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 %define major 5
    21 %define major 5
    22 %define mainver %major.0
    22 %define mainver %major.99
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files zip fdupes Mesa-devel yasm
    25 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files zip fdupes Mesa-devel yasm
    26 %if %suse_version > 1110
    26 %if %suse_version > 1110
    27 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011061500
    38 %define         releasedate 2011070600
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
    66 Patch3:         mozilla-prefer_plugin_pref.patch
    66 Patch3:         mozilla-prefer_plugin_pref.patch
    67 Patch4:         mozilla-shared-nss-db.patch
    67 Patch4:         mozilla-shared-nss-db.patch
    68 Patch5:         mozilla-kde.patch
    68 Patch5:         mozilla-kde.patch
    69 Patch6:         mozilla-cairo-lcd.patch
    69 Patch6:         mozilla-cairo-lcd.patch
    70 Patch7:         mozilla-language.patch
    70 Patch7:         mozilla-language.patch
    71 Patch8:         mozilla-gio.patch
       
    72 Patch9:         mozilla-cairo-return.patch
    71 Patch9:         mozilla-cairo-return.patch
    73 Patch10:        mozilla-ntlm-full-path.patch
    72 Patch10:        mozilla-ntlm-full-path.patch
    74 Patch11:        mozilla-ppc-ipc.patch
       
    75 Patch12:        mozilla-repo.patch
    73 Patch12:        mozilla-repo.patch
    76 Patch13:        mozilla-dump_syms-static.patch
    74 Patch13:        mozilla-dump_syms-static.patch
    77 Patch14:        mozilla-sle11.patch
    75 Patch14:        mozilla-sle11.patch
    78 # Firefox/browser
    76 # Firefox/browser
    79 Patch30:        firefox-linkorder.patch
       
    80 Patch31:        firefox-browser-css.patch
    77 Patch31:        firefox-browser-css.patch
    81 Patch32:        firefox-cross-desktop.patch
    78 Patch32:        firefox-cross-desktop.patch
    82 Patch33:        firefox-kde.patch
    79 Patch33:        firefox-kde.patch
    83 Patch34:        firefox-kde-114.patch
    80 Patch34:        firefox-kde-114.patch
    84 Patch36:        firefox-no-sync-l10n.patch
       
    85 Patch38:        firefox-no-default-ualocale.patch
    81 Patch38:        firefox-no-default-ualocale.patch
    86 Patch39:        firefox-multilocale-chrome.patch
    82 Patch39:        firefox-multilocale-chrome.patch
    87 Patch40:        firefox-shellservice.patch
       
    88 Patch41:        firefox-branded-icons.patch
    83 Patch41:        firefox-branded-icons.patch
    89 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    84 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
    90 Requires(post):   coreutils shared-mime-info desktop-file-utils
    85 Requires(post):   coreutils shared-mime-info desktop-file-utils
    91 Requires(postun): shared-mime-info desktop-file-utils
    86 Requires(postun): shared-mime-info desktop-file-utils
    92 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
    87 Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
   199 %patch3 -p1
   194 %patch3 -p1
   200 %patch4 -p1
   195 %patch4 -p1
   201 %patch5 -p1
   196 %patch5 -p1
   202 %patch6 -p1
   197 %patch6 -p1
   203 %patch7 -p1
   198 %patch7 -p1
   204 %patch8 -p1
       
   205 %patch9 -p1
   199 %patch9 -p1
   206 %patch10 -p1
   200 %patch10 -p1
   207 %patch11 -p1
       
   208 %patch12 -p1
   201 %patch12 -p1
   209 %patch13 -p1
   202 %patch13 -p1
   210 %if %suse_version < 1120
   203 %if %suse_version < 1120
   211 %patch14 -p1
   204 %patch14 -p1
   212 %endif
   205 %endif
   213 #
   206 #
   214 %patch30 -p1
   207 #%patch30 -p1
   215 %patch31 -p1
   208 %patch31 -p1
   216 %patch32 -p1
   209 %patch32 -p1
   217 %if %suse_version >= 1110
   210 %if %suse_version >= 1110
   218 %patch33 -p1
   211 %patch33 -p1
   219 # install kde.js
   212 # install kde.js
   220 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   213 install -m 644 %{SOURCE6} browser/app/profile/kde.js
   221 %endif
   214 %endif
   222 %if %suse_version >= 1140
   215 %if %suse_version >= 1140
   223 %patch34 -p1
   216 %patch34 -p1
   224 %endif
   217 %endif
   225 %patch36 -p1
   218 #%patch36 -p1
   226 %patch38 -p1
   219 %patch38 -p1
   227 %patch39 -p1
   220 %patch39 -p1
   228 %patch40 -p1
       
   229 %patch41 -p1
   221 %patch41 -p1
   230 
   222 
   231 %build
   223 %build
   232 # no need to add build time to binaries
   224 # no need to add build time to binaries
   233 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   225 modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/%{name}.changes")"
   274 ac_add_options --disable-updater
   266 ac_add_options --disable-updater
   275 ac_add_options --disable-tests
   267 ac_add_options --disable-tests
   276 ac_add_options --disable-debug
   268 ac_add_options --disable-debug
   277 ac_add_options --enable-startup-notification
   269 ac_add_options --enable-startup-notification
   278 #ac_add_options --enable-chrome-format=jar
   270 #ac_add_options --enable-chrome-format=jar
   279 ac_add_options --enable-update-channel=default
   271 ac_add_options --enable-update-channel=beta
   280 EOF
   272 EOF
   281 %if %suse_version > 1130
   273 %if %suse_version > 1130
   282 cat << EOF >> $MOZCONFIG
   274 cat << EOF >> $MOZCONFIG
   283 ac_add_options --disable-gnomevfs
   275 ac_add_options --disable-gnomevfs
   284 ac_add_options --enable-gio
   276 ac_add_options --enable-gio
   499 %{progdir}/dictionaries/
   491 %{progdir}/dictionaries/
   500 %dir %{progdir}/extensions/
   492 %dir %{progdir}/extensions/
   501 %{progdir}/distribution/extensions/
   493 %{progdir}/distribution/extensions/
   502 %{progdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   494 %{progdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
   503 %{progdir}/icons/
   495 %{progdir}/icons/
       
   496 %{progdir}/hyphenation/
   504 %{progdir}/searchplugins/
   497 %{progdir}/searchplugins/
   505 %attr(755,root,root) %{progdir}/%{progname}.sh
   498 %attr(755,root,root) %{progdir}/%{progname}.sh
   506 %{progdir}/firefox-bin
   499 %{progdir}/firefox-bin
   507 %{progdir}/add-plugins.sh
   500 %{progdir}/add-plugins.sh
   508 %{progdir}/application.ini
   501 %{progdir}/application.ini