MozillaFirefox/MozillaFirefox.spec
changeset 283 418b5f502ff2
parent 282 78a523efc513
child 285 0287f70d86e9
equal deleted inserted replaced
282:78a523efc513 283:418b5f502ff2
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 # norootforbuild
    19 # norootforbuild
    20 
    20 
    21 %define major 4
    21 %define major 5
    22 %define mainver %major.99
    22 %define mainver %major.0
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python unzip update-desktop-files zip fdupes Mesa-devel yasm
    25 BuildRequires:  autoconf213 gcc-c++ libcurl-devel libgnomeui-devel libidl-devel libnotify-devel python startup-notification-devel unzip update-desktop-files zip fdupes Mesa-devel yasm
    26 %if %suse_version > 1110
    26 %if %suse_version > 1110
    27 BuildRequires:  libiw-devel
    27 BuildRequires:  libiw-devel
    28 BuildRequires:  libproxy-devel
    28 BuildRequires:  libproxy-devel
    29 %else
    29 %else
    30 BuildRequires:  wireless-tools
    30 BuildRequires:  wireless-tools
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011061400
    38 %define         releasedate 2011061500
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
   268 ac_add_options --with-system-zlib
   268 ac_add_options --with-system-zlib
   269 ac_add_options --disable-installer
   269 ac_add_options --disable-installer
   270 ac_add_options --disable-updater
   270 ac_add_options --disable-updater
   271 ac_add_options --disable-tests
   271 ac_add_options --disable-tests
   272 ac_add_options --disable-debug
   272 ac_add_options --disable-debug
       
   273 ac_add_options --enable-startup-notification
   273 #ac_add_options --enable-chrome-format=jar
   274 #ac_add_options --enable-chrome-format=jar
   274 ac_add_options --enable-update-channel=beta
   275 ac_add_options --enable-update-channel=default
   275 EOF
   276 EOF
   276 %if %suse_version > 1130
   277 %if %suse_version > 1130
   277 cat << EOF >> $MOZCONFIG
   278 cat << EOF >> $MOZCONFIG
   278 ac_add_options --disable-gnomevfs
   279 ac_add_options --disable-gnomevfs
   279 ac_add_options --enable-gio
   280 ac_add_options --enable-gio