MozillaFirefox/MozillaFirefox.spec
branchfirefox43
changeset 892 571212dc4d05
parent 890 4ba0eb6a14ca
child 893 86f72f1e98a4
equal deleted inserted replaced
890:4ba0eb6a14ca 892:571212dc4d05
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 43
    21 %define major 43
    22 %define mainver %major.0
    22 %define mainver %major.0.3
    23 %define update_channel release
    23 %define update_channel release
    24 %define releasedate 2015121300
    24 %define releasedate 2015122500
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
    75 BuildRequires:  libiw-devel
    75 BuildRequires:  libiw-devel
    76 BuildRequires:  libnotify-devel
    76 BuildRequires:  libnotify-devel
    77 BuildRequires:  libproxy-devel
    77 BuildRequires:  libproxy-devel
    78 BuildRequires:  makeinfo
    78 BuildRequires:  makeinfo
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.10
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.10
    80 BuildRequires:  mozilla-nss-devel >= 3.19.4
    80 BuildRequires:  mozilla-nss-devel >= 3.20.2
    81 BuildRequires:  nss-shared-helper-devel
    81 BuildRequires:  nss-shared-helper-devel
    82 BuildRequires:  python-devel
    82 BuildRequires:  python-devel
    83 BuildRequires:  startup-notification-devel
    83 BuildRequires:  startup-notification-devel
    84 BuildRequires:  unzip
    84 BuildRequires:  unzip
    85 BuildRequires:  update-desktop-files
    85 BuildRequires:  update-desktop-files
    88 BuildRequires:  zip
    88 BuildRequires:  zip
    89 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    89 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    90 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    91 BuildRequires:  pkgconfig(gstreamer-plugins-base-%gstreamer_ver)
    92 BuildRequires:  pkgconfig(libpulse)
    92 BuildRequires:  pkgconfig(libpulse)
       
    93 # libavcodec is already used if available for H.264 but
       
    94 # explicitely loaded by FF. For proper H.264 support the
       
    95 # openSUSE delivered version is not sufficient but currently
       
    96 # prevents even the use of the GStreamer method
       
    97 # https://bugzilla.mozilla.org/show_bug.cgi?id=1234157
       
    98 # to get H.264 working correctly libavcodec from packman
       
    99 # is required. As of today the following recommends will
       
   100 # pull in libavcodec52 from packman since it's the only
       
   101 # package providing libavcodec but it's not loaded from
       
   102 # Firefox as the minimal version is 53
       
   103 #Recommends:     libavcodec
    93 %if 0%{?gstreamer} == 1
   104 %if 0%{?gstreamer} == 1
    94 Requires:       libgstreamer-1_0-0
   105 Requires:       libgstreamer-1_0-0
    95 Recommends:     gstreamer-fluendo-mp3
   106 Recommends:     gstreamer-fluendo-mp3
    96 Recommends:     gstreamer-plugins-libav
   107 Recommends:     gstreamer-plugins-libav
    97 %else
   108 %else
   145 Patch6:         mozilla-ntlm-full-path.patch
   156 Patch6:         mozilla-ntlm-full-path.patch
   146 Patch7:         mozilla-repo.patch
   157 Patch7:         mozilla-repo.patch
   147 Patch8:         mozilla-openaes-decl.patch
   158 Patch8:         mozilla-openaes-decl.patch
   148 Patch10:        mozilla-no-stdcxx-check.patch
   159 Patch10:        mozilla-no-stdcxx-check.patch
   149 Patch11:        mozilla-libproxy.patch
   160 Patch11:        mozilla-libproxy.patch
       
   161 Patch12:        mozilla-bmo1233434.patch
   150 # Firefox/browser
   162 # Firefox/browser
   151 Patch101:       firefox-kde.patch
   163 Patch101:       firefox-kde.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   164 Patch102:       firefox-no-default-ualocale.patch
   153 Patch103:       firefox-branded-icons.patch
   165 Patch103:       firefox-branded-icons.patch
   154 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   166 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   254 %patch6 -p1
   266 %patch6 -p1
   255 %patch7 -p1
   267 %patch7 -p1
   256 %patch8 -p1
   268 %patch8 -p1
   257 %patch10 -p1
   269 %patch10 -p1
   258 %patch11 -p1
   270 %patch11 -p1
       
   271 %patch12 -p1
   259 # Firefox
   272 # Firefox
   260 %patch101 -p1
   273 %patch101 -p1
   261 %patch102 -p1
   274 %patch102 -p1
   262 %patch103 -p1
   275 %patch103 -p1
   263 
   276