MozillaFirefox/MozillaFirefox.spec
changeset 269 9ec311cdd7c8
parent 265 f9de3817b442
child 270 785d28fc6d4d
equal deleted inserted replaced
265:f9de3817b442 269:9ec311cdd7c8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    33 BuildRequires:  mozilla-nss-devel >= 3.12.8
    34 BuildRequires:  nss-shared-helper-devel
    34 BuildRequires:  nss-shared-helper-devel
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    35 License:        MPLv1.1 or GPLv2+ or LGPLv2+
    36 Version:        %{mainver}
    36 Version:        %{mainver}
    37 Release:        1
    37 Release:        1
    38 %define         releasedate 2011041300
    38 %define         releasedate 2011041800
    39 Provides:       web_browser
    39 Provides:       web_browser
    40 Provides:       firefox = %{version}-%{release}
    40 Provides:       firefox = %{version}-%{release}
    41 Provides:       firefox = %{mainver}
    41 Provides:       firefox = %{mainver}
    42 # this is needed to match this package with the kde4 helper package without the main package
    42 # this is needed to match this package with the kde4 helper package without the main package
    43 # having a hard requirement on the kde4 package
    43 # having a hard requirement on the kde4 package
    99 %define desktop_file_name firefox
    99 %define desktop_file_name firefox
   100 %else
   100 %else
   101 %define desktop_file_name %{name}
   101 %define desktop_file_name %{name}
   102 %endif
   102 %endif
   103 ### build options
   103 ### build options
   104 %define branding 1
   104 %define branding 0
   105 %define localize 1
   105 %define localize 1
   106 %ifarch ppc ppc64 s390 s390x ia64
   106 %ifarch ppc ppc64 s390 s390x ia64
   107 %define crashreporter    0
   107 %define crashreporter    0
   108 %define plugincontainer  0
   108 %define plugincontainer  0
   109 %else
   109 %else
   165 #BRAND: Provide three files -
   165 #BRAND: Provide three files -
   166 #BRAND: /usr/lib/firefox/browserconfig.properties that contains the
   166 #BRAND: /usr/lib/firefox/browserconfig.properties that contains the
   167 #BRAND: default homepage and some other default configuration options
   167 #BRAND: default homepage and some other default configuration options
   168 #BRAND: /usr/lib/firefox/defaults/profile/bookmarks.html that contains
   168 #BRAND: /usr/lib/firefox/defaults/profile/bookmarks.html that contains
   169 #BRAND: the list of default bookmarks
   169 #BRAND: the list of default bookmarks
   170 #BRAND: for mapping some Firefox prefs to gconf
       
   171 #BRAND: It's also possible to create a file
   170 #BRAND: It's also possible to create a file
   172 #BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
   171 #BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
   173 #BRAND: custom preference overrides.
   172 #BRAND: custom preference overrides.
   174 #BRAND: It's also possible to drop files in /usr/lib/firefox/searchplugins
   173 #BRAND: It's also possible to drop files in /usr/lib/firefox/searchplugins
   175 
   174 
   255 ac_add_options --disable-installer
   254 ac_add_options --disable-installer
   256 ac_add_options --disable-updater
   255 ac_add_options --disable-updater
   257 ac_add_options --disable-tests
   256 ac_add_options --disable-tests
   258 ac_add_options --disable-debug
   257 ac_add_options --disable-debug
   259 #ac_add_options --enable-chrome-format=jar
   258 #ac_add_options --enable-chrome-format=jar
   260 #ac_add_options --enable-update-channel=beta
   259 ac_add_options --enable-update-channel=beta
   261 EOF
   260 EOF
   262 %if %suse_version > 1130
   261 %if %suse_version > 1130
   263 cat << EOF >> $MOZCONFIG
   262 cat << EOF >> $MOZCONFIG
   264 ac_add_options --disable-gnomevfs
   263 ac_add_options --disable-gnomevfs
   265 ac_add_options --enable-gio
   264 ac_add_options --enable-gio
   361 mkdir -p $RPM_BUILD_ROOT/usr/share/pixmaps/
   360 mkdir -p $RPM_BUILD_ROOT/usr/share/pixmaps/
   362 ln -sf %{progdir}/icons/mozicon128.png $RPM_BUILD_ROOT/usr/share/pixmaps/%{progname}.png
   361 ln -sf %{progdir}/icons/mozicon128.png $RPM_BUILD_ROOT/usr/share/pixmaps/%{progname}.png
   363 ln -sf %{progdir}/icons/mozicon128.png $RPM_BUILD_ROOT/usr/share/pixmaps/%{progname}-gnome.png
   362 ln -sf %{progdir}/icons/mozicon128.png $RPM_BUILD_ROOT/usr/share/pixmaps/%{progname}-gnome.png
   364 %if %branding
   363 %if %branding
   365 for size in 16 22 24 32 48 256; do
   364 for size in 16 22 24 32 48 256; do
       
   365 %else
       
   366 for size in 16 32 48; do
       
   367 %endif
   366   mkdir -p $RPM_BUILD_ROOT%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/
   368   mkdir -p $RPM_BUILD_ROOT%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/
   367   ln -sf %{progdir}/chrome/icons/default/default$size.png \
   369   ln -sf %{progdir}/chrome/icons/default/default$size.png \
   368          $RPM_BUILD_ROOT%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/%{progname}.png
   370          $RPM_BUILD_ROOT%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/%{progname}.png
   369 done
   371 done
   370 %endif
       
   371 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   372 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
   372 # excludes
   373 # excludes
   373 rm -f $RPM_BUILD_ROOT%{progdir}/updater.ini
   374 rm -f $RPM_BUILD_ROOT%{progdir}/updater.ini
   374 rm -f $RPM_BUILD_ROOT%{progdir}/removed-files
   375 rm -f $RPM_BUILD_ROOT%{progdir}/removed-files
   375 rm -f $RPM_BUILD_ROOT%{progdir}/README.txt
   376 rm -f $RPM_BUILD_ROOT%{progdir}/README.txt
   510 %dir %{_datadir}/mozilla/extensions
   511 %dir %{_datadir}/mozilla/extensions
   511 %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
   512 %dir %{_datadir}/mozilla/extensions/%{firefox_appid}
   512 %dir %{_libdir}/mozilla
   513 %dir %{_libdir}/mozilla
   513 %dir %{_libdir}/mozilla/extensions
   514 %dir %{_libdir}/mozilla/extensions
   514 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
   515 %dir %{_libdir}/mozilla/extensions/%{firefox_appid}
   515 %if %branding
       
   516 %{gnome_dir}/share/icons/hicolor/
   516 %{gnome_dir}/share/icons/hicolor/
   517 %endif
       
   518 %{_bindir}/%{progname}
   517 %{_bindir}/%{progname}
   519 %doc %{_mandir}/man1/%{progname}.1.gz
   518 %doc %{_mandir}/man1/%{progname}.1.gz
   520 
   519 
   521 %files devel
   520 %files devel
   522 %defattr(-,root,root)
   521 %defattr(-,root,root)