MozillaFirefox/MozillaFirefox.spec
changeset 850 a2bdff616a0e
parent 845 a704b2a17e39
child 851 0855c4ac4793
equal deleted inserted replaced
845:a704b2a17e39 850:a2bdff616a0e
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 37
    21 %define major 37
    22 %define mainver %major.99
    22 %define mainver %major.99
    23 %define update_channel beta
    23 %define update_channel beta
    24 %define releasedate 2015040700
    24 %define releasedate 2015042200
    25 
    25 
    26 # general build definitions
    26 # general build definitions
    27 %if "%{update_channel}" != "aurora"
    27 %if "%{update_channel}" != "aurora"
    28 %define progname firefox
    28 %define progname firefox
    29 %define pkgname  MozillaFirefox
    29 %define pkgname  MozillaFirefox
    75 BuildRequires:  libiw-devel
    75 BuildRequires:  libiw-devel
    76 BuildRequires:  libnotify-devel
    76 BuildRequires:  libnotify-devel
    77 BuildRequires:  libproxy-devel
    77 BuildRequires:  libproxy-devel
    78 BuildRequires:  makeinfo
    78 BuildRequires:  makeinfo
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.8
    79 BuildRequires:  mozilla-nspr-devel >= 4.10.8
    80 BuildRequires:  mozilla-nss-devel >= 3.18
    80 BuildRequires:  mozilla-nss-devel >= 3.18.1
    81 BuildRequires:  nss-shared-helper-devel
    81 BuildRequires:  nss-shared-helper-devel
    82 BuildRequires:  python-devel
    82 BuildRequires:  python-devel
    83 BuildRequires:  startup-notification-devel
    83 BuildRequires:  startup-notification-devel
    84 BuildRequires:  unzip
    84 BuildRequires:  unzip
    85 BuildRequires:  update-desktop-files
    85 BuildRequires:  update-desktop-files
   142 Patch8:         mozilla-ntlm-full-path.patch
   142 Patch8:         mozilla-ntlm-full-path.patch
   143 Patch9:         mozilla-repo.patch
   143 Patch9:         mozilla-repo.patch
   144 Patch10:        mozilla-icu-strncat.patch
   144 Patch10:        mozilla-icu-strncat.patch
   145 Patch11:        mozilla-arm-disable-edsp.patch
   145 Patch11:        mozilla-arm-disable-edsp.patch
   146 Patch12:        mozilla-openaes-decl.patch
   146 Patch12:        mozilla-openaes-decl.patch
   147 Patch13:        mozilla-skia-bmo1136958.patch
       
   148 Patch14:        mozilla-skia-be-le.patch
   147 Patch14:        mozilla-skia-be-le.patch
   149 Patch15:        mozilla-bmo1005535.patch
   148 Patch15:        mozilla-bmo1005535.patch
   150 # Firefox/browser
   149 # Firefox/browser
   151 Patch101:       firefox-kde.patch
   150 Patch101:       firefox-kde.patch
   152 Patch102:       firefox-no-default-ualocale.patch
   151 Patch102:       firefox-no-default-ualocale.patch
   257 %patch8 -p1
   256 %patch8 -p1
   258 %patch9 -p1
   257 %patch9 -p1
   259 %patch10 -p1
   258 %patch10 -p1
   260 %patch11 -p1
   259 %patch11 -p1
   261 %patch12 -p1
   260 %patch12 -p1
   262 %patch13 -p1
       
   263 %patch14 -p1
   261 %patch14 -p1
   264 %patch15 -p1
   262 %patch15 -p1
   265 # Firefox
   263 # Firefox
   266 %patch101 -p1
   264 %patch101 -p1
   267 %patch102 -p1
   265 %patch102 -p1
   340 #ac_add_options --enable-chrome-format=jar
   338 #ac_add_options --enable-chrome-format=jar
   341 ac_add_options --enable-update-channel=%{update_channel}
   339 ac_add_options --enable-update-channel=%{update_channel}
   342 %if 0%{?gstreamer} == 1
   340 %if 0%{?gstreamer} == 1
   343 ac_add_options --enable-gstreamer=1.0
   341 ac_add_options --enable-gstreamer=1.0
   344 %endif
   342 %endif
   345 ac_add_options --disable-gnomevfs
       
   346 ac_add_options --enable-gio
       
   347 %if %branding
   343 %if %branding
   348 ac_add_options --enable-official-branding
   344 ac_add_options --enable-official-branding
   349 %endif
   345 %endif
   350 ac_add_options --enable-libproxy
   346 ac_add_options --enable-libproxy
   351 %if ! %crashreporter
   347 %if ! %crashreporter