MozillaFirefox/MozillaFirefox.spec
branchfirefox52
changeset 944 ce8a98f8d8d7
parent 943 ace605efe50f
child 945 7b1e775ff77a
equal deleted inserted replaced
943:ace605efe50f 944:ce8a98f8d8d7
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major 51
    21 %define major 52
    22 %define mainver %major.99
    22 %define mainver %major.0
    23 %define update_channel beta
    23 %define update_channel release
    24 %define releasedate 20170224000000
    24 %define releasedate 20170302000000
    25 
    25 
    26 # PIE, full relro (x86_64 for now)
    26 # PIE, full relro (x86_64 for now)
    27 %define build_hardened 1
    27 %define build_hardened 1
    28 
    28 
    29 %if 0%{?suse_version} > 1320
    29 %if 0%{?suse_version} > 1320
    30 %define firefox_use_gtk3 1
    30 %define firefox_use_gtk3 1
    31 %define firefox_use_rust 1
    31 %define firefox_use_rust 1
    32 %endif
    32 %endif
    33 
       
    34 
    33 
    35 # general build definitions
    34 # general build definitions
    36 %if "%{update_channel}" != "aurora"
    35 %if "%{update_channel}" != "aurora"
    37 %define progname firefox
    36 %define progname firefox
    38 %define pkgname  MozillaFirefox
    37 %define pkgname  MozillaFirefox
    79 BuildRequires:  libiw-devel
    78 BuildRequires:  libiw-devel
    80 BuildRequires:  libnotify-devel
    79 BuildRequires:  libnotify-devel
    81 BuildRequires:  libproxy-devel
    80 BuildRequires:  libproxy-devel
    82 BuildRequires:  makeinfo
    81 BuildRequires:  makeinfo
    83 BuildRequires:  mozilla-nspr-devel >= 4.13.1
    82 BuildRequires:  mozilla-nspr-devel >= 4.13.1
    84 BuildRequires:  mozilla-nss-devel >= 3.28.2
    83 BuildRequires:  mozilla-nss-devel >= 3.28.3
    85 BuildRequires:  nss-shared-helper-devel
    84 BuildRequires:  nss-shared-helper-devel
    86 BuildRequires:  python-devel
    85 BuildRequires:  python-devel
    87 BuildRequires:  startup-notification-devel
    86 BuildRequires:  startup-notification-devel
    88 BuildRequires:  unzip
    87 BuildRequires:  unzip
    89 BuildRequires:  update-desktop-files
    88 BuildRequires:  update-desktop-files
    98 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
    97 BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
    99 %endif
    98 %endif
   100 %if 0%{?firefox_use_rust}
    99 %if 0%{?firefox_use_rust}
   101 BuildRequires:  cargo
   100 BuildRequires:  cargo
   102 BuildRequires:  rust >= 1.10
   101 BuildRequires:  rust >= 1.10
       
   102 BuildRequires:  rust-std
   103 %endif
   103 %endif
   104 # libavcodec is required for H.264 support but the
   104 # libavcodec is required for H.264 support but the
   105 # openSUSE version is currently not able to play H.264
   105 # openSUSE version is currently not able to play H.264
   106 # therefore the Packman version is required
   106 # therefore the Packman version is required
   107 # minimum version of libavcodec is 53
   107 # minimum version of libavcodec is 53