MozillaFirefox/MozillaFirefox.spec
branchfirefox118
changeset 1194 d1b75dcb25fc
parent 1193 16de98d33e97
child 1195 78bbadb03249
equal deleted inserted replaced
1193:16de98d33e97 1194:d1b75dcb25fc
    26 # orig_version would be the upstream tar ball
    26 # orig_version would be the upstream tar ball
    27 # orig_version 70.0
    27 # orig_version 70.0
    28 # orig_suffix b3
    28 # orig_suffix b3
    29 # major 69
    29 # major 69
    30 # mainver %%major.99
    30 # mainver %%major.99
    31 %define major          117
    31 %define major          118
    32 %define mainver        %major.0.1
    32 %define mainver        %major.0.1
    33 %define orig_version   117.0.1
    33 %define orig_version   118.0.1
    34 %define orig_suffix    %{nil}
    34 %define orig_suffix    %{nil}
    35 %define update_channel release
    35 %define update_channel release
    36 %define branding       1
    36 %define branding       1
    37 %define devpkg         1
    37 %define devpkg         1
    38 
    38 
    71 %define progdir %{_prefix}/%_lib/%{progname}
    71 %define progdir %{_prefix}/%_lib/%{progname}
    72 %define gnome_dir     %{_prefix}
    72 %define gnome_dir     %{_prefix}
    73 %define desktop_file_name %{progname}
    73 %define desktop_file_name %{progname}
    74 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    74 %define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
    75 %define __provides_exclude ^lib.*\\.so.*$
    75 %define __provides_exclude ^lib.*\\.so.*$
    76 %define __requires_exclude ^(libmoz.*|liblgpllibs.*|libxul.*)$
    76 %define __requires_exclude ^(libmoz.*|liblgpllibs.*|libxul.*|libgk.*)$
    77 %define localize 1
    77 %define localize 1
    78 %ifarch %ix86 x86_64
    78 %ifarch %ix86 x86_64
    79 %define crashreporter 1
    79 %define crashreporter 1
    80 %else
    80 %else
    81 %define crashreporter 0
    81 %define crashreporter 0
   112 BuildRequires:  libcurl-devel
   112 BuildRequires:  libcurl-devel
   113 BuildRequires:  libiw-devel
   113 BuildRequires:  libiw-devel
   114 BuildRequires:  libproxy-devel
   114 BuildRequires:  libproxy-devel
   115 BuildRequires:  makeinfo
   115 BuildRequires:  makeinfo
   116 BuildRequires:  mozilla-nspr-devel >= 4.35
   116 BuildRequires:  mozilla-nspr-devel >= 4.35
   117 BuildRequires:  mozilla-nss-devel >= 3.92
   117 BuildRequires:  mozilla-nss-devel >= 3.93
   118 BuildRequires:  nasm >= 2.14
   118 BuildRequires:  nasm >= 2.14
   119 BuildRequires:  nodejs >= 12.22.12
   119 BuildRequires:  nodejs >= 12.22.12
   120 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   120 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   121 BuildRequires:  libXtst-devel
   121 BuildRequires:  libXtst-devel
   122 BuildRequires:  python-libxml2
   122 BuildRequires:  python-libxml2
   207 Source19:       google-api-key
   207 Source19:       google-api-key
   208 Source20:       https://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/source/%{srcname}-%{orig_version}%{orig_suffix}.source.tar.xz.asc
   208 Source20:       https://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/source/%{srcname}-%{orig_version}%{orig_suffix}.source.tar.xz.asc
   209 Source21:       https://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/KEY#/mozilla.keyring
   209 Source21:       https://ftp.mozilla.org/pub/%{srcname}/releases/%{version}%{orig_suffix}/KEY#/mozilla.keyring
   210 # Gecko/Toolkit
   210 # Gecko/Toolkit
   211 Patch1:         mozilla-nongnome-proxies.patch
   211 Patch1:         mozilla-nongnome-proxies.patch
   212 Patch2:         mozilla-kde.patch
   212 #Patch2:         mozilla-kde.patch
   213 Patch3:         mozilla-ntlm-full-path.patch
   213 Patch3:         mozilla-ntlm-full-path.patch
   214 Patch4:         mozilla-aarch64-startup-crash.patch
   214 Patch4:         mozilla-aarch64-startup-crash.patch
   215 Patch5:         mozilla-fix-aarch64-libopus.patch
   215 Patch5:         mozilla-fix-aarch64-libopus.patch
   216 Patch6:         mozilla-s390-context.patch
   216 Patch6:         mozilla-s390-context.patch
   217 Patch7:         mozilla-pgo.patch
   217 Patch7:         mozilla-pgo.patch
   228 Patch21:        svg-rendering.patch
   228 Patch21:        svg-rendering.patch
   229 Patch22:        mozilla-partial-revert-1768632.patch
   229 Patch22:        mozilla-partial-revert-1768632.patch
   230 Patch23:        mozilla-rust-disable-future-incompat.patch
   230 Patch23:        mozilla-rust-disable-future-incompat.patch
   231 Patch24:        mozilla-bmo1822730.patch
   231 Patch24:        mozilla-bmo1822730.patch
   232 # Firefox/browser
   232 # Firefox/browser
   233 Patch101:       firefox-kde.patch
   233 #Patch101:       firefox-kde.patch
   234 Patch102:       firefox-branded-icons.patch
   234 Patch102:       firefox-branded-icons.patch
   235 %endif
   235 %endif
   236 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   236 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   237 Requires(post): coreutils shared-mime-info desktop-file-utils
   237 Requires(post): coreutils shared-mime-info desktop-file-utils
   238 Requires(postun):shared-mime-info desktop-file-utils
   238 Requires(postun):shared-mime-info desktop-file-utils
   347 sed -i "s|/usr/bin/env python3|/usr/bin/env python3.9|" mach
   347 sed -i "s|/usr/bin/env python3|/usr/bin/env python3.9|" mach
   348 sed -i "s|potential_python_binary = f\"python3.{i}\"|potential_python_binary = f\"python3.9.{i}\"|" mach
   348 sed -i "s|potential_python_binary = f\"python3.{i}\"|potential_python_binary = f\"python3.9.{i}\"|" mach
   349 export PYTHON3=/usr/bin/python3.9
   349 export PYTHON3=/usr/bin/python3.9
   350 %endif
   350 %endif
   351 
   351 
   352 kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   352 #kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
   353 if test "$kdehelperversion" != %{kde_helper_version}; then
   353 #if test "$kdehelperversion" != %{kde_helper_version}; then
   354   echo fix kde helper version in the .spec file
   354 #  echo fix kde helper version in the .spec file
   355   exit 1
   355 #  exit 1
   356 fi
   356 #fi
   357 
   357 
   358 # When doing only_print_mozconfig, this file isn't necessarily available, so skip it
   358 # When doing only_print_mozconfig, this file isn't necessarily available, so skip it
   359 cp %{SOURCE4} .obsenv.sh
   359 cp %{SOURCE4} .obsenv.sh
   360 %else
   360 %else
   361 # We need to make sure its empty
   361 # We need to make sure its empty