MozillaFirefox/MozillaFirefox.spec
changeset 762 f20576d5885a
parent 761 c748af0c7534
child 763 9f6de8c8a5c5
child 768 af83869ba02e
equal deleted inserted replaced
748:72ba5129e5fd 762:f20576d5885a
    15 
    15 
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 %define major 31
    20 %define major 32
    21 %define mainver %major.98
    21 %define mainver %major.0.1
    22 %define update_channel aurora
    22 %define update_channel release
    23 
    23 
    24 %if %suse_version > 1210
    24 %if %suse_version > 1210
    25 %if %suse_version > 1310
    25 %if %suse_version > 1310
    26 %define gstreamer_ver 1.0
    26 %define gstreamer_ver 1.0
    27 %define gstreamer 1
    27 %define gstreamer 1
    53 BuildRequires:  libproxy-devel
    53 BuildRequires:  libproxy-devel
    54 %else
    54 %else
    55 BuildRequires:  wireless-tools
    55 BuildRequires:  wireless-tools
    56 %endif
    56 %endif
    57 BuildRequires:  mozilla-nspr-devel >= 4.10.6
    57 BuildRequires:  mozilla-nspr-devel >= 4.10.6
    58 BuildRequires:  mozilla-nss-devel >= 3.16.3
    58 BuildRequires:  mozilla-nss-devel >= 3.16.4
    59 BuildRequires:  nss-shared-helper-devel
    59 BuildRequires:  nss-shared-helper-devel
    60 BuildRequires:  pkgconfig(libpulse)
    60 BuildRequires:  pkgconfig(libpulse)
    61 %if %suse_version > 1210
    61 %if %suse_version > 1210
    62 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    62 BuildRequires:  pkgconfig(gstreamer-%gstreamer_ver)
    63 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    63 BuildRequires:  pkgconfig(gstreamer-app-%gstreamer_ver)
    72 Recommends:     gstreamer-0_10-plugins-ffmpeg
    72 Recommends:     gstreamer-0_10-plugins-ffmpeg
    73 %endif
    73 %endif
    74 %endif
    74 %endif
    75 Version:        %{mainver}
    75 Version:        %{mainver}
    76 Release:        0
    76 Release:        0
    77 %define         releasedate 2014061200
    77 %define         releasedate 2014091200
    78 Provides:       firefox = %{mainver}
    78 Provides:       firefox = %{mainver}
    79 Provides:       firefox = %{version}-%{release}
    79 Provides:       firefox = %{version}-%{release}
    80 Provides:       web_browser
    80 Provides:       web_browser
    81 Provides:       browser(npapi)
    81 Provides:       browser(npapi)
    82 # this is needed to match this package with the kde4 helper package without the main package
    82 # this is needed to match this package with the kde4 helper package without the main package
   152 ### build options
   152 ### build options
   153 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
   153 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
   154 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   154 # Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
   155 # please get your own set of keys.
   155 # please get your own set of keys.
   156 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
   156 %define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
   157 %define branding 0
   157 %define branding 1
   158 %define localize 1
   158 %define localize 1
   159 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
   159 %ifarch aarch64 ppc ppc64 ppc64le s390 s390x ia64 %arm
   160 %define crashreporter 0
   160 %define crashreporter 0
   161 %else
   161 %else
   162 %define crashreporter 1
   162 %define crashreporter 1
   347 %ifarch %arm
   347 %ifarch %arm
   348 ac_add_options --disable-neon
   348 ac_add_options --disable-neon
   349 %endif
   349 %endif
   350 %ifnarch %ix86 x86_64
   350 %ifnarch %ix86 x86_64
   351 ac_add_options --disable-webrtc
   351 ac_add_options --disable-webrtc
       
   352 %endif
       
   353 # try to use OpenGL-ES on ARM
       
   354 %ifarch %arm
       
   355 ac_add_options --with-gl-provider=EGL
   352 %endif
   356 %endif
   353 EOF
   357 EOF
   354 make -f client.mk build
   358 make -f client.mk build
   355 
   359 
   356 %install
   360 %install