MozillaFirefox/MozillaFirefox.spec
branchfirefox81
changeset 1145 fbfd8f7cbd53
parent 1144 8a43aff7e982
child 1147 e81381ea5f3d
equal deleted inserted replaced
1144:8a43aff7e982 1145:fbfd8f7cbd53
    14 # published by the Open Source Initiative.
    14 # published by the Open Source Initiative.
    15 
    15 
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
       
    19 
       
    20 %if 0%{?suse_version} < 1550 && 0%{?sle_version} <= 150100
       
    21 #!BuildIgnore: post-build-checks
       
    22 %endif
    19 
    23 
    20 # changed with every update
    24 # changed with every update
    21 # orig_version vs. mainver: To have beta-builds
    25 # orig_version vs. mainver: To have beta-builds
    22 # FF70beta3 would be released as FF69.99
    26 # FF70beta3 would be released as FF69.99
    23 # orig_version would be the upstream tar ball
    27 # orig_version would be the upstream tar ball
    98 BuildRequires:  makeinfo
   102 BuildRequires:  makeinfo
    99 BuildRequires:  mozilla-nspr-devel >= 4.28
   103 BuildRequires:  mozilla-nspr-devel >= 4.28
   100 BuildRequires:  mozilla-nss-devel >= 3.56
   104 BuildRequires:  mozilla-nss-devel >= 3.56
   101 BuildRequires:  nasm >= 2.14
   105 BuildRequires:  nasm >= 2.14
   102 BuildRequires:  nodejs10 >= 10.21.0
   106 BuildRequires:  nodejs10 >= 10.21.0
   103 BuildRequires:  python-devel
       
   104 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   107 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
   105 BuildRequires:  python-libxml2
   108 BuildRequires:  python-libxml2
   106 BuildRequires:  python36
   109 BuildRequires:  python36
   107 %else
   110 %else
   108 BuildRequires:  python2-xml
   111 BuildRequires:  python3-devel
   109 BuildRequires:  python3 >= 3.5
   112 BuildRequires:  python3 >= 3.5
       
   113 BuildRequires:  python3-curses
   110 %endif
   114 %endif
   111 BuildRequires:  rust >= 1.43
   115 BuildRequires:  rust >= 1.43
   112 BuildRequires:  rust-cbindgen >= 0.14.3
   116 BuildRequires:  rust-cbindgen >= 0.14.3
   113 BuildRequires:  unzip
   117 BuildRequires:  unzip
   114 BuildRequires:  update-desktop-files
   118 BuildRequires:  update-desktop-files
   207 Patch24:        mozilla-bmo1602730.patch
   211 Patch24:        mozilla-bmo1602730.patch
   208 Patch25:        mozilla-bmo998749.patch
   212 Patch25:        mozilla-bmo998749.patch
   209 Patch26:        mozilla-bmo1626236.patch
   213 Patch26:        mozilla-bmo1626236.patch
   210 Patch27:        mozilla-s390x-skia-gradient.patch
   214 Patch27:        mozilla-s390x-skia-gradient.patch
   211 Patch28:        mozilla-libavcodec58_91.patch
   215 Patch28:        mozilla-libavcodec58_91.patch
   212 Patch29:        mozilla-silence-no-return-type.patch
   216 Patch29:        revert-795c8762b16b.patch
   213 Patch30:        revert-795c8762b16b.patch
       
   214 # Firefox/browser
   217 # Firefox/browser
   215 Patch101:       firefox-kde.patch
   218 Patch101:       firefox-kde.patch
   216 Patch102:       firefox-branded-icons.patch
   219 Patch102:       firefox-branded-icons.patch
   217 %endif
   220 %endif
   218 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   221 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
   351 %patch24 -p1
   354 %patch24 -p1
   352 %patch25 -p1
   355 %patch25 -p1
   353 %patch26 -p1
   356 %patch26 -p1
   354 %patch27 -p1
   357 %patch27 -p1
   355 %patch28 -p1
   358 %patch28 -p1
   356 %patch29 -p1
   359 %patch29 -p1 -R
   357 %patch30 -p1 -R
       
   358 # Firefox
   360 # Firefox
   359 %patch101 -p1
   361 %patch101 -p1
   360 %patch102 -p1
   362 %patch102 -p1
   361 %endif
   363 %endif
   362 
   364 
   392 export MOZ_SOURCE_REPO=$RELEASE_REPO
   394 export MOZ_SOURCE_REPO=$RELEASE_REPO
   393 export MOZ_BUILD_DATE=$RELEASE_TIMESTAMP
   395 export MOZ_BUILD_DATE=$RELEASE_TIMESTAMP
   394 export MOZILLA_OFFICIAL=1
   396 export MOZILLA_OFFICIAL=1
   395 export BUILD_OFFICIAL=1
   397 export BUILD_OFFICIAL=1
   396 export MOZ_TELEMETRY_REPORTING=1
   398 export MOZ_TELEMETRY_REPORTING=1
       
   399 export MACH_USE_SYSTEM_PYTHON=1
   397 %if 0%{?suse_version} <= 1320
   400 %if 0%{?suse_version} <= 1320
   398 export CC=gcc-9
   401 export CC=gcc-9
   399 %else
   402 %else
   400 %if 0%{?clang_build} == 0
   403 %if 0%{?clang_build} == 0
   401 export CC=gcc
   404 export CC=gcc