MozillaFirefox/firefox-esr.spec
branchfirefox52
changeset 950 266ac4247974
child 957 b28ad21f195e
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/MozillaFirefox/firefox-esr.spec	Wed Mar 22 08:35:22 2017 +0100
@@ -0,0 +1,655 @@
+#
+# spec file for package firefox-esr
+#
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+#               2006-2017 Wolfgang Rosenauer
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
+
+# changed with every update
+%define major 52
+%define mainver %major.0.1
+%define update_channel esr52
+%define releasedate 20170317000000
+
+# PIE, full relro (x86_64 for now)
+%define build_hardened 1
+
+%if 0%{?suse_version} > 1320
+%define firefox_use_gtk3 1
+%ifarch %ix86 x86_64
+%define firefox_use_rust 1
+%endif
+%endif
+
+# general build definitions
+%if "%{update_channel}" != "aurora"
+%define progname firefox
+%define pkgname  firefox-esr
+%define appname  Firefox
+%else
+%define progname firefox-dev
+%define pkgname  firefox-dev-edition
+%define appname  Firefox Developer Edition
+%endif
+%define progdir %{_prefix}/%_lib/%{progname}
+%define gnome_dir     %{_prefix}
+%define desktop_file_name %{progname}
+%define firefox_appid \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
+%define _use_internal_dependency_generator 0
+%define __find_requires sh %{SOURCE4}
+%global provfind sh -c "grep -v '.so' | %__find_provides"
+%global __find_provides %provfind
+# Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
+# Note: these are for the openSUSE Firefox builds ONLY. For your own distribution,
+# please get your own set of keys.
+%define _google_api_key AIzaSyD1hTe85_a14kr1Ks8T3Ce75rvbR1_Dx7Q
+%if %update_channel == "aurora"
+%define branding 0
+%else
+%define branding 1
+%endif
+%define localize 1
+%ifarch %ix86 x86_64
+%define crashreporter 1
+%else
+%define crashreporter 0
+%endif
+
+Name:           %{pkgname}
+BuildRequires:  Mesa-devel
+BuildRequires:  autoconf213
+BuildRequires:  dbus-1-glib-devel
+BuildRequires:  fdupes
+BuildRequires:  gcc-c++
+BuildRequires:  libXcomposite-devel
+BuildRequires:  libcurl-devel
+BuildRequires:  libgnomeui-devel
+BuildRequires:  libidl-devel
+BuildRequires:  libiw-devel
+BuildRequires:  libnotify-devel
+BuildRequires:  libproxy-devel
+BuildRequires:  makeinfo
+BuildRequires:  mozilla-nspr-devel >= 4.13.1
+BuildRequires:  mozilla-nss-devel >= 3.28.3
+BuildRequires:  nss-shared-helper-devel
+BuildRequires:  python-devel
+BuildRequires:  startup-notification-devel
+BuildRequires:  unzip
+BuildRequires:  update-desktop-files
+BuildRequires:  xorg-x11-libXt-devel
+BuildRequires:  yasm
+BuildRequires:  zip
+BuildRequires:  pkgconfig(libpulse)
+BuildRequires:  pkgconfig(libffi)
+%if 0%{?firefox_use_gtk3}
+BuildRequires:  pkgconfig(glib-2.0)
+BuildRequires:  pkgconfig(gobject-2.0)
+BuildRequires:  pkgconfig(gtk+-3.0) >= 3.4.0
+BuildRequires:  pkgconfig(gtk+-unix-print-3.0)
+%endif
+%if 0%{?firefox_use_rust}
+BuildRequires:  cargo
+BuildRequires:  rust >= 1.10
+BuildRequires:  rust-std
+%endif
+# libavcodec is required for H.264 support but the
+# openSUSE version is currently not able to play H.264
+# therefore the Packman version is required
+# minimum version of libavcodec is 53
+Recommends:     libavcodec-full >= 0.10.16
+Version:        %{mainver}
+Release:        0
+%if "%{name}" == "MozillaFirefox"
+Provides:       firefox-esr = %{mainver}
+Provides:       firefox-esr = %{version}-%{release}
+%endif
+Provides:       web_browser
+Provides:       browser(npapi)
+%if "%{update_channel}" != "aurora"
+Provides:       appdata()
+Provides:       appdata(firefox.appdata.xml)
+%endif
+# this is needed to match this package with the kde4 helper package without the main package
+# having a hard requirement on the kde4 package
+%define kde_helper_version 6
+Provides:       mozilla-kde4-version = %{kde_helper_version}
+Conflicts:      firefox
+Summary:        Mozilla %{appname} Web Browser
+License:        MPL-2.0
+Group:          Productivity/Networking/Web/Browsers
+Url:            http://www.mozilla.org/
+Source:         firefox-%{version}-source.tar.xz
+Source1:        MozillaFirefox.desktop
+Source2:        MozillaFirefox-rpmlintrc
+Source3:        mozilla.sh.in
+Source4:        find-external-requires.sh
+Source5:        source-stamp.txt
+Source6:        kde.js
+Source7:        l10n-%{version}.tar.xz
+Source8:        firefox-mimeinfo.xml
+Source9:        firefox.js
+Source10:       compare-locales.tar.xz
+Source11:       firefox.1
+Source12:       mozilla-get-app-id
+Source13:       spellcheck.js
+Source14:       create-tar.sh
+Source15:       firefox-appdata.xml
+Source16:       firefox-esr.changes
+Source17:       l10n_changesets.txt
+# Gecko/Toolkit
+Patch1:         mozilla-nongnome-proxies.patch
+Patch2:         mozilla-shared-nss-db.patch
+Patch3:         mozilla-kde.patch
+Patch4:         mozilla-preferences.patch
+Patch5:         mozilla-language.patch
+Patch6:         mozilla-ntlm-full-path.patch
+Patch7:         mozilla-openaes-decl.patch
+Patch8:         mozilla-no-stdcxx-check.patch
+Patch9:         mozilla-reduce-files-per-UnifiedBindings.patch
+Patch10:        mozilla-aarch64-startup-crash.patch
+# Firefox/browser
+Patch101:       firefox-kde.patch
+Patch102:       firefox-no-default-ualocale.patch
+Patch103:       firefox-branded-icons.patch
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-build
+Requires(post):   coreutils shared-mime-info desktop-file-utils
+Requires(postun): shared-mime-info desktop-file-utils
+%if %branding
+Requires:       %{name}-branding > 44.0
+%endif
+Requires:       mozilla-nspr >= %(rpm -q --queryformat '%{VERSION}' mozilla-nspr)
+Requires:       mozilla-nss >= %(rpm -q --queryformat '%{VERSION}' mozilla-nss)
+Recommends:     libcanberra0
+Recommends:     libpulse0
+# addon leads to startup crash (bnc#908892)
+Obsoletes:      tracker-miner-firefox < 0.15
+# libproxy's mozjs pacrunner crashes FF (bnc#759123)
+%if 0%{?suse_version} < 1220
+Obsoletes:      libproxy1-pacrunner-mozjs <= 0.4.7
+%endif
+
+%description
+Mozilla Firefox is a standalone web browser, designed for standards
+compliance and performance.  Its functionality can be enhanced via a
+plethora of extensions.
+
+%package devel
+Summary:        Devel package for %{appname}
+Group:          Development/Tools/Other
+Provides:       firefox-devel = %{version}-%{release}
+Requires:       %{name} = %{version}
+Requires:       perl(Archive::Zip)
+Requires:       perl(XML::Simple)
+
+%description devel
+Development files for %{appname} to make packaging of addons easier.
+
+%if %localize
+%package translations-common
+Summary:        Common translations for %{appname}
+Group:          System/Localization
+Provides:       locale(%{name}:ar;ca;cs;da;de;en_GB;el;es_AR;es_CL;es_ES;fi;fr;hu;it;ja;ko;nb_NO;nl;pl;pt_BR;pt_PT;ru;sv_SE;zh_CN;zh_TW)
+Requires:       %{name} = %{version}
+Obsoletes:      %{name}-translations < %{version}-%{release}
+
+%description translations-common
+This package contains several common languages for the user interface
+of %{appname}.
+
+%package translations-other
+Summary:        Extra translations for %{appname}
+Group:          System/Localization
+Provides:       locale(%{name}:ach;af;an;as;ast;az;bg;bn_BD;bn_IN;br;bs;cak;cy;dsb;en_ZA;eo;es_MX;et;eu;fa;ff;fy_NL;ga_IE;gd;gl;gn;gu_IN;he;hi_IN;hr;hsb;hy_AM;id;is;ka;kab;kk;km;kn;lij;lt;lv;mai;mk;ml;mr;ms;nn_NO;or;pa_IN;rm;ro;si;sk;sl;son;sq;sr;ta;te;th;tr;uk;uz;vi;xh)
+Requires:       %{name} = %{version}
+Obsoletes:      %{name}-translations < %{version}-%{release}
+
+%description translations-other
+This package contains rarely used languages for the user interface
+of %{appname}.
+%endif
+
+%if %branding
+%package branding-upstream
+Summary:        Upstream branding for %{appname}
+Group:          Productivity/Networking/Web/Browsers
+Provides:       %{name}-branding = %{version}
+Conflicts:      otherproviders(MozillaFirefox-branding)
+Supplements:    packageand(%{name}:branding-upstream)
+#BRAND: Provide three files -
+#BRAND: /usr/lib/firefox/browserconfig.properties that contains the
+#BRAND: default homepage and some other default configuration options
+#BRAND: /usr/lib/firefox/defaults/profile/bookmarks.html that contains
+#BRAND: the list of default bookmarks
+#BRAND: It's also possible to create a file
+#BRAND: /usr/lib/firefox/defaults/preferences/firefox-$vendor.js to set
+#BRAND: custom preference overrides.
+#BRAND: It's also possible to drop files in /usr/lib/firefox/distribution/searchplugins/common/
+
+%description branding-upstream
+This package provides upstream look and feel for %{appname}.
+%endif
+
+%if %crashreporter
+%package buildsymbols
+Summary:        Breakpad buildsymbols for %{appname}
+Group:          Development/Debug
+
+%description buildsymbols
+This subpackage contains the Breakpad created and compatible debugging
+symbols meant for upload to Mozilla's crash collector database.
+%endif
+
+%prep
+%if %localize
+%setup -q -n mozilla -b 7 -b 10
+%else
+%setup -q -n mozilla
+%endif
+cd $RPM_BUILD_DIR/mozilla
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+# Firefox
+%patch101 -p1
+%patch102 -p1
+%patch103 -p1
+
+%build
+# no need to add build time to binaries
+modified="$(sed -n '/^----/n;s/ - .*$//;p;q' "%{_sourcedir}/firefox-esr.changes")"
+DATE="\"$(date -d "${modified}" "+%%b %%e %%Y")\""
+TIME="\"$(date -d "${modified}" "+%%R")\""
+find . -regex ".*\.c\|.*\.cpp\|.*\.h" -exec sed -i "s/__DATE__/${DATE}/g;s/__TIME__/${TIME}/g" {} +
+#
+kdehelperversion=$(cat toolkit/xre/nsKDEUtils.cpp | grep '#define KMOZILLAHELPER_VERSION' | cut -d ' ' -f 3)
+if test "$kdehelperversion" != %{kde_helper_version}; then
+  echo fix kde helper version in the .spec file
+  exit 1
+fi
+source %{SOURCE5}
+export MOZ_SOURCE_CHANGESET=$REV
+export SOURCE_REPO=$REPO
+export source_repo=$REPO
+export MOZ_SOURCE_REPO=$REPO
+export MOZ_BUILD_DATE=%{releasedate}
+export MOZILLA_OFFICIAL=1
+export BUILD_OFFICIAL=1
+export MOZ_TELEMETRY_REPORTING=1
+export MOZ_GOOGLE_API_KEY=%{_google_api_key}
+export CFLAGS="%{optflags} -fno-strict-aliasing"
+# boo#986541: add -fno-delete-null-pointer-checks and -fno-inline-small-functions for gcc6
+%if 0%{?suse_version} > 1320
+export CFLAGS="$CFLAGS -fno-delete-null-pointer-checks -fno-inline-small-functions"
+%endif
+%ifarch %arm
+export CFLAGS="${CFLAGS/-g / }"
+%endif
+%ifarch %arm %ix86
+# Limit RAM usage during link
+export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+%endif
+%if 0%{?build_hardened}
+%ifarch x86_64
+export LDFLAGS="${LDFLAGS} -Wl,-z,relro,-z,now"
+%endif
+%endif
+%ifarch ppc64 ppc64le
+export CFLAGS="$CFLAGS -mminimal-toc"
+%endif
+export CXXFLAGS="$CFLAGS"
+export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
+cat << EOF > $MOZCONFIG
+mk_add_options MOZILLA_OFFICIAL=1
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZ_MAKE_FLAGS=%{?jobs:-j%jobs}
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj
+. \$topsrcdir/browser/config/mozconfig
+ac_add_options --prefix=%{_prefix}
+ac_add_options --libdir=%{_libdir}
+ac_add_options --includedir=%{_includedir}
+ac_add_options --enable-release
+%if 0%{?firefox_use_rust}
+ac_add_options --enable-rust
+%endif
+%if 0%{?firefox_use_gtk3}
+ac_add_options --enable-default-toolkit=cairo-gtk3
+%else
+ac_add_options --enable-default-toolkit=cairo-gtk2
+%endif
+%if 0%{?build_hardened}
+ac_add_options --enable-pie
+%endif
+%ifarch %ix86 %arm
+%if 0%{?suse_version} > 1230
+ac_add_options --disable-optimize
+%endif
+%endif
+%ifarch ppc ppc64 ppc64le %arm
+ac_add_options --disable-elf-hack
+%endif
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+%if %{localize}
+ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
+%endif
+#ac_add_options --with-system-jpeg    # libjpeg-turbo is used internally
+#ac_add_options --with-system-png     # doesn't work because of missing APNG support
+ac_add_options --with-system-zlib
+ac_add_options --disable-updater
+ac_add_options --disable-tests
+ac_add_options --enable-alsa
+ac_add_options --disable-debug
+ac_add_options --enable-startup-notification
+#ac_add_options --enable-chrome-format=jar
+ac_add_options --enable-update-channel=%{update_channel}
+%if %branding
+ac_add_options --enable-official-branding
+%endif
+ac_add_options --enable-libproxy
+%if ! %crashreporter
+ac_add_options --disable-crashreporter
+%endif
+%ifarch %arm
+ac_add_options --with-fpu=vfpv3-d16
+ac_add_options --with-float-abi=hard
+ac_add_options --with-arch=armv7-a
+%endif
+%ifarch %arm s390x
+ac_add_options --disable-webrtc
+%endif
+EOF
+make -f client.mk build
+
+%install
+cd $RPM_BUILD_DIR/obj
+source %{SOURCE5}
+export MOZ_SOURCE_STAMP=$REV
+export MOZ_SOURCE_REPO=$REPO
+# need to remove default en-US firefox-l10n.js before it gets
+# populated into browser's omni.ja; it only contains general.useragent.locale
+# which should be loaded from each language pack (set in firefox.js)
+rm dist/bin/browser/defaults/preferences/firefox-l10n.js
+make -C browser/installer STRIP=/bin/true MOZ_PKG_FATAL_WARNINGS=0
+#DEBUG (break the build if searchplugins are missing / temporary)
+grep amazondotcom dist/firefox/browser/omni.ja
+# copy tree into RPM_BUILD_ROOT
+mkdir -p %{buildroot}%{progdir}
+cp -rf $RPM_BUILD_DIR/obj/dist/firefox/* %{buildroot}%{progdir}
+mkdir -p %{buildroot}%{progdir}/distribution/extensions
+mkdir -p %{buildroot}%{progdir}/browser/defaults/preferences/
+# install gre prefs
+install -m 644 %{SOURCE13} %{buildroot}%{progdir}/defaults/pref/
+# install browser prefs
+install -m 644 %{SOURCE6} %{buildroot}%{progdir}/browser/defaults/preferences/kde.js
+install -m 644 %{SOURCE9} %{buildroot}%{progdir}/browser/defaults/preferences/firefox.js
+# install additional locales
+%if %localize
+rm -f %{_tmppath}/translations.*
+touch %{_tmppath}/translations.{common,other}
+for locale in $(awk '{ print $1; }' %{SOURCE17}); do
+  case $locale in
+   ja-JP-mac|en-US|'')
+	;;
+   *)
+   	pushd $RPM_BUILD_DIR/compare-locales
+	PYTHONPATH=lib \
+	  scripts/compare-locales -m ../l10n-merged/$locale \
+	  ../mozilla/browser/locales/l10n.ini ../l10n $locale
+	popd
+	LOCALE_MERGEDIR=$RPM_BUILD_DIR/l10n-merged/$locale \
+  	make -C browser/locales langpack-$locale
+	cp -rL dist/xpi-stage/locale-$locale \
+	       %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org
+	# remove prefs, profile defaults, and hyphenation from langpack
+	rm -rf %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/defaults
+	rm -rf %{buildroot}%{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org/hyphenation
+	# check against the fixed common list and sort into the right filelist
+	_matched=0
+	for _match in ar ca cs da de en-GB el es-AR es-CL es-ES fi fr hu it ja ko nb-NO nl pl pt-BR pt-PT ru sv-SE zh-CN zh-TW; do
+	  [ "$_match" = "$locale" ] && _matched=1
+	done
+	[ $_matched -eq 1 ] && _l10ntarget=common || _l10ntarget=other
+  	echo %{progdir}/browser/extensions/langpack-$locale@firefox.mozilla.org \
+	  >> %{_tmppath}/translations.$_l10ntarget
+  esac
+done
+%endif
+# remove some executable permissions
+find %{buildroot}%{progdir} \
+     -name "*.js" -o \
+     -name "*.jsm" -o \
+     -name "*.rdf" -o \
+     -name "*.properties" -o \
+     -name "*.dtd" -o \
+     -name "*.txt" -o \
+     -name "*.xml" -o \
+     -name "*.css" | xargs chmod a-x
+# remove mkdir.done files from installed base
+find %{buildroot}%{progdir} -name ".mkdir.done" | xargs rm
+# overwrite the mozilla start-script and link it to /usr/bin
+mkdir --parents %{buildroot}/usr/bin
+sed "s:%%PREFIX:%{_prefix}:g
+s:%%PROGDIR:%{progdir}:g
+s:%%APPNAME:firefox:g
+s:%%PROFILE:.mozilla/firefox:g" \
+  %{SOURCE3} > %{buildroot}%{progdir}/%{progname}.sh
+chmod 755 %{buildroot}%{progdir}/%{progname}.sh
+ln -sf ../..%{progdir}/%{progname}.sh %{buildroot}%{_bindir}/%{progname}
+# desktop file
+mkdir -p %{buildroot}%{_datadir}/applications
+sed "s:%%NAME:%{appname}:g
+s:%%EXEC:%{progname}:g
+s:%%ICON:%{progname}:g" \
+  %{SOURCE1} > %{buildroot}%{_datadir}/applications/%{desktop_file_name}.desktop
+%suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
+# additional mime-types
+mkdir -p %{buildroot}%{_datadir}/mime/packages
+cp %{SOURCE8} %{buildroot}%{_datadir}/mime/packages/%{progname}.xml
+# appdata
+%if "%{update_channel}" != "aurora"
+mkdir -p %{buildroot}%{_datadir}/appdata
+cp %{SOURCE15} %{buildroot}%{_datadir}/appdata/%{desktop_file_name}.appdata.xml
+%endif
+# install man-page
+mkdir -p %{buildroot}%{_mandir}/man1/
+cp %{SOURCE11} %{buildroot}%{_mandir}/man1/%{progname}.1
+##########
+# ADDONS
+#
+mkdir -p %{buildroot}%{_datadir}/mozilla/extensions/%{firefox_appid}
+mkdir -p %{buildroot}%{_libdir}/mozilla/extensions/%{firefox_appid}
+mkdir -p %{buildroot}/usr/share/pixmaps/
+ln -sf %{progdir}/browser/icons/mozicon128.png %{buildroot}/usr/share/pixmaps/%{progname}.png
+ln -sf %{progdir}/browser/icons/mozicon128.png %{buildroot}/usr/share/pixmaps/%{progname}-gnome.png
+%if %branding
+for size in 16 22 24 32 48 256; do
+%else
+for size in 16 32 48; do
+%endif
+  mkdir -p %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/
+  cp %{buildroot}%{progdir}/browser/chrome/icons/default/default$size.png \
+         %{buildroot}%{gnome_dir}/share/icons/hicolor/${size}x${size}/apps/%{progname}.png
+done
+# excludes
+rm -f %{buildroot}%{progdir}/updater.ini
+rm -f %{buildroot}%{progdir}/removed-files
+rm -f %{buildroot}%{progdir}/README.txt
+rm -f %{buildroot}%{progdir}/old-homepage-default.properties
+rm -f %{buildroot}%{progdir}/run-mozilla.sh
+rm -f %{buildroot}%{progdir}/LICENSE
+rm -f %{buildroot}%{progdir}/precomplete
+rm -f %{buildroot}%{progdir}/dictionaries/en-US*
+rm -f %{buildroot}%{progdir}/update-settings.ini
+# devel
+mkdir -p %{buildroot}%{_bindir}
+install -m 755 %SOURCE12 %{buildroot}%{_bindir}
+# inspired by mandriva
+mkdir -p %{buildroot}%{_sysconfdir}/rpm
+cat <<'FIN' >%{buildroot}%{_sysconfdir}/rpm/macros.%{progname}
+# Macros from %{name} package
+%%firefox_major              %{major}
+%%firefox_version            %{version}
+%%firefox_mainver            %{mainver}
+%%firefox_mozillapath        %%{_libdir}/%{progname}
+%%firefox_pluginsdir         %%{_libdir}/browser-plugins
+%%firefox_appid              \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
+%%firefox_extdir             %%(if [ "%%_target_cpu" = "noarch" ]; then echo %%{_datadir}/mozilla/extensions/%%{firefox_appid}; else echo %%{_libdir}/mozilla/extensions/%%{firefox_appid}; fi)
+
+%%firefox_ext_install() \
+   extdir="%%{buildroot}%%{firefox_extdir}/`mozilla-get-app-id '%%1'`" \
+   mkdir -p "$extdir" \
+   %%{__unzip} -q -d "$extdir" "%%1" \
+   %%{nil}
+FIN
+# just dumping an xpi file there doesn't work...
+#%%firefox_ext_install() \
+#       extdir="%%{buildroot}%%{firefox_extdir}" \
+#       mkdir -p "$extdir" \
+#       cp "%%1" "$extdir" \
+#       %%{nil}
+# fdupes
+%fdupes %{buildroot}%{progdir}
+%fdupes %{buildroot}%{_datadir}
+# create breakpad debugsymbols
+%if %crashreporter
+SYMBOLS_NAME="firefox-%{version}-` echo '%{release}' | sed 's@\.[^\.]\+$@@' `.%{_arch}-%{suse_version}-symbols"
+make buildsymbols \
+  SYMBOL_INDEX_NAME="$SYMBOLS_NAME.txt" \
+  SYMBOL_FULL_ARCHIVE_BASENAME="$SYMBOLS_NAME-full" \
+  SYMBOL_ARCHIVE_BASENAME="$SYMBOLS_NAME"
+if [ -e dist/*symbols.zip ]; then
+  mkdir -p %{buildroot}%{_datadir}/mozilla/
+  cp dist/*symbols.zip %{buildroot}%{_datadir}/mozilla/
+fi
+%endif
+
+%clean
+rm -rf %{buildroot}
+%if %localize
+rm -rf %{_tmppath}/translations.*
+%endif
+
+%post
+# update mime and desktop database
+%mime_database_post
+%desktop_database_post
+%icon_theme_cache_post
+exit 0
+
+%postun
+%icon_theme_cache_postun
+%desktop_database_postun
+%mime_database_postun
+exit 0
+
+%files
+%defattr(-,root,root)
+%dir %{progdir}
+%dir %{progdir}/browser/
+%dir %{progdir}/browser/chrome/
+%dir %{progdir}/browser/extensions/
+%{progdir}/browser/defaults
+%{progdir}/browser/features/
+%{progdir}/browser/icons/
+%{progdir}/browser/chrome/icons
+%{progdir}/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
+%{progdir}/browser/blocklist.xml
+%{progdir}/browser/chrome.manifest
+%{progdir}/browser/omni.ja
+%dir %{progdir}/distribution/
+%{progdir}/distribution/extensions/
+%{progdir}/defaults/
+%{progdir}/dictionaries/
+%if 0%{?firefox_use_gtk3}
+%dir %{progdir}/gtk2
+%{progdir}/gtk2/libmozgtk.so
+%endif
+%{progdir}/gmp-clearkey/
+%attr(755,root,root) %{progdir}/%{progname}.sh
+%{progdir}/firefox
+%{progdir}/firefox-bin
+%{progdir}/application.ini
+%{progdir}/chrome.manifest
+%{progdir}/dependentlibs.list
+%{progdir}/icudt58l.dat
+%{progdir}/*.so
+%{progdir}/omni.ja
+%{progdir}/fonts/
+%{progdir}/platform.ini
+%{progdir}/plugin-container
+%if %crashreporter
+%{progdir}/crashreporter
+%{progdir}/crashreporter.ini
+%{progdir}/Throbber-small.gif
+%{progdir}/minidump-analyzer
+%{progdir}/browser/crashreporter-override.ini
+%endif
+%{_datadir}/applications/%{desktop_file_name}.desktop
+%{_datadir}/mime/packages/%{progname}.xml
+%{_datadir}/pixmaps/firefox*
+%dir %{_datadir}/mozilla
+%dir %{_datadir}/mozilla/extensions
+%dir %{_datadir}/mozilla/extensions/%{firefox_appid}
+%dir %{_libdir}/mozilla
+%dir %{_libdir}/mozilla/extensions
+%dir %{_libdir}/mozilla/extensions/%{firefox_appid}
+%{gnome_dir}/share/icons/hicolor/
+%{_bindir}/%{progname}
+%doc %{_mandir}/man1/%{progname}.1.gz
+%if "%{update_channel}" != "aurora"
+%{_datadir}/appdata/
+%endif
+
+%files devel
+%defattr(-,root,root)
+%{_bindir}/mozilla-get-app-id
+%config %{_sysconfdir}/rpm/macros.%{progname}
+
+%if %localize
+
+%files translations-common -f %{_tmppath}/translations.common
+%defattr(-,root,root)
+%dir %{progdir}
+%dir %{progdir}/browser/extensions/
+
+%files translations-other -f %{_tmppath}/translations.other
+%defattr(-,root,root)
+%dir %{progdir}
+%dir %{progdir}/browser/extensions/
+%endif
+
+# this package does not need to provide files but is needed to fulfill
+# requirements if no other branding package is to be installed
+%if %branding
+%files branding-upstream
+%defattr(-,root,root)
+%dir %{progdir}
+%endif
+
+%if %crashreporter
+%files buildsymbols
+%defattr(-,root,root)
+%{_datadir}/mozilla/*.zip
+%endif
+
+%changelog