MozillaFirefox/MozillaFirefox.spec
branchfirefox112
changeset 1188 a2caa2a2494f
parent 1187 17bc5a064ab4
child 1189 ba0c97b018a6
--- a/MozillaFirefox/MozillaFirefox.spec	Mon Apr 10 23:42:16 2023 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Tue May 09 23:09:18 2023 +0200
@@ -28,9 +28,9 @@
 # orig_suffix b3
 # major 69
 # mainver %%major.99
-%define major          111
-%define mainver        %major.0.1
-%define orig_version   111.0.1
+%define major          112
+%define mainver        %major.0.2
+%define orig_version   112.0.2
 %define orig_suffix    %{nil}
 %define update_channel release
 %define branding       1
@@ -120,17 +120,23 @@
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
 BuildRequires:  mozilla-nspr-devel >= 4.35
-BuildRequires:  mozilla-nss-devel >= 3.88.1
+BuildRequires:  mozilla-nss-devel >= 3.89
 BuildRequires:  nasm >= 2.14
 BuildRequires:  nodejs >= 10.22.1
 %if 0%{?sle_version} >= 120000 && 0%{?sle_version} < 150000
 BuildRequires:  python-libxml2
 BuildRequires:  python36
 %else
-BuildRequires:  python3 >= 3.5
+%if 0%{?sle_version} >= 150000 && 0%{?sle_version} <= 150500
+BuildRequires:  python39
+BuildRequires:  python39-curses
+BuildRequires:  python39-devel
+%else
+BuildRequires:  python3 >= 3.7
 BuildRequires:  python3-curses
 BuildRequires:  python3-devel
 %endif
+%endif
 BuildRequires:  rust-cbindgen >= 0.24.3
 BuildRequires:  unzip
 BuildRequires:  update-desktop-files
@@ -228,7 +234,6 @@
 Patch25:        one_swizzle_to_rule_them_all.patch
 Patch26:        svg-rendering.patch
 Patch27:        mozilla-buildfixes.patch
-Patch28:        mozilla-bmo1807652.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-branded-icons.patch
@@ -247,7 +252,7 @@
 %if 0%{?devpkg} == 0
 Obsoletes:      %{name}-devel < %{version}
 %endif
-ExcludeArch:    armv6l armv6hl ppc ppc64 ppc64le %ix86
+ExcludeArch:    armv6l armv6hl ppc ppc64 ppc64le
 
 %description
 Mozilla Firefox is a standalone web browser, designed for standards
@@ -396,6 +401,10 @@
 export CFLAGS="\$CFLAGS -mminimal-toc"
 %endif
 %endif
+%ifarch %ix86
+# Not enough memory on 32-bit systems, reduce debug info.
+export CFLAGS="\$CFLAGS -g1"
+%endif
 export CXXFLAGS="\$CFLAGS"
 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
 EOF
@@ -618,7 +627,8 @@
 mkdir -p %{buildroot}%{_datadir}/applications
 sed "s:%%NAME:%{appname}:g
 s:%%EXEC:%{progname}:g
-s:%%ICON:%{progname}:g" \
+s:%%ICON:%{progname}:g
+s:%%WMCLASS:%{progname}%{major}:g" \
   %{SOURCE1} > %{buildroot}%{_datadir}/applications/%{desktop_file_name}.desktop
 %suse_update_desktop_file %{desktop_file_name} Network WebBrowser GTK
 # additional mime-types