MozillaFirefox/MozillaFirefox.spec
branchfirefox87
changeset 1156 c3d884659acf
parent 1155 b8c834aafde2
child 1157 57fc0524b50c
--- a/MozillaFirefox/MozillaFirefox.spec	Wed Mar 17 12:24:14 2021 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Sat Mar 27 21:45:50 2021 +0100
@@ -44,13 +44,23 @@
 %define do_profiling   0
 
 # upstream default is clang (to use gcc for large parts set to 0)
-%define clang_build 0
+%define clang_build    1
+%if 0%{?is_opensuse} && 0%{?suse_version} >= 1550
+%ifarch x86_64
+# on Tumbleweed/x86_64 this does not work due to undefined
+#  references to `__rust_probestack'
+%define clang_build    0
+%endif
+%endif
 
 # PIE, full relro
 %define build_hardened 1
 
 %bcond_with only_print_mozconfig
 
+# define if ccache should be used or not
+%define useccache     1
+
 # Firefox only supports i686
 %ifarch %ix86
 ExclusiveArch:  i586 i686
@@ -96,7 +106,9 @@
 BuildRequires:  gcc-c++
 %endif
 BuildRequires:  cargo >= 1.47
+%if 0%{useccache} != 0
 BuildRequires:  ccache
+%endif
 BuildRequires:  libXcomposite-devel
 BuildRequires:  libcurl-devel
 BuildRequires:  libidl-devel
@@ -455,7 +467,9 @@
 #%endif
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
+%if 0%{useccache} != 0
 ac_add_options --with-ccache
+%endif
 %if %{localize}
 ac_add_options --with-l10n-base=$RPM_BUILD_DIR/l10n
 %endif
@@ -505,7 +519,9 @@
 %endif
 EOF
 %if !%{with only_print_mozconfig}
+%if 0%{useccache} != 0
 ccache -s
+%endif
 %if 0%{?do_profiling}
 xvfb-run --server-args="-screen 0 1920x1080x24" \
 %endif
@@ -560,8 +576,10 @@
 ' -- {}
 %endif
 
+%if 0%{useccache} != 0
 ccache -s
 %endif
+%endif
 
 %install
 cd $RPM_BUILD_DIR/obj