Home > Mozilla, SUSE > XULRunner 1.9 / Firefox 3.0b3

XULRunner 1.9 / Firefox 3.0b3

February 29th, 2008

Over the last days I was working on preparing and polishing a XULRunner 1.9 package for openSUSE. It’s now available in the mozilla:beta buildservice repository. Some news of interest for developers using Mozilla technologies can be found here.

(Just a sidenote on what I’ve read yesterday: “Not only will Firefox 3 be the first release of the popular browser to use XulRunner as its back end, but upcoming releases of GNOME-based distros such as Fedora and Ubuntu are expected to install XulRunner by default as well”. I can only say that openSUSE is shipping, installing and actually using XULRunner since version 10.1)

Just a few minutes ago I also finished the first step in redesigning the Firefox 3.0b3 package I’ve been providing in the same repository. You’ll find that it is much smaller (the base package is < 1MB) as it's based on the XULRunner infrastructure now. That is quite a massive change and I don't know yet if it works well. Nevertheless I decided to publish that package so that people subscribed to the repo will get it when they update their packages. We need broad testing of that package since it is planned to ship that way in openSUSE 11.0. So everyone please report bugs you encounter when switching to that (preferably in Bugzilla).

Share
Categories: Mozilla, SUSE Tags:
  1. Aslash
    March 1st, 2008 at 12:37 | #1

    Sorry for posting here, i’m a little newbie at this things and don’t know where fits better…
    i was trying firefox 3 beta3 from your mozilla:beta repository, and after upgrading from one version to another (2.9.93-2 to 2.9.93-3 or 2.9.93-10) the uninstallation of old packeges fails and in yast seems that i have now 4 firefox installed simultaneously…
    i’m using 10.3 on a 32bit system, i will give you any other information needed. thanks!

  2. March 1st, 2008 at 17:20 | #2

    Aslash, there was a bug in the package recently which caused the removal to fail. You can remove the packages with “rpm -e –noscripts PACKAGE”. You probably want to remove all of them and install the latest one afterwards.

  3. Aslash
    March 2nd, 2008 at 00:55 | #3

    thank tou so much… worked perfectly!
    now i’ve got my shiny new beta3 installed 🙂

  4. Pete Herworth
    March 6th, 2008 at 00:48 | #4

    There are 2 packages in the beta – Mozilla Firefox 2.9.93-32 and a more recent firefox 2.9.93-10.
    A bit confusing and the more recent is a bigger download.
    Is there a reason for this? Have I got it wrong?

  5. Rubal
    March 6th, 2008 at 11:53 | #5

    hi , i just read abt this new firefox. how can i insatll it using zypper command

    coz i m new to linux and when i try to install rpms ,, it gives lots of missing dependencies

  6. March 6th, 2008 at 16:40 | #6

    Pete, the “more” recent firefox is a real 3.0b3 which is provided for people using for example mixed arch installations. It doesn’t have requirements to NSPR, NSS and XULRunner because it’s a complete package. The other MozillaFirefox package is actually almost a 3.0b4 but needs NSPR, NSS and mozilla-xulrunner190 in the right architectures installed. Unfortunately the buildservice is not yet ready to provide baselibs (-32bit) packages and so I decided to create the “firefox” alternative for now.

  7. Vadym
    March 12th, 2008 at 11:53 | #7

    Strange, the “standalone” firefox-2.9.94-2.1.i586.rpm package for openSUSE 10.3 won’t install on openSUSE 10.3 for x86_64 unless both mozilla-nss-3.12.0-12.1.i586.rpm and mozilla-xulrunner190-1.8.99.4-2.1.i586.rpm are installed. Which is a blocker as these conflict with the standard 32-bit baselibs packages. And even if I manually extract the right files from the firefox rpm, then firefox does not start because the firefox binary still depends on libs from /usr/lib/xulrunner-1.9/. So there is a dependency on xulrunner … Manually extracting xulrunner files into the right place does not solve the problem because
    firefox.sh does not add /usr/lib/xulrunner-1.9/ to LD_LIBRARY_PATH …

  8. March 12th, 2008 at 12:12 | #8

    Vadym, I don’t see why it should depend on NSPR, NSS and xulrunner. Please send me a PM or open a bug in bugzilla.novell.com and I’ll get it.

  9. Vadym
    March 13th, 2008 at 17:49 | #9

    Hi Wolfgang,

    this is what happens when I try to install the firefox package manually on openSUSE 10.3 for x86-64:
    stal-dev-lx1:/var/lib/smart/packages # rpm -q firefox
    package firefox is not installed
    stal-dev-lx1:/var/lib/smart/packages # rpm -ivh firefox-2.9.94-2.1.i586.rpm
    error: Failed dependencies:
    libjemalloc.so is needed by firefox-2.9.94-2.1.i586

    libjemalloc.so is provided by the xulrunner package, and that one depends on the mozilla-nss package.

  10. March 13th, 2008 at 20:08 | #10

    Ahh, that was an issue in one of the earlier builds. Please get the latest one. It has libjemalloc.so built in.

Comments are closed.