Add conditional for pkgconfig(gconf-2.0) BuildRequires, and pass
author<bjorn.lie@gmail.com>
Fri, 08 Jun 2018 22:31:03 +0200
changeset 1054 fbfe323c62cd
parent 1053 893fc4d031d6
child 1055 526f445635f3
Add conditional for pkgconfig(gconf-2.0) BuildRequires, and pass
conditional --disable-gconf to configure: no longer pull in
obsolete gconf2 for Tumbleweed.
MozillaFirefox/MozillaFirefox.changes
MozillaFirefox/MozillaFirefox.spec
--- a/MozillaFirefox/MozillaFirefox.changes	Fri Jun 08 22:25:59 2018 +0200
+++ b/MozillaFirefox/MozillaFirefox.changes	Fri Jun 08 22:31:03 2018 +0200
@@ -1,4 +1,17 @@
 -------------------------------------------------------------------
+Fri Jun  8 20:27:46 UTC 2018 - wr@rosenauer.org
+
+- update to Firefox 61.0b12
+- requires NSS 3.37.3
+
+-------------------------------------------------------------------
+Fri Jun  1 10:52:13 UTC 2018 - bjorn.lie@gmail.com
+
+- Add conditional for pkgconfig(gconf-2.0) BuildRequires, and pass
+  conditional --disable-gconf to configure: no longer pull in
+  obsolete gconf2 for Tumbleweed.
+
+-------------------------------------------------------------------
 Thu Jun  7 12:11:06 UTC 2018 - wr@rosenauer.org
 
 - update to Firefox 60.0.2
--- a/MozillaFirefox/MozillaFirefox.spec	Fri Jun 08 22:25:59 2018 +0200
+++ b/MozillaFirefox/MozillaFirefox.spec	Fri Jun 08 22:31:03 2018 +0200
@@ -84,7 +84,9 @@
 BuildRequires:  xorg-x11-libXt-devel
 BuildRequires:  yasm
 BuildRequires:  zip
+%if 0%{?suse_version} < 1550
 BuildRequires:  pkgconfig(gconf-2.0)
+%endif
 BuildRequires:  pkgconfig(gdk-x11-2.0)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.22
 BuildRequires:  pkgconfig(gobject-2.0)
@@ -340,6 +342,9 @@
 ac_add_options --includedir=%{_includedir}
 ac_add_options --enable-release
 ac_add_options --enable-default-toolkit=cairo-gtk3
+%if 0%{?suse_version} >= 1550
+ac_add_options --disable-gconf
+%endif
 %if 0%{?build_hardened}
 ac_add_options --enable-pie
 %endif