MozillaFirefox/MozillaFirefox.spec
branchfirefox65
changeset 1085 87f893cf45b9
parent 1084 b0b3c507e253
child 1086 ed1c30c5f456
equal deleted inserted replaced
1084:b0b3c507e253 1085:87f893cf45b9
     1 #
     1 #
     2 # spec file for package MozillaFirefox
     2 # spec file for package MozillaFirefox
     3 #
     3 #
     4 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
     4 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
     5 #               2006-2018 Wolfgang Rosenauer
     5 #               2006-2019 Wolfgang Rosenauer
     6 #
     6 #
     7 # All modifications and additions to the file contributed by third parties
     7 # All modifications and additions to the file contributed by third parties
     8 # remain the property of their copyright owners, unless otherwise agreed
     8 # remain the property of their copyright owners, unless otherwise agreed
     9 # upon. The license for this file, and modifications and additions to the
     9 # upon. The license for this file, and modifications and additions to the
    10 # file, is the same license as for the pristine package itself (unless the
    10 # file, is the same license as for the pristine package itself (unless the
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via https://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 # changed with every update
    20 # changed with every update
    21 %define major          64
    21 %define major          65
    22 %define mainver        %major.0.2
    22 %define mainver        %major.0
    23 %define orig_version   64.0.2
    23 %define orig_version   65.0
    24 %define orig_suffix    %{nil}
    24 %define orig_suffix    %{nil}
    25 %define update_channel release
    25 %define update_channel release
    26 %define branding       1
    26 %define branding       1
    27 %define releasedate    20190108160530
    27 %define releasedate    20190124174741
    28 %define source_prefix  firefox-%{orig_version}
    28 %define source_prefix  firefox-%{orig_version}
    29 
    29 
    30 # always build with GCC as SUSE Security Team requires that
    30 # always build with GCC as SUSE Security Team requires that
    31 %define clang_build 0
    31 %define clang_build 0
    32 
    32 
    67 %if 0%{?suse_version} <= 1320
    67 %if 0%{?suse_version} <= 1320
    68 BuildRequires:  gcc7-c++
    68 BuildRequires:  gcc7-c++
    69 %else
    69 %else
    70 BuildRequires:  gcc-c++
    70 BuildRequires:  gcc-c++
    71 %endif
    71 %endif
    72 BuildRequires:  cargo >= 1.29
    72 BuildRequires:  cargo >= 1.30
    73 BuildRequires:  libXcomposite-devel
    73 BuildRequires:  libXcomposite-devel
    74 BuildRequires:  libcurl-devel
    74 BuildRequires:  libcurl-devel
    75 BuildRequires:  libidl-devel
    75 BuildRequires:  libidl-devel
    76 BuildRequires:  libiw-devel
    76 BuildRequires:  libiw-devel
    77 BuildRequires:  libnotify-devel
    77 BuildRequires:  libnotify-devel
    78 BuildRequires:  libproxy-devel
    78 BuildRequires:  libproxy-devel
    79 BuildRequires:  makeinfo
    79 BuildRequires:  makeinfo
    80 BuildRequires:  mozilla-nspr-devel >= 4.20
    80 BuildRequires:  mozilla-nspr-devel >= 4.20
    81 BuildRequires:  mozilla-nss-devel >= 3.40.1
    81 BuildRequires:  mozilla-nss-devel >= 3.41
    82 BuildRequires:  nodejs8 >= 8.11
    82 BuildRequires:  nodejs8 >= 8.11
    83 BuildRequires:  python-devel
    83 BuildRequires:  python-devel
    84 BuildRequires:  python2-xml
    84 BuildRequires:  python2-xml
    85 BuildRequires:  python3 >= 3.5
    85 BuildRequires:  python3 >= 3.5
    86 BuildRequires:  rust >= 1.29
    86 BuildRequires:  rust >= 1.30
    87 BuildRequires:  rust-cbindgen >= 0.6.4
    87 BuildRequires:  rust-cbindgen >= 0.6.7
    88 BuildRequires:  startup-notification-devel
    88 BuildRequires:  startup-notification-devel
    89 BuildRequires:  unzip
    89 BuildRequires:  unzip
    90 BuildRequires:  update-desktop-files
    90 BuildRequires:  update-desktop-files
    91 BuildRequires:  xorg-x11-libXt-devel
    91 BuildRequires:  xorg-x11-libXt-devel
    92 BuildRequires:  yasm
    92 BuildRequires:  yasm