xulrunner/xulrunner.spec
branchfirefox16
changeset 535 cba7622bad5d
parent 533 6bcb1bfae08e
child 539 b1134fe91f9a
child 542 890521f49a09
equal deleted inserted replaced
533:6bcb1bfae08e 535:cba7622bad5d
    85 ### build configuration ###
    85 ### build configuration ###
    86 %define has_system_nspr  1
    86 %define has_system_nspr  1
    87 %define has_system_nss   1
    87 %define has_system_nss   1
    88 %define has_system_cairo 0
    88 %define has_system_cairo 0
    89 %define localize 0
    89 %define localize 0
    90 %ifarch ppc ppc64 s390 s390x ia64
    90 %ifarch ppc ppc64 s390 s390x ia64 %arm
    91 %define crashreporter    0
    91 %define crashreporter    0
    92 %else
    92 %else
    93 %define crashreporter    1
    93 %define crashreporter    1
    94 %endif
    94 %endif
    95 ### configuration end ###
    95 ### configuration end ###
   205 export MOZ_BUILD_DATE=%{releasedate}
   205 export MOZ_BUILD_DATE=%{releasedate}
   206 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   206 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   207 %ifarch ppc64
   207 %ifarch ppc64
   208 export CFLAGS="$CFLAGS -mminimal-toc"
   208 export CFLAGS="$CFLAGS -mminimal-toc"
   209 %endif
   209 %endif
       
   210 export LDFLAGS=" -Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   211 %ifarch %arm
       
   212 # debug symbols require too much memory during build
       
   213 export CFLAGS="${CFLAGS/-g/}"
       
   214 LDFLAGS+="-Wl,--reduce-memory-overheads -Wl,--no-keep-memory"
       
   215 %endif
   210 export CXXFLAGS="$CFLAGS"
   216 export CXXFLAGS="$CFLAGS"
   211 export LDFLAGS="-Wl,-rpath -Wl,${MOZ_APP_DIR}"
       
   212 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   217 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   213 export MOZILLA_OFFICIAL=1
   218 export MOZILLA_OFFICIAL=1
   214 export BUILD_OFFICIAL=1
   219 export BUILD_OFFICIAL=1
   215 export MOZ_MILESTONE_RELEASE=1
   220 export MOZ_MILESTONE_RELEASE=1
   216 #
   221 #
   280 EOF
   285 EOF
   281 %endif
   286 %endif
   282 # ARM
   287 # ARM
   283 %ifarch %arm
   288 %ifarch %arm
   284 cat << EOF >> $MOZCONFIG
   289 cat << EOF >> $MOZCONFIG
   285 %ifarch armv7l
   290 %ifarch armv7l armv7hl
   286 ac_add_options --with-arch=armv7-a
   291 ac_add_options --with-arch=armv7-a
   287 ac_add_options --with-float-abi=hard
   292 ac_add_options --with-float-abi=hard
   288 ac_add_options --with-fpu=vfpv3-d16
   293 ac_add_options --with-fpu=vfpv3-d16
   289 ac_add_options --with-thumb=yes
   294 ac_add_options --with-thumb=yes
       
   295 ac_add_options --disable-debug
   290 %endif
   296 %endif
   291 %ifarch armv5tel
   297 %ifarch armv5tel
   292 ac_add_options --with-arch=armv5te
   298 ac_add_options --with-arch=armv5te
   293 ac_add_options --with-float-abi=soft
   299 ac_add_options --with-float-abi=soft
   294 ac_add_options --with-thumb=no
   300 ac_add_options --with-thumb=no