MozillaFirefox/MozillaFirefox.spec
branchfirefox19
changeset 631 e5ead5bc3360
parent 623 9bf0a4872e3d
child 633 7c6f56a37ed6
equal deleted inserted replaced
623:9bf0a4872e3d 631:e5ead5bc3360
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    16 # Please submit bugfixes or comments via http://bugs.opensuse.org/
    17 #
    17 #
    18 
    18 
    19 
    19 
    20 %define major 19
    20 %define major 19
    21 %define mainver %major.0.1
    21 %define mainver %major.0.2
    22 %define update_channel release
    22 %define update_channel release
    23 
    23 
    24 Name:           MozillaFirefox
    24 Name:           MozillaFirefox
    25 BuildRequires:  Mesa-devel
    25 BuildRequires:  Mesa-devel
    26 BuildRequires:  autoconf213
    26 BuildRequires:  autoconf213
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    52 BuildRequires:  pkgconfig(gstreamer-app-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    53 BuildRequires:  pkgconfig(gstreamer-plugins-base-0.10)
    54 %endif
    54 %endif
    55 Version:        %{mainver}
    55 Version:        %{mainver}
    56 Release:        0
    56 Release:        0
    57 %define         releasedate 2013022700
    57 %define         releasedate 2013030600
    58 Provides:       firefox = %{mainver}
    58 Provides:       firefox = %{mainver}
    59 Provides:       firefox = %{version}-%{release}
    59 Provides:       firefox = %{version}-%{release}
    60 Provides:       web_browser
    60 Provides:       web_browser
    61 Provides:       browser(npapi)
    61 Provides:       browser(npapi)
    62 # this is needed to match this package with the kde4 helper package without the main package
    62 # this is needed to match this package with the kde4 helper package without the main package
   266 export MOZ_BUILD_DATE=%{releasedate}
   266 export MOZ_BUILD_DATE=%{releasedate}
   267 export MOZILLA_OFFICIAL=1
   267 export MOZILLA_OFFICIAL=1
   268 export BUILD_OFFICIAL=1
   268 export BUILD_OFFICIAL=1
   269 export MOZ_TELEMETRY_REPORTING=1
   269 export MOZ_TELEMETRY_REPORTING=1
   270 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
   270 export CFLAGS="$RPM_OPT_FLAGS -Os -fno-strict-aliasing"
       
   271 %ifarch %arm
       
   272 export CFLAGS="${CFLAGS/-g/}"
       
   273 %endif
   271 %ifarch ppc64
   274 %ifarch ppc64
   272 export CFLAGS="$CFLAGS -mminimal-toc"
   275 export CFLAGS="$CFLAGS -mminimal-toc"
   273 %endif
   276 %endif
   274 export CXXFLAGS="$CFLAGS"
   277 export CXXFLAGS="$CFLAGS"
   275 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   278 export MOZCONFIG=$RPM_BUILD_DIR/mozconfig
   326 %endif
   329 %endif
   327 # Disable neon for arm as it does not build correctly
   330 # Disable neon for arm as it does not build correctly
   328 %ifarch %arm
   331 %ifarch %arm
   329 cat << EOF >> $MOZCONFIG
   332 cat << EOF >> $MOZCONFIG
   330 ac_add_options --disable-neon
   333 ac_add_options --disable-neon
       
   334 ac_add_options --disable-webrtc
   331 EOF
   335 EOF
   332 %endif
   336 %endif
   333 make -f client.mk build
   337 make -f client.mk build
   334 
   338 
   335 %install
   339 %install