MozillaFirefox/MozillaFirefox.spec
changeset 1044 142a0c92607c
parent 1043 5ba4fbb8bed7
child 1045 f645c886d36b
--- a/MozillaFirefox/MozillaFirefox.spec	Tue Mar 13 20:14:45 2018 +0100
+++ b/MozillaFirefox/MozillaFirefox.spec	Sun Apr 01 23:51:44 2018 +0200
@@ -19,10 +19,10 @@
 
 # changed with every update
 %define major 59
-%define mainver %major.0
-%define update_channel release
+%define mainver %major.99
+%define update_channel beta
 %define branding 1
-%define releasedate 20180310025718
+%define releasedate 20180323154952
 
 # PIE, full relro (x86_64 for now)
 %define build_hardened 1
@@ -70,11 +70,11 @@
 BuildRequires:  libnotify-devel
 BuildRequires:  libproxy-devel
 BuildRequires:  makeinfo
-BuildRequires:  mozilla-nspr-devel >= 4.18
-BuildRequires:  mozilla-nss-devel >= 3.35
+BuildRequires:  mozilla-nspr-devel >= 4.19
+BuildRequires:  mozilla-nss-devel >= 3.36
 BuildRequires:  python-devel
 BuildRequires:  python2-xml
-BuildRequires:  rust >= 1.22.1
+BuildRequires:  rust >= 1.24
 BuildRequires:  rust-std
 BuildRequires:  startup-notification-devel
 BuildRequires:  unzip
@@ -150,6 +150,9 @@
 Patch6:         mozilla-reduce-files-per-UnifiedBindings.patch
 Patch7:         mozilla-aarch64-startup-crash.patch
 Patch8:         mozilla-bmo256180.patch
+Patch9:         mozilla-bmo1005535.patch
+Patch10:        mozilla-i586-DecoderDoctorLogger.patch
+Patch11:        mozilla-i586-domPrefs.patch
 # Firefox/browser
 Patch101:       firefox-kde.patch
 Patch102:       firefox-branded-icons.patch
@@ -260,6 +263,11 @@
 %endif
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
+%ifarch %ix86
+%patch10 -p1
+%patch11 -p1
+%endif
 # Firefox
 %patch101 -p1
 %patch102 -p1
@@ -333,7 +341,7 @@
 ac_add_options --disable-optimize
 %endif
 %endif
-%ifarch ppc ppc64 ppc64le %arm
+%ifarch %arm
 ac_add_options --disable-elf-hack
 %endif
 ac_add_options --with-system-nspr